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Stap over van papier naar CAD





Tekenen op schaal

Bij de lay-out van uw tekening is de schaal van belang. In CAD wordt de schaal anders bepaald dan 
bij tekenen met de hand.

Bij handmatig tekenen moet 
u voordat u begint, de schaal 
van een aanzicht bepalen. 
Deze schaal vergelijkt de 
grootte van het eigenlijke 
object met de grootte van het 
model op papier.

Bij AutoCAD en AutoCAD LT 
bepaalt u eerst de gewenste 
maateenheid, waarna u uw 
model op een schaal van 1:1 
tekent.

Tekent u bijvoorbeeld een motoronderdeel, 
dan zou de lengte van één eenheid gelijk 
kunnen zijn aan een millimeter of een inch. 
Wanneer u een kaart tekent, zou één eenheid 
gelijk kunnen zijn aan een kilometer of een 
mijl.

Bij deze tekening van een gemechaniseerd 
voertuig wordt de lengte van één eenheid in 
millimeters uitgedrukt. Aanzichten van het 
onderdeel werden later geschaald om de lay-
out voor de gedrukte tekening te maken.

Teken het object op een schaal van 1:1 in de 
gewenste eenheid

Wanneer u uw tekening indeelt en plot, kunt u 
een willekeurige schaal opgeven.
Tekenen op schaal | 3





Een tekening indelen

Op papier wordt een lay-out beperkt door het papierformaat dat u gebruikt. In CAD bent u niet tot 
een bepaalde lay-out of bepaald papierformaat beperkt.

Tekent u met de hand, dan 
selecteert u eerst een vel papier, 
dat meestal een voorgedrukte 
rand en een titelblok bevat. 
Vervolgens bepaalt u de locatie 
voor aanzichten: plattegronden, 
hoogten, doorsneden en details. 
Daarna begint u pas met tekenen.

Bij AutoCAD en AutoCAD LT 
tekent u eerst uw ontwerp, of 
model, in een werkomgeving, 
werkvlak genaamd. Daarna kunt u een lay-out voor 
dat model maken in de omgeving die papierkader 
wordt genoemd.

Een lay-out stelt een tekenblad voor, en bevat 
meestal een rand, titelblok, bematingen, algemene 
notities en een of meer aanzichten van het model 
dat in lay-outvensters wordt weergegeven. 
Lay-outvensters zijn gebieden, zoals fotolijsten of 
vensters, waardoorheen u uw model kunt zien. 
U schaalt de aanzichten in vensters door in- of uit 
te zoomen.

In deze tekening van een huisje wordt het model in 
plattegrond- en hoogteaanzicht weergegeven.

U maakt uw basisontwerp, of model, 
in een tekengebied dat werkvlak 
wordt genoemd.

Wanneer u klaar bent om af te drukken, kunt u 
verschillende aanzichten van uw model 
rangschikken in een lay-out
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Tekeninggegevens organiseren

Bij handmatig tekenen en in CAD hebt u een methode nodig om uw tekeninginhoud te organiseren: 
een methode om specifieke tekeninggegevens te verdelen, sorteren en bewerken.

Bij handmatig tekenen kunt u gegevens over 
verschillende transparante overlays verdelen. 
Een bouwplan kan bijvoorbeeld aparte 
overlays bevatten voor zijn structurele, 
elektrische en sanitaire onderdelen.

Bij AutoCAD en AutoCAD LT zijn lagen 
hetzelfde als transparante overlays. Net als bij 
overlays kunt u lagen apart of in combinatie 
weergeven, bewerken en afdrukken.

U kunt lagen benoemen om inhoud te traceren, en 
vergrendelen zodat ze niet veranderd kunnen worden. Wanneer 
u instellingen zoals kleur, lijntype of lijndikte aan lagen toewijst, 
is het gemakkelijker om aan industriestandaarden te voldoen.

U kunt lagen ook gebruiken om tekenobjecten voor plotten te 
organiseren. Wanneer u een plotstijl aan een laag toewijst, 
worden alle objecten die op die laag getekend zijn, op 
gelijksoortige wijze geplot.

Bij deze tekening van een pers worden lagen gebruikt om 
verschillende lijntypen en kleuren te definiëren.

Lagen uitschakelen om 
complexe details te verbergen 
terwijl u werkt

Lagen weergeven wanneer u 
alle componenten moet zien
Tekeninggegevens organiseren | 7





Een ontwerpnormblad vaststellen

Of u nu als lid van een team of aan een eigen project werkt, normen vaststellen is een vereiste voor 
efficiënte communicatie.

Bij handmatig tekenen is grote 
precisie vereist om bijvoorbeeld 
lijntypen, lijndikten, tekst en 
bematingen te tekenen. Normen 
moeten vanaf het begin worden 
vastgesteld en consequent worden 
toegepast.

Met AutoCAD en AutoCAD LT kunt u 
naleving van industrie- of 
bedrijfsstandaarden verzekeren door 
stijlen te maken die u consequent 
kunt toepassen.

U kunt stijlen maken voor tekst, bematingen en 
lijntypen. Bij een tekststijl worden bijvoorbeeld 
lettertype- en opmaakkenmerken bepaald zoals hoogte, 
breedte en helling.

In tekeningsjabloonbestanden kunt u stijlen, lagen, 
lay-outs, titelblok- en randgegevens, en bepaalde 
opdrachtinstellingen opslaan. Met behulp van 
sjablonen kunt u snel nieuwe tekeningen starten die 
aan standaarden voldoen.

Bij deze tekening van een wegplan worden stijlen 
gebruikt om ontwerpstandaarden voor tekst, bemating 
en lijntypen te handhaven.

Bemating, tekst en lijntypestijlen kunnen 
in een sjabloontekening worden 
vastgesteld en voor het maken van 
nieuwe tekeningen worden gebruikt.
Een ontwerpnormblad vaststellen | 9





Efficiënt tekenen

Met minder inspanning tekenen en met meer snelheid herzien: dit zijn twee hoofdredenen om CAD 
te gebruiken. U krijgt een volledige set teken- en bewerkingstools om steeds terugkerende, 
tijdrovende tekentaken te elimineren.

Bij handmatig tekenen gebruikt u 
tekengerei zoals potloden, meetlatten, 
passers, parallelle linialen, sjablonen en 
een gum. Terugkerende teken- en 
bewerkingstaken moeten handmatig 
worden uitgevoerd.

In AutoCAD en AutoCAD LT hebt u de 
keus uit verschillende tekentools 
waarmee u lijnen, cirkels, spline-
krommen enzovoort kunt maken.

U kunt moeiteloos objecten verplaatsen, kopiëren, 
verschuiven, roteren en spiegelen, evenals objecten 
tussen geopende tekeningen kopiëren.

In deze tekening van een tram werden vaak 
voorkomende en symmetrische elementen met behulp 
van kopiëren en spiegelen gemaakt. Verschuiving werd 
ook gebruikt om parallelle lijnen efficiënter te trekken.

U kunt tekentijd besparen door één helft van 
een item te tekenen en het dan te spiegelen 
om de andere helft te maken
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Accuraat tekenen

Voor technische en bouwkundige tekeningen is een hoge mate van precisie vereist. Met CAD kunt 
u nauwkeuriger ontwerpen dan met handmatige methoden.

Bij handmatig tekenen moet u 
objecten zorgvuldig tekenen om 
juiste grootte en uitlijning te 
verkrijgen. Objecten die op schaal 
zijn getekend, moeten handmatig 
geverifieerd en bemaat worden.

Met AutoCAD en AutoCAD LT kunt 
u verschillende methoden gebruiken 
om exacte bematingen te verkrijgen.

De eenvoudigste manier is punten te 
vinden door naar een interval op een 
rechthoekig raster te springen.

U kunt ook exacte coördinaten opgeven. Coördinaten 
specificeren locatie op de tekening door een punt 
langs een X- en Y-as aan te geven, of een afstand en 
hoek vanaf een ander punt.

Met objectmagneten kunt u naar locaties op bestaande 
objecten springen, zoals een eindpunt van een boog, 
het middelpunt van een lijn of het hartpunt van een 
cirkel.

Met polaire tracking kunt u naar eerder ingestelde 
hoeken springen en afstanden langs die hoeken 
opgeven.

In deze tekening van een pompstation werden 
objectmagneten gebruikt om te verzekeren dat de lijnen 
perfect werden verbonden. Polaire tracking werd 
gebruikt om lijnen met de juiste hoek te trekken.

Met polaire tracking 
worden er visuele 
richtlijnen bij specifieke 
hoeken weergegeven en 

Wanneer u uw 
cursor hier 
neerzet...

kunt u met 
objectmagneten 
automatisch naar 
het hartpunt 
springen.
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Uw tekening bekijken

Dankzij de kracht van CAD kunt u moeiteloos snel verschillende delen van uw ontwerp bij 
verschillende vergrotingen bekijken.

Bij handmatig tekenen zijn de 
grootte en resolutie van uw 
tekening vastgesteld.

Met AutoCAD en AutoCAD LT 
kunnen de grootte en resolutie 
van uw tekening naar wens 
worden gewijzigd.

Voor detailwerk kunt u de 
weergave groter maken door in 
te zoomen. U kunt uitzoomen 
om meer van de tekening te laten zien. Wilt u een 
ander deel van een tekening bekijken, dan kunt u 
de tekening pannen zonder de vergroting te 
wijzigen.

U kunt zoomen en pannen om optimale 
werkomstandigheden te creëren. Dit kan van 
onschatbare waarde zijn wanneer u aan grote, 
gedetailleerde tekeningen werkt, zoals deze 
plattegrond van een beautycentrum.

U kunt uitzoomen om meer van uw ontwerp 
te zien, of inzoomen om een detail beter te 
bekijken.

U kunt pannen om naar een ander deel van uw 
ontwerp te schuiven
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Bematingen en tekst maken

Accurate bematingen en consistente, leesbare tekst maken, is een tijdrovende taak voor de 
handmatige tekenaar. CAD biedt manieren om deze taak te stroomlijnen.

Wanneer u bij handmatig 
tekenen het formaat wijzigt 
van een deel van de tekening, 
moet u de bematingen 
uitgummen en opnieuw 
tekenen. Wijzigt u tekst, dan 
moeten de letters voor de hele 
tekening vaak worden 
aangepast.

Met AutoCAD en AutoCAD LT 
kunnen associatieve bematingen 
en tekst op de lay-out in het 
papierkader worden gemaakt.

Associatieve bematingen zijn aan het 
onderliggende model gebonden. Wanneer het 
model wordt gewijzigd, worden de 
bematingswaarden automatisch bijgewerkt.

Standaardbematingstypen zijn onder meer 
lineaire, radius-, hoek- en basislijnbemating en 
bematingen met coördinaten.

U kunt de inhoud, het lettertype, het formaat, 
de spatiëring en de rotatie van tekst in 
bematingen en notities gemakkelijk herzien.

In deze detailtekening van een goot wordt de 
vereiste hardware door de tekst, verwijslijnen en 
bematingen beschreven.

Als u bematingen associatief maakt, kunt u de grootte 
en waarde van de bemating automatisch updaten 
wanneer u het bemate object uitrekt of schaalt

U kunt verwijslijnen maken met gekoppelde tekst. Als u 
de tekst verplaatst, wordt de verwijslijn automatisch 
aangepast.
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Uw tekening wijzigen

Correcties zijn een onderdeel van elk tekenproject. Of u nu op papier of met CAD werkt, u zult uw 
tekening toch enigszins moeten wijzigen.

Wilt u wijzigingen aanbrengen in uw tekening op papier, dan betekent dit 
uitgummen en opnieuw tekenen.

CAD elimineert vervelende handmatige bewerkingen met zijn assortiment 
bewerkingstools. Moet u een object geheel of gedeeltelijk kopiëren, dan hoeft u het 
niet opnieuw te tekenen. Als u een object moet verwijderen, kunt u het met een 
paar muisklikken wissen, en als u een fout maakt, kunt u uw bewerkingen snel 
ongedaan maken.

Hebt u een object eenmaal getekend, dan hoeft u het nooit meer opnieuw te 
tekenen. U kunt bestaande objecten wijzigen door ze te spiegelen, roteren, schalen, 
uit te rekken, bij te snijden, enzovoort. Objecteigenschappen zoals lijntype, 
lijndikte, kleur en laag kunt u ook op elk moment wijzigen.

Deze tekeningen voor en na tonen enkele typische wijzigingen in een huisopstand. 
De revisiewolkfunctie wordt gebruikt om gewijzigde gebieden te markeren.

Hebt u iets eenmaal getekend, dan kunt u het gemakkelijk 
kopiëren zonder dat u het opnieuw hoeft te maken.
Uw tekening wijzigen | 19
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Waarom u deze gids zou gebruiken

Deze Aan de slag-gids biedt een introductie tot de meest gebruikte functies van AutoCAD en 
AutoCAD LT. Gebruik de gids om de basisfuncties te leren, zodat u snel kunt beginnen te werken.

Aangezien u over een groot aantal functies beschikt, zijn er vaak vele manieren om een taak uit te 
voeren. In deze gids wordt het volgende besproken:

■ Wat u moet weten om aan de slag te kunnen.
■ De aanbevolen manier om de geboden functies te gebruiken.

Wanneer u meer vertrouwd bent met de functies, zult u de efficiënste manier vinden om uw werk 
uit te voeren.

Studielessen en opdrachten weergeven

U kunt op verschillende manieren opdrachten oproepen in AutoCAD en AutoCAD LT: via de 
opdrachtregel, het lint, werkbalken, paletten en de menubrowser. 

Aangezien het lint aangepast kan zijn en sommige opdrachten niet via het lint kunnen worden 
opgeroepen, worden opdrachten in de studielessen van deze gids meestal via de menubrowser 
opgeroepen.

Menubrowser
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N.B. In alle screenshots en dialoogvensters in deze gids wordt AutoCAD LT op de titelbalk 
weergegeven. De uitleg en studielessen in de Aan de slag-gids zijn van toepassing op zowel AutoCAD als 
AutoCAD LT. De geboden functies zijn identiek.

Extra informatie verkrijgen

Wanneer u meer informatie nodig hebt, kunt u via het Help-menu de volgende resources oproepen. 
Via het Help-menu kunt u de volgende resources oproepen:

■ Help biedt procedures, conceptuele informatie, en beschrijvingen van opdrachten. U kunt ook 
achter de opdrachtprompt, in een dialoogvenster, of achter een aanwijzing binnen een opdracht 
op F1 drukken om Help-informatie weer te geven.

■ New Features Workshop biedt een reeks overzichten van nieuwe functies.
■ Additional Resources biedt verschillende opties voor extra hulp via het web.

Verwante onderwerpen in het Help-systeem oproepen

Aan het eind van de meeste Aan de slag-onderwerpen worden trefwoordverwijzingen weergegeven. 
Uit de informatie hieronder blijkt bijvoorbeeld dat wanneer u 'line' invoert op het tabblad Index van 
het Help-venster, u concepten, procedures, opdrachten en systeemvariabelen kunt vinden die 
betrekking hebben op de opdracht LINE.

LINE

Probeer het: Een Help-onderwerp zoeken met behulp van een trefwoord

■ Start AutoCAD of AutoCAD LT en druk op de F1-toets. Volg dan de stappen in de afbeelding.

2 Voer een 
trefwoord in 

3 Dubbelklik om 
een onderwerp te 
bekijken

4 Klik hierop voor een concept 
dat het geselecteerde 
onderwerp betreft

5 Klik hierop voor procedures 
die het geselecteerde 
onderwerp betreffen

6 Klik hierop voor 
opdrachten die het 
geselecteerde 
onderwerp betreffen

1 Klik op de 
tab Index
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Studieles: Het Help-systeem gebruiken

In deze studieles gebruikt u het Help-systeem om informatie te vinden over hoe u een tekening met 
een sjabloonbestand kunt beginnen en hoe u een lay-out maakt.

N.B. Het is belangrijk te leren hoe u het Help-systeem effectief kunt gebruiken. Het Help-systeem kan 
antwoorden bieden om onnodige frustratie te voorkomen.

1 Start AutoCAD of AutoCAD LT en druk op F1 om het Help-venster weer te geven.

2 In het linkerdeelvenster van het Help-venster klikt u indien nodig op de tab Contents om de 
inhoudsopgave weer te geven. Klik dan op het plusteken (+) naast Gebruikersgids.

De Gebruikersgids wordt uitgevouwen en geeft een lijst met hoofdstukken weer.

3 In het linkerdeelvenster klikt u op de titel Een tekening maken, indelen en opslaan. In het 
rechterdeelvenster van het Help-venster worden koppelingen naar verschillende onderwerpen 
en bijbehorende beschrijvingen weergegeven.

4 Klik in het rechterdeelvenster op Beginnen met een tekening. Klik dan op Een sjabloon gebruiken om 
een nieuwe tekening te beginnen.

U hebt naar een doelonderwerp in het Help-systeem genavigeerd. De inhoudsopgave in het 
linkerdeelvenster toont de onderwerphiërarchie voor gemakkelijke navigatie.
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5 Klik op de tab Procedure. Klik vervolgens op de eerste procedure in de lijst. Klik op de tab 
Procedure om de lijst opnieuw weer te geven.

6 Klik op de tab Quick Reference. Op het tabblad worden alle opdrachten en systeemvariabelen 
weergegeven die bij dit onderwerp horen.

Als u op een koppeling op dit tabblad klikt, wordt in de Help het Opdrachtenoverzicht geopend, 
dat details over opdracht- en dialoogvensteropties biedt.

7 Klik vervolgens op de tab Search in het linkerdeelvenster.

Zoek nu onderwerpen die het trefwoord lay-out bevatten.

8 Typ het woord lay-out en druk op ENTER. 

Er worden verschillende onderwerpen weergegeven die het woord lay-out bevatten. 
Typ verschillende trefwoorden of een exacte woordgroep tussen aanhalingstekens voor de beste 
resultaten.

N.B. U kunt op de kolom Title klikken om de lijst met onderwerpen alfabetisch te sorteren. 
Klik vervolgens op de kolom Location om de lijst met onderwerpen op boek te sorteren: 
Opdrachtenoverzicht, Gebruikersgids enzovoort.

9 Scroll omlaag om het onderwerp Op een lay-outtabblad werken van de Gebruikersgids te vinden. 
Dubbelklik dan op het onderwerp.

Het onderwerp wordt weergegeven. Maar hoe weet u waar u in de inhoudsopgave bent? Hoe kunt 
u een aangrenzend verwant onderwerp weergeven?
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10 Klik op de tab Contents in het linkerdeelvenster.

De inhoudsopgave wordt bij het huidige onderwerp geopend. Gebruik deze methode om 
gemakkelijk verwante onderwerpen te vinden.

N.B. Als de inhoudsopgave niet automatisch bij het huidige onderwerp wordt geopend, klikt u op de 
tab Concept in het rechterdeelvenster.

11 Klik met de rechtermuisknop op een onderwerp in het linkerdeelvenster, en klik dan op 
Close All.

Dit is een snelle methode om de inhoudsopgave samen te vouwen wanneer er te veel 
subonderwerpen worden weergegeven.

12 Sluit het Help-venster.
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Lees Het Help-systeem efficiënt gebruiken voor meer informatie. Klik op het tabblad Contents in het 
Help-systeem op Gebruikersgids ➤ Informatie verkrijgen ➤ Informatie vinden ➤ Het Help-systeem 
efficiënt gebruiken.

Testvragen

1 Wat is het doel van de tabbladen in het rechterdeelvenster van het Help-venster?

2 Wanneer gebruikt u het tabblad Contents in plaats van Index in het linkerdeelvenster van het Help-
venster?

3 Via welk menu kunt u informatie over nieuwe functies verkrijgen?

Aan de slag

Handeling Menubrowser

Het Help-systeem oproepen Help ➤ Help

New Features Workshop gebruiken Help ➤ New Features Workshop

Cursusbronnen zoeken Help ➤ Additional Resources ➤ 
Online Training Resources

Help-systeem

HELP
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Met opdrachten werken
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De muis gebruiken

De meeste mensen gebruiken een muis als aanwijsapparaat. Op een tweeknopsmuis is de linkerknop 
meestal de selectieknop waarmee punten gespecificeerd of objecten geselecteerd worden in het 
tekengebied. Met de rechtermuisknop kunt u een snelmenu oproepen met relevante opdrachten en 
opties. Afhankelijk van de positie van de cursor worden verschillende snelmenu's weergegeven.

N.B. Klik met de rechtermuisknop om een snelmenu op te roepen en te zien welke opties in een 
bepaalde situatie beschikbaar zijn.

Een wielmuis is een tweeknopsmuis met een wieltje tussen de knoppen, dat u kunt draaien of 
indrukken om snel in uw tekening te zoomen en pannen. Het gebruik van een wielmuis wordt ten 
sterkste aanbevolen.

Een opdracht annuleren

Als u per ongeluk in het scherm klikt, een snelmenu oproept of een opdracht start, kunt u dit te allen 
tijde annuleren door op de ESC-toets op uw toetsenbord te drukken.

Probeer het: Een selectie annuleren

■ Klik in het tekengebied en verplaats de muis. U bevindt zich nu in een objectselectiemodus. 
Druk op ESC om te annuleren.

punten specificeren of 
objecten selecteren

een snelmenu oproepen

draaien voor zoomen, 
indrukken voor pannen
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Een opdracht starten

U kunt een opdracht starten via de menubrowser, een werkbalk, een palet of de opdrachtregel. 
Aangezien AutoCAD en AutoCAD LT erg flexibel zijn, kunt u werken op de manier die voor u het 
meest comfortabel is.

U kunt opdrachten uit verschillende soorten menu's kiezen:

■ U opent de menubrowser via de felrode knop in de linkerbovenhoek van het toepassingsvenster. 
Alle opdrachten voor de studielessen in dit boek kunnen via deze lijsten worden opgeroepen.

■ Het menu Object Snap wordt weergegeven wanneer u SHIFT ingedrukt houdt en rechtsklikt. 
Met objectmagneten kunt u gemakkelijk nauwkeuriger tekenen door de cursor naar een element 
op het object te laten springen, zoals het eindpunt van een lijn of het midden van een cirkel.

■ Snelmenu's worden weergegeven wanneer u met de rechtsklikt. Er worden verschillende menu's 
weergegeven afhankelijk van waar u rechtsklikt op een object, in het tekengebied, op een 
werkbalk of in een dialoogvenster, palet of venster.

Opdrachten op de opdrachtregel starten

U kunt opdrachten starten door ze op de opdrachtregel in het opdrachtvenster te typen in plaats van 
werkbalken of menu's te gebruiken. Verder moeten sommige opdrachten op de opdrachtregel 
voltooid worden, ongeacht hoe ze gestart zijn.

Sommige opdrachten hebben ook verkorte namen of opdrachtaliassen. Zo kunt u c invoeren als alias 
voor CIRCLE. 

Nadat u de opdracht op de opdrachtregel hebt getypt, drukt u op ENTER of de spatiebalk om de 
opdracht te starten. U kunt ook de vorige opdracht herhalen door op ENTER of de spatiebalk te 
drukken.

N.B. Wanneer u in deze gids en het Help-systeem geïnstrueerd wordt iets in te voeren, typt u de 
vetgedrukte waarde op de opdrachtregel en drukt u op de ENTER-toets.

Een opdrachtoptie opgeven

Wanneer u een opdracht start, ziet u vaak een set opties op de opdrachtregel. Wanneer u 
bijvoorbeeld de opdracht CIRCLE invoert, wordt de volgende prompt op de opdrachtregel 
weergegeven: 

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]:

opdrachtvenster

opdrachtregel
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De standaardoptie Specify center point for circle wordt vóór de vierkante haakjes weergegeven. 
Tussen de haakjes worden alternatieve opties weergegeven.

■ Voer coördinaatwaarden in om de standaardoptie te accepteren, of klik met het aanwijsapparaat 
op een hartpunt in het tekengebied. 

■ Voer de hoofdletters in de optienaam in om een andere optie te kiezen. Typ bijvoorbeeld 2P en 
druk op ENTER om de tweepuntsoptie te kiezen.

De dynamische prompt gebruiken

Naast de prompt op de opdrachtregel wordt er een gelijksoortige prompt naast de cursor 
weergegeven die de dynamische prompt wordt genoemd.

Met de dynamische prompt kunt u uw ogen op uw werk houden en hoeft u niet omlaag te kijken 
naar de opdrachtregel.

Druk op de toets PIJL-OMLAAG en klik op een optie in het menu om opdrachtopties in de 
dynamische invoerprompt weer te geven.

Probeer het: Een lijn trekken met behulp van de menubrowser

1 Klik op de menubrowser ➤ Klik op Draw ➤ Klik op Line.

2 Achter de prompt Specify First Point klikt u ergens in het tekengebied om een punt te markeren.

De prompt verandert: Specify Next Point or [Undo]. 

3 Achter de prompt Specify Next Point or [Undo] klikt u ergens anders in de tekening om het 
eindpunt van het lijnsegment op te geven.

4 Maak een tweede lijnsegment door nogmaals te klikken om een ander punt te vinden.

De prompt Specify Next Point or [Undo] wordt herhaald zodat u segmenten kunt blijven tekenen 
tot u de opdracht LINE beëindigt.

5 Druk op ENTER om de opdracht LINE te beëindigen.

De twee lijnsegmenten die u zojuist gemaakt hebt, delen een eindpunt, maar zijn afzonderlijke 
objecten.

6 Klik op Modify ➤ Erase, en klik op elke lijn. Druk vervolgens op ENTER om de wisopdracht te 
beëindigen.
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Probeer het: Het lint gebruiken om een lijn te trekken

1 Tabblad Home ➤ paneel Draw ➤ Klik op de knop Line .

2 Teken twee lijnsegmenten.

3 Tabblad Home ➤ paneel Modify➤ Klik op de knop Erase .

4 Klik op elke lijn en druk vervolgens op ENTER om de lijnen te wissen.

Probeer het: Een lijn trekken met behulp van de opdrachtregel

1 Typ line op de opdrachtregel of de letter L. Druk op ENTER.

2 Klik ergens in het tekengebied om een punt te markeren.

3 Achter de prompt Specify Next Point or [Undo] klikt u ergens anders in het tekengebied om het 
eindpunt van het lijnsegment op te geven.

4 Achter de prompt Specify Next Point or [Undo] klikt u ergens anders in het tekengebied om het 
eindpunt van het lijnsegment op te geven.

5 Typ u en druk op ENTER om het laatste lijnsegment ongedaan te maken en klik op een andere 
locatie voor het eindpunt.

6 Typ vervolgens c (Close) en druk op ENTER om een derde lijnsegment toe te voegen dat een 
verbinding maakt met het oorspronkelijke punt en de opdracht beëindigt.

Probeer het: Een cirkel tekenen met behulp van de opdrachtregel

1 Typ circle op de opdrachtregel of de letter c (typ c en druk op ENTER).

2 Achter de prompt Specify Center Point for Circle klikt u ergens in het tekengebied om een punt 
te markeren.

3 Typ 5 achter de prompt Specify Radius of Circle (typ 5 en druk op ENTER).

4 Druk op ENTER op de opdrachtregel om de opdracht CIRCLE te herhalen.

5 Typ 2P om een cirkel te maken met behulp van twee punten (typ 2P en druk op ENTER).

6 Klik ergens in de tekening om elk punt te markeren.

7 Herhaal de opdracht CIRCLE nog een aantal malen met alle andere opties.

8 Wanneer u klaar bent, typt u erase of e, en klikt u op elke cirkel om deze te selecteren. 
Druk vervolgens op ENTER om de geselecteerde cirkels te wissen.

Probeer het: Een cirkel tekenen met behulp van de dynamische prompt

1 Typ circle achter de dynamische prompt of de letter c.

2 Achter de prompt Specify Center Point for Circle drukt u op de toets PIJL-OMLAAG.

3 Klik op een van de CIRCLE-opties in het menu en voltooi de opdracht.
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Opdrachten ongedaan maken of opnieuw uitvoeren

Het zal af en toe voorkomen dat u delen van uw werk ongedaan moet maken. Via twee knoppen op 
de werkbalk Standard kunt u fouten in uw tekening ongedaan maken.

■ Undo. U kunt eerdere handelingen ongedaan maken. Zo kunt u op Undo klikken om een object 
dat u zojuist gemaakt hebt, te verwijderen.

■ Redo. U kunt de handelingen die u ongedaan hebt gemaakt, weer opnieuw uitvoeren. Zo kunt u 
op Redo klikken om het object te herstellen dat u zojuist geannuleerd hebt. 

Testvragen

1 Op welke drie manieren kunt u een opdracht starten?

2 Met welke andere toets behalve ENTER kunt u een opdracht beëindigen of herhalen?

3 Hoe annuleert u een opdracht?

Aan de slag

Handeling Snelmenu Toetsenbord

Opdracht beëindigen Rechtsklikken ➤ Enter ENTER of SPATIEBALK

Een opdracht herhalen Rechstklikken ➤ Repeat <actie> ENTER of SPATIEBALK

Een opdracht annuleren Rechstklikken ➤ Cancel ESC

Vorige opdracht ongedaan maken Rechstklikken ➤ Undo <action> U en druk op ENTER

Help-systeem

OPTIONS, U, UNDO, REDO

Redo

Undo
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Wanneer u inzoomt om de weergave te ver-
groten, kunt u objecten gemakkelijker maken 
of wijzigen.

Nadat u klaar bent met een gebied, kunt u uit-
zoomen voor een beter algeheel overzicht.

Nadat u ingezoomd hebt, kunt u de weergave 
pannen om de objecten waaraan u werkt, te 
centreren.
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Aanzichten wijzigen

Zoomen om een aanzicht te vergroten . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  38
Pannen om een aanzicht te verplaatsen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39



Zoomen om een aanzicht te vergroten

Een aanzicht is een specifieke vergroting, plaats en stand van uw ontwerp. De gebruikelijkste manier 
om een aanzicht te wijzingen is zoomen. Met zoomen wordt de vergroting van de afbeelding die in 
het tekengebied wordt weergegeven, verhoogd of verlaagd.

U kunt verschillende zoommethoden voor uw tekeningen gebruiken.

Zoomen door de cursor te verplaatsen

U kunt een aanwijsapparaat gebruiken om in realtime te zoomen, dat wil zeggen in- of uitzoomen 
door de cursor te verplaatsen. Met de optie Realtime van de opdracht ZOOM kunt u de cursor 
omhoogslepen om in te zoomen en omlaag om uit te zoomen. Als u een wielmuis gebruikt, draait u 
de wielknop vooruit om in te zoomen en achteruit om uit te zoomen.

Naar een specifiek gebied zoomen

Via de optie Window van de opdracht ZOOM kunt u snel op een specifiek gebied inzoomen door 
met de cursor een rechthoekig zoomvenster te definiëren. Het gebied dat u definieert, wordt in het 
nieuwe aanzicht gecentreerd.

Zoomen om de hele tekening weer te geven

Gebruik de optie Extents van de opdracht ZOOM om de hele tekening weer te geven. Dit is nuttig 
wanneer u snel naar het algemene aanzicht wilt terugkeren. Deze optie is ook nuttig als uw 
tekengebied leeg is, omdat u te dicht op een leeg gebied ingezoomd of te ver buiten het tekengebied 
gepand hebt.

uitgezoomd ingezoomd
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Pannen om een aanzicht te verplaatsen

Pannen is ook een veel gebruikte manier om het aanzicht te veranderen. Met pannen wordt de positie 
van de afbeelding in een willekeurige tweedimensionale richting weergegeven.

Pannen door de cursor te verplaatsen

U kunt in realtime pannen. Dit betekent dat u het aanwijsapparaat gebruikt om de afbeelding in het 
tekengebied te verplaatsen. Via de opdracht PAN versleept u de cursor om de afbeelding naar een 
nieuwe locatie te pannen. Bij een wielmuis houdt u de wielknop ingedrukt terwijl u de cursor 
verplaatst om te pannen.

Studieles: Zoomen en pannen

In deze studieles kunt u oefenen met zoomen en pannen via de opdrachten in de menubrowser of 
direct met een wielmuis.

1 Klik op de menubrowser ➤ File ➤ Open.

2 In het dialoogvenster Open navigeert u naar de map Sample in de map met programmabestanden 
van AutoCAD of AutoCAD LT. Klik op elk tekeningbestand, en open een bestand dat er 
interessant uitziet.

3 Klik op de menubrowser ➤ View ➤ Zoom ➤ Window.

4 Klik ergens dicht bij het midden van de tekening. Verplaats uw cursor om een rechthoekig gebied 
te vormen, en klik opnieuw.

5 Klik op de menubrowser ➤ View ➤ Pan ➤ Realtime.

6 Versleep de cursor in een willekeurige richting om het aanzicht te verplaatsen. Druk op ESC om 
de bewerking te beëindigen.

vóór PAN na PAN
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7 Blijf zoomen en pannen oefenen met de volgende opties:

■ Zoom Realtime (of gebruik het wiel van een wielmuis)
■ Zoom Previous
■ Zoom Window
■ Zoom Extents
■ Pan Realtime (of houd het wieltje ingedrukt en verplaats de muis)

Oefen met deze opties tot u helemaal vertrouwd bent met zoomen en pannen. Deze opties 
worden het meest gebruikt voor tekenen in 2D.

N.B. Als u inzoomt en merkt dat bogen en cirkels er minder goed afgewerkt uitzien, of als u buiten 
een grens niet kunt in- of uitzoomen, kunt u de weergave opnieuw genereren. Klik op View ➤ Regen 
All. Met deze opdracht worden ook losse pixels verwijderd.

8 (Optioneel) Als u een wielmuis hebt, kunt u zonder een opdracht in te voeren zoomen en 
pannen. Probeer de volgende bewerkingen:

■ Verplaats uw cursor naar een gebied in de tekening, en draai de wielknop vooruit en achteruit 
om in- en uit te zoomen. Uw cursorlocatie bepaalt dan het stationaire referentiepunt van uw 
zoombewerking.

■ Houd de wielknop ingedrukt terwijl u het aanzicht versleept om het te pannen.
■ Dubbelklik met de wielknop om tot de begrenzingen van de tekening te zoomen.

9 Sluit de voorbeeldtekening zonder opslaan.

Aan de slag

Handeling Menubrowser Lint

Pannen View ➤ Pan Tabblad Home ➤ paneel 
Utilities ➤ Pan 

Zoomen View ➤ Zoom Tabblad Home ➤ paneel 
Utilities ➤ Realtime

De weergavebegrenzing voor zoomen 
opnieuw instellen

View ➤ Regen

Bogen en cirkels afwerken View ➤ Regen

Help-systeem

PAN, ZOOM, REGEN, REGENALL
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Testvragen

1 Welke ZOOM-optie moet u gebruiken om uw hele tekening in het tekengebied te laten passen?

2 Hoe kunt u snel het vorige aanzicht opnieuw weergeven?

3 Met welke opdracht wordt de weergave van bogen afgewerkt en worden losse pixels verwijderd?
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Maak lagen om informatie te 
ordenen als op transparante 
overlays van tekeningen.

Wijs standaardlijndikten toe om te 
verzekeren dat lijnen op dezelfde 
manier geplot worden, ongeacht de 
schaal van de tekening.

Gebruik verschillende lijntypen om verschil-
lende typen objecten te identificeren.
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Met een tekening beginnen

Er zijn verschillende manieren om een nieuwe tekening te beginnen. Het is raadzaam met een 
tekeningsjabloonbestand te beginnen.

Een tekeningsjabloonbestand bevat vooraf gedefinieerde instellingen, standaarden en definities die 
u aanzienlijk veel tijd in de set-up besparen. Wanneer u een tekening met een tekeningsjabloon 
begint, worden deze instellingen aan de nieuwe tekening doorgegeven. Tekeningsjabloonbestanden 
bevatten instellingen en basiselementen voor een tekening die u vaak zult gebruiken, zoals

■ type eenheid en precisie
■ toolinstellingen en voorkeuren
■ laagordening
■ titelblokken, kaders en logo's
■ bematingsstijlen
■ tekststijlen
■ lijntypen en lijndikten
■ plotstijlen

Uw product bevat verschillende tekeningsjabloonbestanden, waaronder een aantal waarmee 
naleving van ANSI-, DIN-, ISO- en JIS-standaarden vereenvoudigd wordt. Toch is het heel goed 
mogelijk dat u een of meer ervan zult aanpassen, of dat u uw eigen tekeningsjabloonbestanden zult 
maken zodat ze aan uw standaarden en behoeften voldoen.

U kunt een tekeningsjabloonbestand maken door een tekening met de .dwt-extensie op te slaan.

tekeningsjabloonbestand 
waarin een titelblok is 
opgenomen
44 | Hoofdstuk 4 Set-up van een tekening



Probeer het: Een tekeningsjabloonbestand openen

1 Begin een nieuwe tekening.

2 Klik in het dialoogvenster Select Template op een van de volgende tekeningsjabloonbestanden 
en klik dan op Open.

■ Tutorial-mArch.dwt. Bouwkundige voorbeeldsjabloon (metrisch)
■ Tutorial-mMfg.dwt. Voorbeeldsjabloon voor mechanisch ontwerp (metrisch)
■ Tutorial-iArch.dwt. Bouwkundige voorbeeldsjabloon (Engels)
■ Tutorial-iMfg.dwt. Voorbeeldsjabloon voor mechanisch ontwerp (Engels)

De metrische sjabloonbestanden worden geschaald zodat millimeters als tekeneenheid gebruikt 
worden, en de Engelse sjabloonbestanden worden geschaald zodat inches als tekeneenheid gebruikt 
worden.
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De tekeneenheden en tekenschaal plannen

In tegenstelling tot bij handmatig tekenen hoeft u zich geen zorgen te maken over het instellen van 
een schaal voordat u met een tekening begint. Hoewel u uiteindelijk met een gespecificeerde schaal 
op papier afdrukt of plot, maakt u het model met een schaal van 1:1. Voordat u echter met een 
tekening begint, moet u eerst bepalen welke tekeneenheden u wilt gebruiken.

De tekeneenheden kiezen

In AutoCAD en AutoCAD LT worden afstanden in tekeneenheden gemeten. In een tekening kan één 
tekeneenheid overeenkomen met één inch, één millimeter, één meter of één mijl. 

Voordat u met een tekening begint, bepaalt u waarmee één tekeneenheid overeenkomt — er is geen 
instelling waarmee de lengte van een tekeneenheid wordt bepaald.

De notatie van tekeneenheden instellen

Nadat u hebt bepaald welke tekeneenheden u wilt gebruiken, kunt u de notatie van de 
tekeneenheden instellen. De volgende notatie-instellingen voor lineaire eenheden zijn beschikbaar:

■ Architectural. Een lengte van 15,5 eenheden wordt als 1’-3 1/2” weergegeven
■ Decimal. Een lengte van 15,5 eenheden wordt als 15.5000 weergegeven
■ Engineering. Een lengte van 15,5 eenheden wordt als 1’-3.5” weergegeven
■ Fractional. Een lengte van 15,5 eenheden wordt als 15 1/2 weergegeven
■ Scientific. Een lengte van 15,5 eenheden wordt als 1.5000E+1 weergegeven

Schacht
1 eenheid = 1 mm
(rasterafstand = 2 mm)

Kantoorplattegrond
1 eenheid = 1 inch
(rasterafstand = 12 inch)
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Als u bijvoorbeeld een mechanisch engineer bent die gewoonlijk in millimeters werkt, stelt u de 
notatie voor lineaire eenheden op decimaal in. Bent u een architect die gewoonlijk in feet en inches 
werkt, dan stelt u de notatie op bouwkundig in.

De notatie van de tekeneenheden bepaalt alleen de weergavestijl van de tekeneenheden op het 
scherm, zoals in de weergave van coördinaten en waarden in het palet, de dialoogvensters en de 
prompts van Properties. 

Probeer het: De notatie en precisie van de tekeneenheid selecteren

1 Klik op de menubrowser ➤ Format ➤ Units. In het dialoogvenster Drawing Units ziet u de 
weergavestijl die voor lineaire en hoekeenheden is geselecteerd.

N.B. Beschouw dit dialoogvenster als het dialoogvenster Drawing Units Format.

2 Let op de waarde die onder Precision wordt weergegeven. Deze waarde is de decimale of 
breukafronding van waarden die op het scherm worden weergegeven.

3 Sluit het dialoogvenster.
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Modellen en lay-outs begrijpen

De knop Model en de lay-outknoppen op de statusbalk bieden twee werkomgevingen. Gebruik het 
werkvlak om een model van uw onderwerp op volledige grootte te tekenen. In de lay-outruimte kunt 
u een lay-out met verschillende aanzichten maken om te plotten.

■ Het werkvlak biedt toegang tot een onbegrensd tekengebied. In het werkvlak bepaalt u eerst of 
één eenheid overeenkomt met één millimeter, één meter, één inch of een andere tekeneenheid. 
Vervolgens stelt u de notatie van de tekeneenheid in. Daarna tekent u met een schaal van 1:1.

■ De lay-outruimte biedt toegang tot tekeninglay-outs. Wanneer u een lay-out instelt, specificeert 
u welk papierformaat u wilt gebruiken. De lay-out representeert een afgedrukt tekenblad waarop 
u een of meer aanzichten van het model op verschillende schalen kunt weergeven. Deze lay-
outomgeving wordt het papierkader genoemd. Hier maakt u lay-outvensters die als vensters in het 
werkvlak dienen. Elk lay-outvenster kan een ander aanzicht van het model bevatten.

model van een onderdeel op volledige 
grootte dat met een schaal van 1:1 is 
gemaakt

lay-out met titelblok en rechthoekige lay-
outvensters met geschaalde aanzichten

lay-out met vensters op verschillende schalen
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Probeer het: Tussen de werkruimte en de lay-outruimte schakelen

1 Klik onder aan het toepassingsvenster aan de rechterkant op de knop Model. Het werkvlak 
verschijnt nu, waarin u de geometrie voor uw model kunt maken en wijzigen.

De strook onder aan het toepassingsvenster wordt de tekenstatusbalk genoemd.

2 Rechtsklik op dezelfde knop Model en klik op de optie Display Model and Layout Tabs. 
Er verschijnen nu tabs linksonder in uw tekengebied. 

Tijdens het leerproces is het gemakkelijker om met tabs te werken. U kunt de tabs verbergen en 
weer knoppen gebruiken door te rechtsklikken op een tab en vervolgens op Hide Model and 
Layout Tabs te klikken in het snelmenu.

3 Klik op de lay-outtab rechts van de tab Model. Lay-outs worden gebruikt om gedrukte tekeningen 
te maken.

De lay-out is al voorbereid, inclusief een voorbeeldtitelblok en een lay-outvenster, de blauwe 
rechthoek.

4 Dubbelklik ergens in het rechthoekige venstergebied op de lay-out. Op deze manier roept u het 
werkvlak vanuit een lay-out op om het werkvlakaanzicht te pannen en bematingen toe te 
voegen.

De rand van het lay-outvenster wordt dikker en de kruiscursor is alleen actief in het lay-
outvenster.

5 Dubbelklik in een leeg gebied buiten het rechthoekige venster. U keert dan terug naar het 
papierkader.

De rand van het lay-outvenster is niet meer zo dik en de kruiscursor is actief in het gehele 
tekengebied.

6 Klik op de tab Model om weer naar het werkvlak te gaan.
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Tekeningen met lagen ordenen

Lagen zijn het equivalent van de overlays die worden gebruikt bij handmatig tekenen. In CAD zijn 
ze een belangrijke organisatietool. 

Elke laag heeft een toegewezen kleur, lijntype en lijndikte. Voordat u objecten maakt, stelt u de laag 
in waarop de objecten moeten worden gemaakt. Dit wordt de actieve laag genoemd. Standaard 
worden de kleur, het lijntype en de lijndikte van de actieve laag automatisch toegewezen aan de 
nieuwe objecten die u maakt.

Lagen toewijzen

U kunt de tekening ordenen door gelijksoortige componenten aan dezelfde laag toe te wijzen. 
U kunt bijvoorbeeld een laag met de naam Elektrisch maken en de kleur groen eraan toewijzen. 
Telkens wanneer u elektrische objecten tekent, schakelt u naar die laag. De objecten die u tekent, 
worden op de laag Elektrisch gemaakt en zijn groen gekleurd.

Als u elektrische objecten later niet wilt bekijken of plotten, kunt u die laag uitschakelen.

N.B. Het is erg belangrijk een laagstandaard voor het gehele bedrijf vast te stellen en te handhaven. 
Met een laagstandaard wordt de ordening van tekeningen logischer, consistenter, compatibeler en beter 
onderhoudbaar. Laagstandaarden zijn essentieel voor teamprojecten.

Probeer het: Geef in een tekening de lijst met lagen weer

1 Klik op de menubrowser ➤ Format ➤ Layer. 

2 In de Layer Properties Manager ziet u de naam en standaardeigenschappen die aan elke laag zijn 
toegewezen.

Deze lagen zijn slechts een voorbeeld van de soorten lagen die u in een goed georganiseerde 
tekening moet gebruiken. Er zijn al vele laagstandaarden in gebruik, waaronder die in bedrijven 
zijn gespecificeerd en die door professionele organisaties worden aanbevolen.

3 Vergroot de rechterkant van het dialoogvenster om alle kolommen weer te geven. Klik op de 
titels van de kolommen Status, Color en Name om de volgorde van de lagen te wijzigen.

Bekijk de beschrijvingen van elke laag in de uiterst rechtse kolom.

muren

meubilair

alle lagen

elektrisch
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Lagen beheren

Als u objecten op een laag onzichtbaar wilt maken, kunt u de laag uitschakelen of bevriezen in de 
Layer Properties Manager. U kunt lagen ook vergrendelen om te voorkomen dat objecten per 
ongeluk worden gewijzigd.

■ Lagen uitschakelen. Gebruik deze optie in plaats van bevriezen als u de zichtbaarheid van een 
laag vaak moet uitschakelen.

■ Lagen bevriezen. Gebruik deze optie als een laag niet zo lang zichtbaar hoeft te zijn. Wanneer u 
een bevroren laag ontdooit, wordt de tekening automatisch opnieuw gegenereerd, wat langer 
duurt dan het inschakelen van een laag.

■ Lagen vergrendelen. Gebruik deze optie om te voorkomen dat objecten op een laag worden 
gewijzigd. U kunt de objecten op een vergrendelde laag nog steeds gebruiken voor bewerkingen 
waarmee de objecten niet worden gewijzigd. U kunt bijvoorbeeld op deze objecten uitlijnen om 
ze als richtlijnen voor nauwkeurig tekenen te gebruiken.
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Studieles: Met een tekening oefenen

In deze studieles oefent u met een tekening van een prieel- en staketselontwerp.

1 Klik op de menubrowser ➤ File ➤ Open.

2 In het dialoogvenster Select File zoekt u naar de map \Help\GettingStarted in de productmap van 
AutoCAD of AutoCAD LT. Hierin opent u het bestand arbor.dwg.

Als u de tekeningbestanden niet ziet, controleer dan of Drawing (.dwg) is geselecteerd in de 
vervolgkeuzelijst Files of Type van het dialoogvenster.

3 Klik op de tab Model (of klik op de knop Model op de statusbalk).

4 Wanneer u met de cursor over objecten in de tekening gaat, kunt u zien dat de objecten 
automatisch worden gemarkeerd.

5 Zoom en pan in het werkvlak om het prieelontwerp te bekijken.

6 Voer de bewerking Zoom Extents uit om het gehele ontwerp weer te geven.

7 Klik op de tab ANSI C Layout.

8 Zoom en pan in het papierkader om de tekeninglay-out te bekijken.

9 Voer de bewerking Zoom Extents uit om de gehele lay-out weer te geven.

10 Klik op de menubrowser ➤ Format ➤ Layer. In de Layer Properties Manager bekijkt u de lijst met 
lagen die zijn gemaakt om deze tekening te ordenen.

Er staat nu een groen vinkje naast de actieve laag.

11 Klik op verschillende gloeilampjes om de bijbehorende lagen uit te schakelen.

12 Klik op de kolom On om de lagen op aan- of uitstatus te schikken. Schakel de lagen dan weer in.

13 Klik op de kolom Color om de lagen op kleur te schikken.

14 Klik op de kolom Name en dan op OK.

15 Sluit de tekening zonder opslaan.
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Testvragen

1 Waarom is het belangrijk een tekening met een tekeningsjabloonbestand te beginnen?

2 Wat is het verschil tussen tekeneenheden kiezen en de notatie van tekeneenheden instellen?

3 Wat is het verschil tussen het tabblad Model en een lay-outtabblad?

4 Wat zijn de voordelen van het maken van een tekening met lagen?

Aan de slag

Handeling Menubrowser Pictogram

Een nieuwe tekening beginnen File ➤ New

Een tekeningsjabloon opslaan File ➤ Save As

De weergavestijl van de eenheden 
instellen

Format ➤ Units

Een lay-out maken Insert ➤ Layout ➤ New Layout

Lagen maken en wijzigen Format ➤ Layer

Help-systeem

NEW, SAVEAS, STARTUP, UNITS, MODEL, LAYOUT, LAYER
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Maak gemakkelijk rechthoeken

Gebruik lijnen voor het tekenen 
van objecten en voor constructie-
geometrie

Gebruik cirkels en bogen om regelma-
tige krommen te maken

Verschuif lijnen om parallelle lijnen te maken

Gebruik polylijnen om lijn- 
en boogsegmenten te com-
bineren

Gebruik splines om vloeiende, 
niet-uniforme krommen te 
maken
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Overzicht van objecteigenschappen

Alle objecten die u maakt, hebben eigenschappen. Objecteigenschappen zijn instellingen die de 
weergave en geometrische kenmerken van een object bepalen. De algemene eigenschappen voor alle 
objecten worden in de onderstaande lijst weergegeven. Alle andere eigenschappen zijn specifiek 
voor het type object.

Objecteigenschappen toewijzen

Objecteigenschappen worden meestal op een van de volgende manieren toegewezen:

■ By layer. Eigenschappen worden aan een laag toegewezen. Voor objecten die op die laag worden 
getekend, worden automatisch die eigenschappen gebruikt.

■ Individual properties. Eigenschappen worden afzonderlijk aan objecten toegewezen, ongeacht 
de laag waarop ze zijn getekend.

Color Linetype scale Hyperlink

Layer Plot style Lineweight

Linetype Thickness

Klik op het pictogram om een categorie van 
eigenschappen uit of samen te vouwen

Klik om een eigenschap te wijzigen

Klik met de rechtermuisknop om opties voor paletgedrag in te stellen
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Het palet Properties gebruiken

Het palet Properties is de hoofdtool om de eigenschappen van objecten weer te geven, in te stellen 
en te wijzigen. Het palet werkt als volgt:

■ Als er geen objecten zijn geselecteerd, worden de huidige instellingen voor de 
standaardeigenschappen weergegeven. Voor alle objecten die u daarna maakt, kunt u dan de 
standaardeigenschappen instellen.

■ Wanneer u op een object klikt, worden de eigenschappen van dat object op het palet Properties 
weergegeven, waar u ze vervolgens kunt wijzigen.

■ Als u op meerdere objecten klikt, worden alle eigenschappen die ze gemeen hebben, op het palet 
Properties weergegeven. U kunt deze gedeelde eigenschappen vervolgens wijzigen.

Probeer het: Het palet Properties weergeven

1 Klik op de menubrowser ➤ File ➤ New.

2 Klik in het dialoogvenster Select Template op een van de tekeningsjabloonbestanden en klik dan 
op Open.

3 Klik op de menubrowser ➤ Modify ➤ Properties.

Wanneer u het palet openlaat, hebt u het altijd bij de hand. U kunt Auto-hide inschakelen, zodat 
het palet Properties verschijnt of verdwijnt wanneer u de cursor op de titelbalk van het palet 
Properties zet.

Probeer het: Het Auto-hide-gedrag van het palet Properties wijzigen

1 Klik met de rechtermuisknop op de titelbalk van het palet Properties. Klik op Auto-hide in het 
snelmenu.

2 Verplaats de cursor naar en uit het palet Eigenschappen. Laat het palet Properties openstaan.

Het paneel Properties gebruiken

U kunt de knoppen op de panelen Properties en Layers gebruiken om de eigenschappen weer te 
geven, in te stellen en te wijzigen, net zoals u dat op het palet Properties doet. Deze panelen worden 
standaard weergegeven op het tabblad Home van het lint dat zich boven het tekengebied bevindt.

Het paneel Properties biedt handige toegang tot de belangrijkste objecteigenschappen.

vervolgkeuzelijst Color

vervolgkeuzelijst Linetype

vervolgkeuze lijst
Lineweight

vervolgkeuzelijst Plotstyle

paneel 
Properties
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Het paneel Layers gebruiken

Op het paneel Layers kunt u lagen en laageigenschappen instellen. Gebruik de knop Layer Properties 
Manager om laaginstellingen te wijzigen. Via de vervolgkeuzelijst Layer kunt u snel verschillende 
laageigenschappen wijzigen en een andere laag actief maken.

Studieles: Objecteigenschappen wijzigen

In deze studieles gebruikt u verschillende vervolgkeuzelijsten om de eigenschappen van lagen en 
objecten weer te geven.

1 Klik op de menubrowser ➤ File ➤ Open.

2 In het dialoogvenster Select File zoekt u naar de map \Help\GettingStarted in de productmap van 
AutoCAD of AutoCAD LT. Hierin opent u het bestand arbor.dwg.

3 Klik op de tab Model.

4 Zet uw cursor op de titelbalk van het palet Properties om het te openen. 

Bekijk de huidige instellingen voor de standaardeigenschappen.

5 Klik op een bematingsobject in de tekening om het te selecteren.

Verschillende eigenschappen van dit object worden in het paneel Properties op het lint 
weergegeven. De laag van het object is Dimension. De eigenschappen voor kleur, lijntype en 
lijndikte van het object zijn op ByLayer ingesteld. De kleur van de laag Dimension is rood.

6 Zet uw cursor op de titelbalk van het palet Properties om het te openen. 

Bekijk de extra eigenschappen van het bematingsobject dat in het palet Properties wordt 
weergegeven.

7 Klik op verschillende objecten met andere kleuren. Zet uw cursor op de titelbalk van het palet 
Properties.

Alleen de gedeelde eigenschappen van de objecten worden vermeld.

8 Verplaats uw cursor uit het palet Properties en druk op ESC om de selectie te annuleren.

vervolgkeuzelijst 
Layer

maak de laag van het
geselecteerde object de actieve laag

Layer Properties 
Manager

schakel de laag van een geselecteerd 
object uit:

paneel 
Layers
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De standaardkleur van een laag wijzigen

1 Klik op de menubrowser ➤ Format ➤ Layer.

2 In de Layer Properties Manager klikt u op het rode vakje onder de kolom Color van de laag 
Dimension.

3 In het dialoogvenster Select Color klikt u eerst op het groene vakje en dan op OK ter bevestiging. 
Sluit de Layer Properties Manager.

Alle objecten op de laag Dimension zijn nu groen. Aangezien alle bematingen zich op één laag 
bevinden, kunt u de eigenschappen van alle objecten op die laag in één keer wijzigen.

De kleur van een afzonderlijk object wijzigen

1 Klik op een groen bematingsobject om het te selecteren.

2 Paneel Properties ➤ Klik op de vervolgkeuzelijst Color ➤ Klik op Magenta.

De kleur van het geselecteerde object wordt nu gewijzigd in magenta, waardoor de groene 
laagkleur van het object vervangen wordt. Als u de laagkleur wijzigt, blijft de kleur van het 
bematingsobject magenta.

3 Druk op ESC om af te sluiten.

4 Klik op hetzelfde bematingsobject.

5 Klik op de vervolgkeuzelijst Color en klik op ByLayer. Hiermee wordt het gedrag van de 
kleureigenschap van het bematingsobject hersteld.

De actieve laag wijzigen

1 Klik op de vervolgkeuzelijst Layer van het paneel Layers.

2 Klik op een andere laag om die actief te maken.

Alle nieuwe objecten worden nu op deze laag gemaakt tot u een andere laag actief maakt.

3 Klik op de menubrowser ➤ Format ➤ Layer

4 In de Layer Properties Manager klikt u op een laag om deze te selecteren.

vervolgkeuzelijst Color

Paneel 
Properties

vervolgkeuzelijst Layer

paneel
Layers
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5 Klik op de knop met het groene vinkje boven in de Layer Properties Manager. Klik op OK om de 
geselecteerde laag als actieve laag in te stellen.

6 Klik nogmaals op de vervolgkeuzelijst Layer van het paneel Layers.

7 Klik op het gloeilampje voor de laag Dimension om deze uit te schakelen. Klik dan ergens in het 
tekengebied.

Alle objecten op de laag Dimension zijn nu verborgen.

8 U schakelt de laag Dimension weer in via de Layer Properties Manager.

9 Sluit de tekening zonder opslaan.

Lijntypen gebruiken

U kunt één lijntype aan alle objecten koppelen die op dezelfde laag getekend zijn, of lijntypen 
afzonderlijk aan objecten toewijzen.

Wilt u een lijntype gebruiken, dan moet u dit eerst via de Linetype Manager in uw tekening laden.

CONTINUOUS

HIDDEN

CENTER

PHANTOM
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Probeer het: Een lijntype laden en actief maken

1 Klik op de menubrowser ➤ File ➤ New, en selecteer een tekeningsjabloonbestand.

2 Klik op de menubrowser ➤ Format ➤ Linetype.

3 Klik op Load in het venster Linetype Manager.

4 In het diaIoogvenster Load or Reload Linetypes navigeert u naar de lijst met lijntypen en klikt u 
op HIDDENX2. Klik op OK.

5 Klik op Show Details.

Er worden nu verschillende schaalopties voor lijntypen weergegeven, waaronder de optie Use 
Paper Space Units for Scaling. Selecteer deze optie als u wilt dat lijntypen automatisch in lay-
outvensters worden geschaald.

6 Klik op het lijntype HIDDENX2 en selecteer Current. Klik op OK.

Op het paneel Properties op het lint wordt het lijntype HIDDENX2 als het actieve lijntype 
weergegeven in plaats van BYLAYER. Alle objecten die hierna worden gemaakt, worden met dit 
lijntype weergegeven. Deze instelling vervangt het lijntype dat aan de actieve laag is toegewezen.

7 Klik op de tab Model.

8 Klik op de menubrowser ➤ Draw ➤ Line, en klik op verschillende locaties in het tekengebied om 
lijnsegmenten te tekenen. Druk op ENTER om de opdracht te beëindigen.

9 Via de Linetype Manager of het paneel Properties kunt u het actieve lijntype weer op BYLAYER 
instellen.

Alle objecten die hierna worden gemaakt, worden weergegeven met het lijntype dat aan de actieve 
laag is toegewezen.
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Lijntypen schalen

Wanneer u aanzichten in lay-outvensters schaalt, kunt u inconsistenties in de weergave van 
lijntypen introduceren. In onderbroken lijntypen kunnen de lengte van streepjes en punten, en de 
afstand ertussen, langer of korter worden. U kunt de schaal instellen zodat deze met de schaal van 
het model of de lay-out overeenkomt, of bij elke zoomschaal hetzelfde blijft.

Gebruik het vak Details van de Linetype Manager om de schaal van het lijntype in lay-outvensters 
te bepalen.

■ Global Scale Factor. Hiermee wordt de algemene schaalfactor voor alle lijntypen ingesteld.
■ Current Object Scale. Hiermee kunt u de schaal van het lijntype instellen voor pas gemaakte 

objecten.
■ Use Paper Space Units for Scaling. Hiermee worden lijntypen in het papierkader en in het 

werkvlak op dezelfde manier geschaald.

Wilt u een lijntypeschaal updaten, dan moet u de werkvlakweergave binnen een lay-outvenster op 
het tabblad Layout opnieuw genereren. Dit doet u als volgt:

1 Klik op een lay-outtabblad.

2 Dubbelklik in een lay-outvenster om het werkvlak op te roepen.

3 Klik op de menubrowser ➤ View ➤ Regen.

De lijntypen in het lay-outvenster worden volgens de schaalinstelling voor vensterweergave op 
schaal gebracht.

Streepjeslijn op 
schaal van model

de streepjeslijn op 
schaal van lay-out
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Lijndikten toewijzen

Met lijndikten kunt u dikke en dunne lijnen maken om onderbrekingen in secties aan te geven, 
evenals de diepte van hoogten, maatlijnen en maatstreepjes, en verschillen in details. Lijndikten zijn 
niet afhankelijk van de actieve weergaveschaal. Objecten met een zwaardere lijndikte verschijnen 
altijd met de opgegeven lijnbreedte, ongeacht de weergaveschaal.

Probeer het: Een lijndikte kiezen en actief maken

1 Klik op de tab Model.

2 Klik op de menubrowser ➤ Format ➤ Lineweight.

3 In het dialoogvenster Lineweight Settings klikt u onder Lineweights op een zwaardere lijndikte 
zoals 0.50 mm of 0.020".

4 Klik eerst op Display Lineweight en dan op OK.

Het paneel Properties geeft de nieuwe lijndikte als de actieve dikte weer. Objecten die vanaf nu 
worden gemaakt, worden met de zwaardere lijndikte weergegeven.

5 Klik op de menubrowser ➤ Draw ➤ Line, en trek verschillende lijnsegmenten. Druk op ENTER.

6 Via het dialoogvenster Lineweight Settings of de werkbalk Properties kunt u het actieve lijntype 
weer op BYLAYER instellen.

Objecten die vanaf nu worden gemaakt, worden weergegeven met de lijndikte die aan de actieve 
laag is toegewezen.

7 Oefen met het instellen van lijntypen en lijndikten.

N.B. U kunt een kleur, lijntype of lijndikte aan afzonderlijke objecten toewijzen, ongeacht de instelling 
van de standaardlaag. U kunt deze eigenschappen afzonderlijk of per laag toewijzen, afhankelijk van uw 
tekeningopzet en bedrijfsstandaarden.
Overzicht van objecteigenschappen | 63



Lijnen tekenen

De lijn is het eenvoudigste object dat u zult gebruiken. Een lijn kan één segment zijn of een reeks 
opeenvolgende segmenten, maar elk segment is een apart lijnobject. Maak een polylijnobject als u 
een reeks lijnsegmenten als één object moet tekenen, zoals op een reliëfkaart.

Parallelle lijnen maken

Een verschoven lijn is een exacte kopie van een lijn, die met een specifieke afstand van die lijn 
getrokken is. Met de opdracht OFFSET kunt u parallelle lijnen maken, evenals concentrische cirkels 
en parallelle bogen.

Objecten verschuiven is een bijzonder efficiënte constructiemethode.

Probeer het: Een lijn verschuiven om parallelle lijnen te trekken

1 Trek een lijn.

2 Klik op de menubrowser ➤ Modify ➤ Offset.

3 Achter de prompt voor verschuivingsafstand typt u 10.

4 Klik op de lijn die u wilt verschuiven.

5 Klik op één zijde van de lijn.

6 Druk op ENTER om de opdracht te beëindigen.

Polylijnen en veelhoeken tekenen

Een polylijn bestaat uit een verbonden reeks van lijn- of boogsegmenten die als één object zijn 
gemaakt. Gebruik polylijnen om de volgende objecten te maken:

■ Sporen op printplaten
■ Randen
■ Contourlijnen, wegen en rivieren op kaarten
■ Segmenten met vaste of taps toelopende breedten

Veelhoeken zijn gesloten polylijnen met gelijke zijden en hoeken. De opdracht Polygon is de 
eenvoudigste methode om bijvoorbeeld gelijkzijdige driehoeken, vierkanten, vijfhoeken en 
zeshoeken te maken.

verschoven bogen
verschoven lijnen
64 | Hoofdstuk 5 Objecten tekenen



Polylijnen maken

U tekent elk polylijnsegment door een begin- en eindpunt op te geven. Wilt u nog meer segmenten 
tekenen, dan geeft u nog meer punten in uw tekening op.

Probeer het: Een polylijn maken

1 Klik op de menubrowser ➤ Draw ➤ Polyline.

2 Na elke prompt klikt u op een punt. Na meerdere punten voert u een van de volgende 
handelingen uit:

■ Druk op ENTER om de opdracht te beëindigen.
■ Typ c om een gesloten lus te maken.

3 Klik op de polylijn. De segmenten behoren alle tot één object.

U kunt boogsegmenten in polylijnen opnemen.

Probeer het: Een polylijn met boogsegmenten maken

1 Klik op de menubrowser ➤ Draw ➤ Polyline.

2 Maak een polylijnsegment (1 en 2).

3 Achter de prompt typt u a om naar Arc-modus over te gaan en met een boogsegment door te 
gaan (3).

4 Typ L om naar Line-modus terug te keren en een ander lijnsegment te tekenen.

5 Beëindig de opdracht.

Probeer het: Een rechthoek maken

1 Klik op de menubrowser ➤ Draw ➤ Rectangle.

2 Klik op een locatie op het scherm.

3 Verplaats de cursor diagonaal en klik op een andere locatie.

Het resulterende object is een gesloten polylijn in de vorm van een rechthoek.

eindpunt van boog laatste segment

3

2

1
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Probeer het: Een veelhoek maken

1 Klik op de menubrowser ➤ Draw ➤ Polygon.

2 Voer het aantal zijden in, bijvoorbeeld 6.

3 Klik op een locatie voor het midden van de veelhoek.

4 Specificeer de optie Inscribed of Circumscribed. Hiermee wordt bepaald hoe de afstand wordt 
gemeten die u achter de volgende prompt invoert.

5 U geeft een radius van een veelhoek op door een van de volgende handelingen uit te voeren:

■ Verplaats de cursor en klik op een locatie.
■ Voer een afstand in.

Het uiteindelijke object is ook een gesloten polylijn.

Nadat u een beginpunt voor een polylijn hebt opgegeven, kunt u via de opties Width en Halfwidth 
polylijnen met verschillende breedten tekenen. U kunt polylijnsegmenten ook taps laten toelopen. 

Nadat u een polylijn hebt gemaakt, kunt u het volgende doen:

■ De polylijn via de opdracht EXPLODE in onafhankelijke segmenten opsplitsen.
■ Gebruik de opdracht JOIN om een polylijn met een andere polylijn, lijn of boog te verbinden.

ingeschreven radius omschreven radius

gemengde breedteuniforme breedte taps toelopend segment
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Cirkels en bogen tekenen

U kunt verschillende gebogen objecten maken, zoals cirkels en bogen. 

Cirkels tekenen

Gebruik een van de volgende methoden om cirkels te maken:

■ Specificeer het middelpunt en de straal (standaardmethode).
■ Specificeer het middelpunt en de diameter.
■ Definieer de omtrek van de cirkel met twee of drie punten.
■ Maak een cirkel die twee bestaande objecten raakt. 
■ Maak een cirkel die twee objecten raakt en specificeer een straal.

Bogen tekenen

Als u bogen wilt tekenen, kunt u diverse waardecombinaties opgeven voor middelpunt, eindpunt, 
beginpunt, straal, hoek, koordelengte en richting. Hieronder wordt op drie manier geïllustreerd hoe 
u twee punten en een ingesloten hoek kunt opgeven.

straal

11

3

2

middelpunt

2

straal

raaklijnobjecten

Middelpunt, 
straal

Twee punten die 
diameter definiëren

Drie punten die 
omtrek definiëren

Raaklijn, raaklijn, 
straal

Begin, midden, hoek

1

Midden, begin, hoek

2

Begin, einde, hoek

1

2

ingesloten hoek

1

2
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N.B. Met de opdracht FILLET wordt een boog gemaakt die twee bestaande objecten raakt. Dit is vaak 
de aanbevolen methode om bogen te maken en wordt later besproken.

Testvragen

1 Wat is het resultaat wanneer u de kleur van een object op ByLayer instelt?

2 Wat is de snelste manier om een andere laag als actieve laag te selecteren?

3 Hoe verkrijgt u een complete lijst met eigenschappen van een object?

4 Wat is de aanbevolen opdracht om parallelle lijnen en bogen te maken?

5 Welk type object bestaat uit een reeks verbonden segmenten?

Aan de slag

Handeling Menubrowser Pictogram

Eigenschappen instellen Modify ➤ Properties

Lijntypen laden, schalen 
en beheren

Format ➤ Linetype

Lijndikte-instellingen wijzigen Format ➤ Lineweight

Lijnen trekken Draw ➤ Line  

Parallelle lijnen trekken Modify ➤ Offset  

Polylijnen trekken Draw ➤ Polyline

Veelhoeken tekenen Draw ➤ Polygon

Polylijnsegmenten opsplitsen Modify ➤ Explode

Polylijnen verbinden Modify ➤ Join

Cirkels tekenen Draw ➤ Circle  

Bogen tekenen Draw ➤ Arc  

Help-systeem

PROPERTIES, COLOR, LAYER, LINETYPE, LTSCALE, CELTSCALE, PSLTSCALE, LINEWEIGHT, LINE, OFFSET, 
PLINE, POLYGON, RECTANG, PEDIT, JOIN, EXPLODE, CIRCLE, ARC
68 | Hoofdstuk 5 Objecten tekenen



Voer coördinaatwaarden in om 
punten precies te vinden

Schakel polaire tracking in om 
langs opgegeven hoeken te 
tekenen

Schakel Ortho in om 
horizontale en verticale 
lijnen te trekken

Schakel de Grid- en Snap-
modus in om binnen een 
vooraf gedefinieerd kader 
te tekenen

Gebruik objectmag-
neten om exacte 
punten op objecten 
te vinden
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Raster- en magneetwaarden instellen

Met de raster- en magneetfuncties kunt u een kader opzetten dat u tijdens het tekenen als richtlijn 
kunt gebruiken.

■ Grid Met deze optie wordt een rechthoekig patroon van punten weergegeven dat zich uitspreidt 
over het gebied dat door de rastergrenzen van de tekening gespecificeerd wordt. Met behulp van 
het raster kunt u objecten uitlijnen en de afstanden ertussen beter bepalen. Het raster verschijnt 
niet in de geplotte tekening.

■ Snap In de Snap-modus (de magneetmodus) kan de cursor alleen worden verplaatst met 
intervallen die u hebt ingesteld. Wanneer de magneetmodus is ingeschakeld, lijkt het alsof de 
cursor een onzichtbaar raster volgt of ernaartoe 'springt'. De modus is handig voor het opgeven 
van exacte punten met de cursor.

De raster- en magneetafstand instellen

Het raster komt niet noodzakelijkerwijs met de actieve magneetinterval overeen. U kunt een grote 
rasterafstand instellen als referentie en een kleinere magneetafstand om nauwkeurig punten te 
kunnen opgeven. Zo kunt u de rasterafstand in een metrische tekening op 10 keer de 
magneetafstand instellen of 12 keer in een tekening in Engelse eenheden.

Probeer het: De cursor met Snap beperken

1 Begin een nieuwe tekening.

2 Klik op de statusbalk op de knop Snap.

De kleur van de knop verandert om aan te geven dat de modus Snap is ingeschakeld.

3 Verplaats de cursor in het tekengebied terwijl Snap ingeschakeld is.

Het lijkt nu alsof de cursor punten op gelijke intervallen in het tekengebied volgt of ernaartoe 
'springt'.

Probeer het: Een raster weergeven

1 Klik op de statusbalk op de knop Grid.

De rasterpunten bedekken een beperkt gebied, de rastergrenzen.

2 Schakel Grid en Snap uit.

Als u in- of uitzoomt, moet u de afstand tussen de rasterpunten soms aanpassen aan de nieuwe 
vergrotings- of verkleiningsfactor.
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Probeer het: De raster- en magneetafstand wijzigen

1 Klik met de rechtermuisknop op de knop Grid of Snap op de statusbalk.

2 Klik op Settings in het snelmenu.

3 Specificeer nieuwe afstanden voor Grid en Snap in het dialoogvenster Drafting Settings. 
Klik op OK.

4 Schakel Grid en Snap in.

Rastergrenzen instellen

Probeer het: De rastergrenzen wijzigen

1 Klik op de menubrowser ➤ Format ➤ Drawing Limits.

2 Klik op twee punten om de linkerbenedenhoek en de rechterbovenhoek van een rechthoekig 
gebied aan te duiden.

3 Herhaal dit met twee andere punten.

Rastergrenzen weergegeven 
door een reeks rasterpunten
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Tekenen met coördinaten

Coördinaten staan voor locaties in uw tekening. Wanneer u achter de opdrachtprompt een punt 
moet opgeven, kunt u met behulp van de cursor een punt in het tekengebied specificeren of 
coördinaatwaarden invoeren.

Cartesische coördinaten en poolcoördinaten gebruiken

In tweedimensionale ruimte specificeert u punten op een vlak dat te vergelijken is met een vel 
grafiekpapier. U kunt tweedimensionale coördinaten als Cartesische coördinaten (X,Y) of 
poolcoördinaten (afstand<hoek) invoeren. 

■ Cartesische coördinaten worden gemeten vanaf twee loodlijnen, de X-as en de Y-as. De X-waarde 
geeft de horizontale afstand aan en de Y-waarde de verticale afstand. Zo staan de coördinaten 
5,3 voor een punt dat zich 5 eenheden langs de X-as en 3 eenheden langs de Y-as bevindt. 
De oorsprong (0,0) geeft aan waar de twee assen elkaar snijden.

■ Poolcoördinaten maken gebruik van een afstand en een hoek om een punt te markeren. 
Zo duiden de coördinaten 5<30 een punt aan dat zich 5 eenheden van de oorsprong bevindt, met 
een hoek van 30 graden van de X-as.

U kunt bij elke methode absolute of relatieve waarden gebruiken. Absolute coördinaatwaarden zijn 
op de oorsprong gebaseerd. Relatieve coördinaten zijn gebaseerd op het laatst ingevoerde punt.

Met absolute Cartesische coördinaten tekenen

Gebruik absolute Cartesische coördinaten wanneer u de exacte X- en Y-waarden weet voor de locatie 
van het punt. De lijn in de illustratie begint bijvoorbeeld bij een X-waarde van –2 en een Y-waarde 
van 1 en eindigt op 3,4. Op de opdrachtregel werd het volgende ingevoerd:

Command: line
Specify first point: #–2,1
Specify next point or [Undo]: #3,4

0,0-2,1

3,4
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Met # wordt aangegeven dat de coördinaten absolute coördinaten zijn.

Met relatieve Cartesische coördinaten tekenen

Gebruik relatieve Cartesische coördinaten wanneer u de locatie van een punt ten opzichte van het 
vorige punt weet. Als u bijvoorbeeld een punt relatief aan de absolute coördinaten –2,1 wilt bepalen, 
start u de volgende coördinaten met het symbool @.

Command: line
Specify first point: #–2,1
Specify next point or [Undo]: @5,3

Met @5,3 wordt in dit voorbeeld hetzelfde punt gevonden als met #3,4 in het vorige voorbeeld.

N.B. Absolute coördinaten worden anders ingevoerd als de knop Dynamic Input aan de linkerkant van 
de statusbalk is uitgeschakeld. In dat geval wordt # niet gebruikt om absolute coördinaten op te geven.
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Naar exacte punten op objecten uitlijnen

Objectmagneten zijn de belangrijkste manier om een exacte locatie op een object aan te geven, zonder 
coördinaten te hoeven gebruiken. Met een objectmagneet kunt u bijvoorbeeld een lijn trekken naar 
het exacte midden van een cirkel, naar het eindpunt van een ander lijnsegment of de raaklijn op een 
boog. 

U kunt een objectmagneet opgeven telkens wanneer u wordt gevraagd een punt op te geven. 
Wanneer u uw cursor over een object beweegt, wordt met AutoSnap-markeringen en knopinfo een 
actief objectmagneetpunt aangegeven.

Eenmalige objectmagneten gebruiken

U kunt bij elke prompt om een punt een eenmalige objectmagneet opgeven. Houd hiervoor SHIFT 
ingedrukt, klik met de rechtermuisknop en kies een objectmagneet uit het menu Object Snap. 

Nadat u een objectmagneet hebt opgegeven, kunt u met behulp van de cursor een locatie op een 
object selecteren.

N.B. Druk op TAB om alle beschikbare objectmagneetpunten voor een bepaald object te doorlopen.

Druk op SHIFT en klik met de 
rechtermuisknop om het 
objectmagneetmenu weer te 
geven.

objectmagneten
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Actieve objectmagneten instellen

Wilt u dezelfde objectmagneet herhaaldelijk gebruiken, dan stelt u deze als een actieve 
objectmagneet in. De magneet blijft actief totdat u deze uitschakelt. U kunt Center bijvoorbeeld als 
een actieve magneet instellen als u de middelpunten van een reeks cirkels met een lijn wilt 
verbinden.

U kunt meerdere actieve objectmagneten instellen, zoals Endpoint en Center, als actieve 
objectmagneten. Actieve objectmagneten kunnen via de statusbalk in- en uitgeschakeld worden.

Probeer het: De instellingen voor actieve objectmagneten wijzigen

1 Klik met de rechtermuisknop op Object Snap op de statusbalk.

2 Klik op Settings in het snelmenu.

3 Selecteer de gewenste objectmagneten in het dialoogvenster Drafting Settings. Klik op OK.

4 Teken verschillende lijnen en cirkels met behulp van objectmagneten om punten precies te 
bepalen.
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Beschrijvingen van objectmagneten

In de volgende tabel ziet u vaak gebruikte objectmagneten.

Objectmagneet Springt naar

Endpoint Eindpunten van objecten

Midpoint Middelpunten van objecten

Intersection
Snijpunten van objecten of, voor eenmalige 
objectmagneten, locaties die snijpunten zouden 
zijn als objecten uitgebreid werden

Center

Hartpunten van cirkels, bogen of ellipsen

Quadrant

Kwadranten van bogen, cirkels of ellipsen

Perpendicular

Punten op objecten die loodrecht op het laatst 
opgegeven punt zijn uitgelijnd

Tangent
Punten op een cirkel of boog die, wanneer 
verbonden met het laatste punt, een lijn geeft die 
het object raakt
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Hoeken en afstanden opgeven

U kunt snel hoeken en afstanden opgeven met behulp van functies voor polaire tracking, directe 
invoer van afstand, en vervangende hoeken.

Polaire tracking gebruiken

Terwijl u lijnen tekent of objecten verplaatst, kunt u polaire tracking gebruiken om de beweging van 
de cursor tot opgegeven hoekvergrotingen (de standaardwaarde is 90 graden) te beperken. U kunt 
bijvoorbeeld snel een reeks loodlijnen tekenen door de Polar in te schakelen voordat u gaat tekenen. 
Aangezien de lijnen beperkt zijn tot de horizontale en verticale as, kunt u sneller tekenen, in de 
wetenschap dat de lijnen loodrecht zijn.

Probeer het: Polaire tracking gebruiken

1 Klik op Polar Tracking op de statusbalk om dit in te schakelen.

2 Teken verschillende lijnen op 90 graden van elkaar.

Afstanden opgeven

Voer afstand direct in om snel een exacte lijnlengte op te geven. Verplaats hiervoor de cursor om een 
richting aan te geven en voer dan de afstand vanaf het eerste punt in. Wanneer polaire tracking is 
ingeschakeld, kunt u met directe invoer van afstand efficiënt loodlijnen van een bepaalde lengte 
tekenen. 

Bij polaire tracking wordt de beweging van 
de cursor tot bepaalde hoeken beperkt.

uitlijningspad

knopinfo over afstand en hoek

Polar: 1.5<45

Polaire tracking beperkt de cursor tot 
een hoek, in dit geval van 180 graden...

vervolgens bepaalt directe invoer van 
afstand de exacte lengte van de lijn, in 
dit geval 1000
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Probeer het: Verschillende lijnen van opgegeven lengtes tekenen

1 Klik op de menubrowser ➤ Draw ➤ Line.

2 Klik op een punt en verplaats de cursor dan naar rechts (0 graden).

3 Voer een waarde in.

4 Verplaats de cursor omhoog (90 graden) en voer een andere waarde in.

5 Herhaal dit nog een aantal malen en druk op ENTER.

Een hoek opgeven

Als de hoek die u wilt gebruiken, niet vaak gebruikt zal worden, kunt u een vervangende hoek opgeven. 
Als u een lijn bijvoorbeeld bij de coördinaten –2,1 begint en de lijn een hoek van 10 graden en een 
lengte van 50 wilt geven, voert u het volgende in

Command: line

Specify first point: #–2,1

Specify next point or [Undo]: <10

(Verplaats de cursor in de gewenste richting)

Specify next point or [Undo]: 50

Studieles: Nauwkeurig tekenen

In deze studieles oefent u met verschillende nauwkeurige tekenfuncties om de volgende tekening te 
maken. Deze tekening kan de basis vormen voor een ontwerp van

■ een beautycentrum met zwembad
■ een onderdeel van een raamsluiting
■ een behuizing voor een motormontage

N.B. Het is belangrijk deze tekening op te slaan terwijl u werkt. De tekening zal voor verschillende 
andere studielessen in deze handleiding gebruikt worden.
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Een nieuwe tekening beginnen

1 Klik op de menubrowser ➤ File ➤ New.

2 Selecteer het tekeningsjabloonbestand uit de studieles dat het beste bij uw voorgenomen 
toepassing en maateenheden past.

■ Tutorial-mArch.dwt. Bouwkundige voorbeeldsjabloon (metrisch)
■ Tutorial-mMfg.dwt. Voorbeeldsjabloon voor mechanisch ontwerp (metrisch)
■ Tutorial-iArch.dwt. Bouwkundige voorbeeldsjabloon (Engels)
■ Tutorial-iMfg.dwt. Voorbeeldsjabloon voor mechanisch ontwerp (Engels)

3 Klik op de tab Model.

4 Klik op File ➤ Save. Geef MyDesign als bestandsnaam.

Een tekening maken met Grid en Snap

1 Schakel Grid en Snap in op de statusbalk. Dynamic Input moet ook ingeschakeld zijn.

2 Klik op de menubrowser ➤ Draw ➤ Line, en klik op verschillende locaties om een reeks 
lijnsegmenten te maken waarmee u het eerder weergegeven ontwerp kunt maken. De exacte 
bematingen doen er niet toe, maar gebruik redelijke afstanden voor het ontwerp. Druk op ENTER 
om de opdracht te beëindigen.

3 Klik op de menubrowser ➤ Draw ➤ Circle ➤ Center, Radius.

4 Klik op een punt om het midden van de cirkel te bepalen, en klik dan op een ander punt om de 
straal op te geven.

5 Schakel Grid en Snap uit.

Een lijn maken met objectmagneten

1 Klik op de menubrowser ➤ Modify ➤ Erase.

De kruiscursor verandert in een vierkant selectiekader.

2 Klik rechtstreeks op een van de lijnen die u gemaakt hebt, en druk dan op ENTER.

De lijn wordt gewist, maar hoe maakt u nauwkeurig een andere vervangende lijn?

3 Klik op de menubrowser ➤ Draw ➤ Line.

4 Druk op SHIFT en klik met de rechtermuisknop. Klik op Endpoint in het menu Object Snap.

5 Beweeg de cursor over een eindpunt van een lijn. Klik wanneer u een AutoSnap-markering ziet.

6 Druk op SHIFT en klik nogmaals met de rechtermuisknop. Klik op Endpoint in het menu Object 
Snap.

7 Zet de cursor op het tegenovergestelde eindpunt en klik. Druk op ENTER om de opdracht te 
beëindigen.

De eindpunten van de nieuwe lijn bevinden zich precies op de eindpunten van de aangrenzende 
lijnen.
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8 Doe het volgende:

■ Gebruik de volgende objectmagneten om met het trekken van lijnen te experimenteren: 
Midpoint, Center, Perpendicular en Tangent.

■ Schakel actieve objectmagneten in en trek nog een aantal lijnen.
■ Trek een lijn vanuit het midden van de cirkel met een hoek van 30 graden en een lengte van 

10 eenheden.

9 Wis alle objecten die geen deel uitmaken van het geïllustreerde resultaat.

10 Sla de tekening op. Geef MyDesign als de bestandsnaam op.

Testvragen

1 Hoe schakelt u de rasterpunten in uw tekengebied uit?

2 Naar welke coördinaatwaarden verwijst de term oorsprong?

3 Welk snelmenu verschijnt wanneer u SHIFT ingedrukt houdt terwijl u met de rechtermuisknop klikt?

4 Welke knop kunt u inschakelen om ervoor te zorgen dat de lijn die u trekt, zuiver verticaal is?

5 Wat wordt bedoeld met directe invoer van afstand?

Aan de slag

Handeling Menubrowser

De raster- en magneetafstand instellen Tools ➤ Drafting Settings, tabblad Snap and Grid

Eenmalige objectmagneten gebruiken SHIFT+klikken met rechtermuisknop om het
objectmagneetmenu weer te geven

 

Actieve objectmagneten instellen Tools ➤ Drafting Settings, tabblad Object Snap

AutoSnap-instellingen wijzigen Tools ➤ Options, tabblad Drafting

Polaire instellingen wijzigen Tools ➤ Drafting Settings

Help-systeem

GRID, SNAP, DSETTINGS, LIMITS, UCS, DYNMODE, OSNAP, OPTIONS
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Gebruik COPY om kopieën op 
opgegeven locaties te maken

Gebruik MIRROR om een exacte replica 
van objecten te maken langs een spiegellijn

Gebruik DIST om de afstand tussen 
twee punten te meten

Gebruik FILLET om twee 
lijnen met een boog te 
verbinden

Gebruik OFFSET om parallelle 
lijnen en concentrische cirkels 
te maken

Gebruik TRIM om de delen van 
objecten te verwijderen die voorbij 
de opgegeven snijranden uitsteken
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Objecten selecteren voor bewerking

Wanneer u objecten bewerkt, selecteert u een of meer objecten om een selectiegroep van de objecten 
te specificeren. Er zijn twee methoden om op te geven welke objecten moeten worden gewijzigd:

■ Kies de opdracht eerst. Kies een bewerkingsopdracht en selecteer dan objecten om te wijzigen.
■ Kies de objecten eerst. Selecteer objecten en start dan de bewerkingsopdracht. Wanneer u deze 

methode gebruikt, worden er bovendien grips op de objecten weergegeven, waarmee u de 
objecten direct kunt wijzigen. U kunt een selectie wissen door op ESC te drukken.

Methoden voor objectselectie

De twee meest gebruikelijke methoden om objecten te selecteren zijn:

■ Afzonderlijke objecten selecteren. Klik objecten een voor een aan.
■ Specificeer een selectiegebied. Klik om een rechthoekig gebied rond de te selecteren objecten te 

vormen.

Een selectiegebied specificeren

U kunt objecten selecteren door ze in een rechthoekig selectiegebied op te nemen. U definieert een 
rechthoekig selectiegebied in het tekengebied door op tegenover elkaar liggende hoeken te klikken. 
De volgorde waarin u de hoeken specificeert, maakt verschil. 

■ Sleep van links naar rechts om een vensterselectie te maken, waarbij alleen objecten worden 
geselecteerd die volledig binnen het selectiegebied liggen. 

■ Sleep van rechts naar links om een overlappend selectievenster te maken, waarbij objecten worden 
geselecteerd die het selectiegebied overlappen of er volledig binnen liggen.

N.B. U kunt objecten uit de selectiegroep verwijderen door op SHIFT te drukken en de objecten dan 
aan te klikken.

Objecten geselecteerd met vensterselectie 

1

2
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Objecten wissen, verlengen en bijsnijden

Met deze methoden worden objecten verwijderd of hun lengten gewijzigd:

■ Erase verwijdert het gehele object.
■ Extend verlengt een object tot een nauwkeurige grens.
■ Trim verkort een object tot een nauwkeurige grens en verwijdert de rest.

Objecten wissen

U kunt alle objectselectiemethoden met de opdracht ERASE gebruiken. In het voorbeeld wordt 
weergegeven hoe u vensterselectie gebruikt om een deel van een pijp te wissen. 

Probeer het: Oefen met vensterselectie en overlappend selectievenster

1 Klik op de menubrowser ➤ File ➤ New.

2 Maak wat lijnen, bogen en cirkels.

3 Klik op de menubrowser ➤ Modify ➤ Erase.

4 Selecteer verschillende objecten met een overlappend selectievenster en druk op ENTER.

Kijk welke objecten worden geselecteerd en gewist.

5 Selecteer een aantal andere objecten met een vensterselectie en druk op ENTER.

Kijk weer welke objecten worden geselecteerd en gewist.

6 Selecteer de andere objecten afzonderlijk die u in stap 1 hebt gemaakt, en druk op ENTER om ze 
te wissen.

1

2

ResultaatGeselecteerde 
objecten

Objecten geselecteerd 
met vensterselectie 
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Objecten verlengen

U kunt objecten verlengen zodat ze precies ophouden bij een grens die door andere objecten wordt 
aangegeven. Als u op ENTER drukt in plaats van grensobjecten te selecteren, worden alle zichtbare 
objecten in de tekening potentiële grenzen. In de afbeelding worden lijnen weergegeven die precies 
zijn verlengd tot de cirkel, die de dichtstbijzijnde grens is.

Probeer het: Een object verlengen

1 Maak een korte lijn. Maak dan een cirkel die de lijn omvat.

2 Klik op de menubrowser ➤ Modify ➤ Extend.

3 Bij de prompt Select Objects klikt u op de cirkel.

De grensobjecten moeten eerst geselecteerd worden. De volgende stap kan gemakkelijk vergeten 
worden.

4 Druk op ENTER om grensselectie te beëindigen.

5 Bij de volgende prompt Select Objects klikt u op het ene uiteinde van de lijn en dan op het 
andere. Druk op ENTER om de opdracht te beëindigen.

Objecten bijsnijden

Objecten bijsnijden is vrijwel hetzelfde als objecten verlengen. Als u een object bijsnijdt, snijdt u het 
af bij een rand die door een of meer objecten wordt aangegeven. Objecten die als snijranden zijn 
gedefinieerd, moeten standaard het bij te snijden object snijden.

Selecteer te verlengen objecten zo 
dicht mogelijk bij het uiteinde dat 
verlengd moet worden

Druk op ENTER om alle 
objecten als grenzen te 
accepteren

Resultaat

Snijranden geselecteerd 
met een overlappend 
selectievenster 

Bij te snijden object 
geselecteerd

Resultaat

1

2

3
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Probeer het: Een object bijsnijden

1 Maak twee horizontale lijnen en twee verticale lijnen zoals aan de linkerkant van de afbeelding 
te zien is.

U kunt de objectmagneet Perpendicular gebruiken om ervoor te zorgen dat de twee horizontale 
lijnen de verticale lijn in een rechte hoek snijden.

2 Klik op de menubrowser ➤ Modify ➤ Trim.

3 Bij de prompt Select Objects klikt u op locaties 1 en 2 zoals eerder is weergegeven.

De grensobjecten moeten eerst geselecteerd worden.

4 Druk op ENTER om grensselectie te beëindigen.

5 Bij de volgende prompt Select Objects klikt u op de verticale lijn bij punt 3, zoals weergegeven. 
Druk op ENTER om de opdracht te beëindigen.

N.B. Met zowel EXTEND als TRIM moet u de selectiegroep grensobjecten accepteren door op ENTER 
te drukken, en vervolgens de objecten selecteren die moeten worden bijgesneden. Als u op ENTER drukt 
zonder grensobjecten te selecteren, worden alle objecten potentiële grenzen.
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Objecten dupliceren

Er zijn verschillende manieren om kopieën van objecten te maken: 

■ Copy maakt nieuwe objecten op een gespecificeerde locatie.
■ Offset maakt nieuwe objecten op een gespecificeerde afstand van geselecteerde objecten of via 

een opgegeven punt.
■ Mirror maakt een spiegelbeeld van objecten rond een gespecificeerde spiegellijn.

Objecten kopiëren

Als u een object wilt kopiëren, selecteert u een of meer objecten, specificeert u een beginpunt (een 
basispunt genoemd) en geeft u vervolgens een tweede punt op om de afstand en richting van de 
kopie te bepalen. De twee punten kunnen zich overal in de tekening bevinden. In de volgende 
afbeelding wordt de cirkel bijvoorbeeld uit één rechthoek naar een corresponderende locatie op de 
tweede rechthoek gekopieerd.

Probeer het: Een object kopiëren

1 Maak twee rechthoeken en een cirkel zoals aan de linkerkant van de vorige afbeelding te zien is.

2 Klik op de menubrowser ➤ Modify ➤ Copy.

3 Bij de prompt Select Objects klikt u op de cirkel en drukt u op ENTER.

4 Bij de prompt Specify Base Point drukt u op SHIFT en klikt u met de rechtermuisknop om het 
objectmagneetmenu weer te geven. Klik op Endpoint.

5 Klik op de hoek van de rechthoek bij punt 2, zoals weergegeven.

Resultaat1 Selecteer de cirkel

2 Specificeer een basispunt (objectmagneet Endpoint)

3 Specificeer een tweede punt (objectmagneet Endpoint)
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6 Bij de prompt Specify Second Point drukt u op SHIFT en klikt u met de rechtermuisknop om het 
objectmagneetmenu weer te geven. Klik op Endpoint.

7 Klik op de hoek van de andere rechthoek bij punt 3, zoals weergegeven.

8 Druk op ENTER om de opdracht te beëindigen.

De gekopieerde cirkel staat ten opzichte van de omringende rechthoek op dezelfde locatie als de 
oorspronkelijke cirkel.

U kunt ook objecten kopiëren door een basispunt op te geven, gevolgd door directe invoer van 
afstand, meestal met polaire magneten ingeschakeld.

De opdracht Copy wordt automatisch herhaald zodat u gemakkelijk meerdere objecten kunt maken.

Objecten 
geselecteerd 

Basispunt opgegeven en 
een afstand ingevoerd

Resultaat

voer een afstand in

Object geselecteerd (struik) Resultaat

basispunt

volgend punt

volgend punt
volgend punt

tweede punt
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Objecten verschuiven

Met verschuiven wordt er een nieuw object gemaakt dat een geselecteerd object op een 
gespecificeerde afstand lijkt te volgen. Bij verschuiving van cirkels worden grotere of kleinere cirkels 
gemaakt, afhankelijk van de verschuivingskant. Gebruik verschuiving om op een gemakkelijke 
manier parallelle lijnen of concentrische cirkels te maken.

N.B. Een zeer efficiënte tekentechniek is verschillende objecten te verschuiven en ze dan bij te snijden 
of te verlengen.

Objecten spiegelen

U spiegelt objecten rond een spiegellijn, die u met twee punten definieert. U kunt dan kiezen de 
oorspronkelijke objecten te verwijderen of te behouden.

Spiegeling is handig om symmetrische objecten te maken. U kunt de helft van het object tekenen 
en deze snel spiegelen in plaats van het gehele object te tekenen.

objectverschuiving

oorspronkelijk object

1

2 3

spiegellijn

Objecten geselecteerd Spiegellijn gedefinieerd Resultaat met oorspronkelijk 
object behouden

4

Objecten geselecteerd 
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Objecten verplaatsen en roteren

Een belangrijke tekentechniek is een of meer objecten te maken en dan naar de juiste locatie te 
verplaatsen of roteren.

Objecten verplaatsen

U verplaatst objecten op dezelfde manier als dat u ze kopieert. U selecteert het object dat u wilt 
verplaatsen, specificeert het basispunt (1) en geeft dan een tweede punt op om de afstand en richting 
van de verplaatsing te bepalen (2). In de afbeelding wordt het raam via deze stappen hoger en weg 
van de deur geplaatst. 

Objecten roteren

U roteert objecten door een basispunt en een rotatiehoek te specificeren. U kunt de rotatiehoek 
specificeren door een punt op te geven of een waarde voor de hoek in te voeren.

In het volgende voorbeeld specificeert u het basispunt (1) en een tweede punt (2) dat de rotatiehoek 
(2) voor de oriëntatie van een huis bepaalt.

In plaats van het tweede punt op te geven in het voorbeeld, kunt u -35 invoeren om de rotatie in 
graden te specificeren.

N.B. Een positieve hoek resulteert standaard in een rotatie tegen de klok in. Deze instelling kan echter 
gewijzigd worden met de opdracht Units.

1 2

Selecteer objecten, en specificeer het 
basispunt en de nieuwe locatie van de 
geselecteerde objecten.

Objecten geselecteerd Resultaat

1

Basispunt en 
rotatiehoek

2
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Hoeken afronden

Met afronding worden twee objecten verbonden door een boog die de objecten raakt en een 
opgegeven straal heeft. 

Gebruik de optie Radius van de opdracht Fillet om de boogstraal van de afronding te specificeren. 
Wanneer u de straal wijzigt, wordt de standaardstraal voor erop volgende afrondingen ingesteld. 
De afgeronde objecten worden standaard bijgesneden zoals in de afbeelding is weergegeven.

Een handige techniek is de afrondingsstraal op 0 in te stellen. Dit resulteert in twee objecten die 
elkaar in een scherpe hoek snijden, zoals weergegeven. Er wordt geen boog gemaakt.

N.B. Als u tijdens het selecteren van de objecten SHIFT ingedrukt houdt, wordt de huidige 
afrondingsstraal vervangen door de waarde 0.

U kunt ook cirkels, bogen en polylijnen afronden. Er is meer dan één afronding tussen cirkels en 
bogen mogelijk, afhankelijk van waar u de objecten selecteert.

Objecten geselecteerd Resultaat

Straal op 0 ingesteld, 
objecten geselecteerd 

Resultaat
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Studieles: Objecten met precisie wijzigen

In de volgende studieles gebruikt u nauwkeurige tekentechnieken om een deel van een percelenkaart 
te wijzigen.

De eigenaars van de percelen naast een leeg stadsperceel hebben hun gemeenteraad overgehaald hen 
toestemming te geven het perceel te kopen. Het enige vereiste was dat de eigenaars akkoord moesten 
gaan met een rechtvaardige verdeling.

Hoe zou u het lege perceel verdelen?

Volgens het voorstel dat door de eigenaars werd geaccepteerd, werden perceel 26 en 27 zodanig 
uitgebreid dat hun totale perceelgrootten gelijk waren. Het hek tussen perceel 38 en 39 werd 
verlengd. Perceel 38 was groter dan de andere percelen, maar dit voordeel woog op tegen zijn 
onregelmatige vorm.

leeg perceel
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Gebruik de volgende procedure om de grenzen van de percelen te wijzigen.

1 Klik op de menubrowser ➤ File ➤ Open.

2 In het dialoogvenster Select File zoekt u naar de map \Help\GettingStarted in de productmap van 
AutoCAD of AutoCAD LT. Hierin opent u het bestand map.dwg.

3 Schakel de tekstlaag uit om de weergave te vereenvoudigen.

Aan de linkerkant van het driehoekige perceel maakt u eerst een nieuwe perceellijn. Het bovenste 
uiteinde van de nieuwe perceellijn wordt met 25,73 feet verschoven, en het onderste uiteinde 
met 39,94 feet. Deze afstanden werden proefondervindelijk bepaald om perceel 26 en 27 
ongeveer even groot te maken, maar zonder perceel 38 te smal of groot te maken.

U kunt wat 'constructiegeometrie' maken om deze taak gemakkelijker te kunnen uitvoeren.

4 Gebruik de opdracht Circle en objectmagneten om een cirkel met een straal van 25,73 en een 
cirkel met een straal van 39,94 te maken met hun middellpunten op de snijpunten, zoals in de 
afbeelding is weergegeven.
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5 Gebruik Intersection-objectmagneten om een nieuwe perceellijn te maken, zoals in de afbeelding 
is weergegeven.

6 Wis de oude perceellijn en de twee constructiecirkels.
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Verleng de oude perceellijn dan tot de nieuwe.

7 Klik op de menubrowser ➤ Modify ➤ Extend.

8 Klik op de nieuwe perceellijn. Deze lijn is de grens tot waar de oude perceellijn moet worden 
verlengd.

9 Druk op ENTER. Deze handeling is belangrijk en wordt gemakkelijk vergeten. Hiermee worden 
de objecten die als grenzen dienen, onderscheiden van de objecten die worden verlengd.

10 Klik op de oude perceellijn dicht bij het uiteinde dat moet worden verlengd, zoals weergegeven. 
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11 Druk op ENTER om de opdracht te beëindigen.

12 Gebruik dezelfde methode om de andere perceellijn tot de onderste rand te verlengen. 

13 Wis de oude perceellijnen om het lange, smalle perceel zichtbaar te maken.
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14 Teken met de objectmagneet Endpoint een korte perceellijn tussen de eindpunten van de 
perceellijnen, zoals weergegeven.

De nieuwe perceellijnen zijn nu voltooid. Maar hoe kunt u de nieuwe oppervlakten van de percelen 
vinden?

De oppervlakten van de percelen vinden

1 Typ boundary op de opdrachtregel.

2 Klik op Pick Points in het dialoogvenster Boundary Creation. Klik dan binnen elk van de 
percelen. Druk op ENTER om de opdracht te beëindigen.

Er wordt een gesloten polylijnobject gemaakt met de perceellijnen voor elk perceel. Deze 
gesloten polylijnen worden over de bestaande perceellijnen weergegeven en kunnen later 
worden gewist.
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N.B. Wanneer u uw cursor over de kaart verplaatst, worden er verschillende polylijnen gemarkeerd. 
Waar de polylijnen dezelfde grens delen, wordt slechts één polylijn gemarkeerd. Druk herhaaldelijk 
SHIFT en SPATIEBALK in op een gedeelde grens om tussen de overlappende objecten op die locatie 
te schakelen.

3 Klik op de menubrowser ➤ Modify ➤ Properties.

4 Klik op een van de grenzen en zoek de oppervlakte die op het palet Properties wordt 
weergegeven.

5 Druk op ESC om de selectie te wissen.

6 Vind de oppervlakte van alle andere percelen.

7 Sluit de kaarttekening zonder opslaan.

Studieles: Een nieuwe tekening met precisie maken

In de volgende studieles maakt u een gedetailleerde tekening van een type straalmotormontage die 
wordt gebruikt om straalmotoren aan commerciële luchtvaartuigen te bevestigen. U zult blij zijn te 
horen dat dit onderdeel van een uiterst sterke nikkel-chroom-ijzerlegering wordt gemaakt.

N.B. Niet alle stappen in deze studieles worden in detail besproken. Wanneer u twijfelt, kunt u eerdere 
delen van deze gids bekijken of het Help-systeem gebruiken. U kunt alle opdrachten in deze studieles 
oproepen via de menu's Draw en Modify.
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1 Begin een nieuwe tekening met het tekeningsjabloonbestand Tutorial-mMfg.dwt.

Deze sjabloon is voor mechanisch-ontwerptekeningen die metrische eenheden gebruiken. 
Hierbij wordt aangenomen dat alle afstanden in millimeters zijn.

2 Klik op de knop Model op de statusbalk.

3 Zorg ervoor dat de knoppen Polar en Osnap op de statusbalk zijn ingeschakeld. De actieve laag 
moet Model-Front zijn.

Het vooraanzicht maken

1 Maak een cirkel met een diameter (niet een straal) van 50 mm op de coördinaten 180,100.

N.B. De precieze locatie van deze cirkel is niet cruciaal in deze studieles, maar het is een goed idee 
ervoor te zorgen dat een aantal belangrijke elementen met magneetpunten samenvallen. Voor 
tekeningen met één aanzicht of 3D-modellen kunt u het beste een belangrijk element op de 
oorsprong (0,0) plaatsen. Dit is handig wanneer u naar een tekening verwijst vanuit een andere 
tekening, zoals bij assemblagetekeningen.

2 Gebruik de objectmagneet Center om een cirkel met een diameter van 24 en met het hartpunt 
van de vorige cirkel te tekenen.

De objectmagneet Center is misschien geen objectmagneet die standaard actief is. Druk op SHIFT 
en klik met de rechtermuisknop om het objectmagneetmenu op te roepen.

3 Kopieer de twee cirkels naar een locatie 125 mm naar rechts door de hoek op 0 graden te 
vergrendelen met behulp van PolarSnap.

Command: copy
Select objects: Selecteer de twee cirkels en druk op ENTER
Specify base point or [Displacement/mOde]: <Displacement> Klik in het midden van de cirkels en 
verplaats uw cursor naar rechts
Specify second point or <use first point as displacement>: 125
Specify second point or [Exit/Undo]: Druk op ENTER

4 Verschuif de binnenste cirkel aan de linkerkant 4 mm naar buiten.

Command: verplaatsing
Specify offset distance or [Through/Erase/Layer]: 4
Select object to offset or [Exit/Undo]: Selecteer de linker binnenste cirkel
Specify point on side to offset or [Exit/Multiple/Undo]: Klik ergens buiten de cirkels
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5 Maak een cirkel met behulp van de TTR-optie (raaklijn-raaklijn-straal). De straal moet 250 mm 
zijn. De AutoSnap-markering voor de raaklijn wordt automatisch ingeschakeld.

Command: cirkel
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: t
Specify point on object for first tangent of circle: Selecteer een buitencirkel dicht bij de verwachte locatie 
van de raaklijn
Specify point on object for second tangent of circle: Selecteer de andere buitencirkel zoals weergegeven
Specify radius of circle: 250 (in de afbeelding wordt slechts een deel van de cirkel weergegeven)

6 Snijd de grote cirkel bij zoals hieronder wordt weergegeven.

7 Gebruik de opdracht Mirror om de boog te spiegelen met behulp van de hartpunten van de 
linker- en rechtercirkels om de spiegellijn te definiëren. Druk weer op SHIFT en klik met de 
rechtermuisknop om het objectmagneetmenu op te roepen.

Er zijn vaak alternatieve methoden voor elke stap. Voor het maken van de onderste boog had u 
bijvoorbeeld de opdracht Fillet kunnen gebruiken om de twee buitenste cirkels met een straal 
van 250 mm af te ronden.
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8 Snijd de buitenste linkercirkel bij zoals weergegeven.

Het vooraanzicht van het onderdeel is voltooid. Nu gebruikt u de objecten in het vooraanzicht om 
het bovenaanzicht van het onderdeel te maken.

Het bovenaanzicht maken

1 Stel de actieve laag op Model-Top in. U kunt de vervolgkeuzelijst Layer op de werkbalk Layers 
gebruiken, of de Layer Properties Manager.

2 Gebruik de objectmagneet Quadrant om een lijn te maken die aan de linkerkant van het 
onderdeel begint. Met de polaire magneet ingeschakeld verplaatst u de cursor omhoog en voert 
u 100 in om de lijn 100 mm lang te maken. Maak nog een lijn van 100 mm aan de rechterkant 
van het onderdeel.

3 Gebruik de objectmagneet Endpoint om een lijn te maken die de bovenste uiteinden van de 
verticale lijnen verbindt.
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4 Verschuif de horizontale lijn 12 mm omlaag.

5 Snijd de onderste uiteinden van de verticale lijnen bij om de rechthoekige omtrek van het 
bovenaanzicht te maken.

6 Verschuif de bovenste horizontale lijn 3 mm omhoog. Maak verticale lijnen van de kwadranten 
van de andere cirkels, zoals weergegeven.

7 Snijd de vier verticale lijnen bij die de silhouetranden van de gaten representeren, zoals 
weergegeven. Vergeet niet op ENTER te drukken nadat u de horizontale grenslijn voor de 
bijsnijding hebt geselecteerd.

grenslijn 
voor bijsnijding
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8 Snijd de andere verticale lijnen bij zoals weergegeven. Zoom en pan indien nodig.

9 Snijd de bovenste horizontale lijn bij zoals weergegeven. 

10 Maak een verticale lijn die bij het eindpunt van de boog begint en loodrecht op de horizontale 
lijn eindigt, zoals weergegeven. Deze lijn is de bijsnijdgrens voor de uitloop op het onderdeel.

11 Snijd de horizontale lijn tot de grenslijn bij, zoals weergegeven.

12 Wis de verticale grenslijn voor bijsnijden.

grenslijn 
voor bijsnijding

grenslijn 
voor bijsnijding

wis lijn
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13 Verleng de resterende verticale lijn zoals weergegeven.

14 Pas afrondingen van 1 mm toe op de buitenhoeken.

Het bovenaanzicht is bijna voltooid. U moet de verborgen silhouetranden van de gaten nog in 
streepjeslijnen veranderen.

Als u het lijntype van de vier verticale lijnen wilt wijzigen, vervangt u de lijntype-eigenschap die 
momenteel aan de lijnen is toegewezen. U herinnert zich misschien nog wel dat u de objecten kunt 
selecteren, en dan het gewenste lijntype via het palet Properties of het paneel Properties kunt 
specificeren.

Lijntypen wijzigen

1 Selecteer de vier verticale silhoutranden van de gaten.

2 Klik op de menubrowser ➤ Modify ➤ Properties.

Aangezien u meer dan een object hebt geselecteerd, worden alleen de gemeenschappelijke 
eigenschappen weergegeven.

3 Klik op Linetype op het palet Properties. Klik op de pijl en kies ACAD_ISO02W100 uit de lijst.

4 Klik op Linetype Scale. Typ 0.3 voor de nieuwe lijntypeschaal en druk op ENTER. 

5 Zet uw cursor buiten het palet Properties en druk op ESC om de selectie te wissen.

De vier lijnen worden nu als streepjeslijnen weergegeven.

N.B. In plaats van het lijntype van de vier lijnen afzonderlijk te wijzigen, had u een nieuwe laag voor 
verborgen lijnen kunnen maken. U had dan de lijntype-eigenschap van die laag op 
ACAD_ISO02W100 kunnen instellen. Het lijntype van de vier lijnen had u dan kunnen wijzigen door 
de laagtoewijzing van de lijnen naar de nieuwe laag te wijzigen.

6 De studieles is voltooid. Als u deze tekening wilt bewaren, slaat u deze nu op.

verleng lijn

silhouetranden
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Eigenschappen overeen laten komen

U kunt eigenschappen van één object gemakkelijk naar andere objecten kopiëren. U kunt de kleur, 
de laag, het lijntype, de lijntypeschaal, de lijndikte, de dikte, de plotstijl en in sommige gevallen de 
bematingsstijlen, tekststijlen en arceerpatronen overeen laten komen.

Probeer het: De eigenschappen van één object naar andere objecten kopiëren

1 Begin een nieuwe tekening.

2 Teken een aantal objecten met verschillende kleureigenschappen.

3 Klik op de menubrowser ➤ Modify ➤ Match Properties.

4 Klik op het bronobject waarvan u eigenschappen wilt kopiëren.

5 Klik op de objecten waarnaar u de eigenschappen wilt kopiëren.

U kunt de optie Settings van de opdracht gebruiken om de eigenschappen te selecteren die u overeen 
wilt laten komen, en de eigenschappen te wissen die u niet overeen wilt laten komen. 
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Bewerkingsmiddelen gebruiken

Met de volgende bewerkingsmiddelen kunt u tekeningen efficiënt wijzigen:

■ Grips: hiermee kunt u objecten met behulp van uw cursor en een snelmenu bewerken.
■ Revisiewolken: hiermee kunt u bijgewerkte gebieden identificeren.

Met grips bewerken

Grips zijn kleine vierkantjes en pijltjes die op een geselecteerd object worden weergegeven. Ze geven 
besturingslocaties aan en zijn krachtige bewerkingstools. 

Nadat u een object hebt geselecteerd, kunt u op een grip klikken en deze met uw cursor verplaatsen. 
Voor meer opties klikt u op een grip en klikt u met de rechtermuisknop om een snelmenu weer te 
geven. Kies dan een gripbewerkingsmodus.

selecteer lijn klik op grip

verplaats grip 
naar einde van 
horizontale lijn

1

2

gripbewerkingsmodi

opties voor gripbewerkingsmodi
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Probeer het: Objecten bewerken met grips

1 Teken verschillende objecten.

2 Klik op een aantal objecten om ze te selecteren en hun grips weer te geven.

3 Klik op een grip van een object en klik op zijn nieuwe locatie. Dit is de standaardgripmodus 
Stretch.

■ Let op het gripgedrag wanneer objectmagneten zijn ingeschakeld.
■ Let op het gripgedrag wanneer u een grip naar een andere grip uitrekt.

4 Klik op een grip van een object en klik dan met de rechtermuisknop.

5 Kies een andere gripmodus zoals Move, Mirror, Rotate of Scale.

6 Druk op ESC om gripbewerking af te sluiten.

Revisiewolken maken

Als u tekeningen controleert of rode correcties, kunt u uw productiviteit verhogen door uw 
aantekeningen met revisiewolken te markeren. U tekent de revisiewolk rond de objecten die u wilt 
benadrukken, waardoor er een polylijn in de vorm van een wolk wordt gemaakt, zoals in de 
volgende afbeelding wordt weergegeven.

Probeer het: Een revisiewolk maken

1 Klik op de menubrowser ➤ Draw ➤ Revision Cloud.

2 Klik ergens in het tekengebied en verplaats uw cursor om een gebied te omgeven.

3 Herhaal de opdracht en kijk of de revisiewolk de bogen altijd naar buiten toe maakt of dat u het 
met een trucje kunt doen.
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Tekeningen analyseren

Met behulp van de opvraagopdrachten kunt u informatie uit uw model extraheren. De meest 
gebruikte opvraagopdracht is DIST.

Gebruik DIST om de relatie tussen twee punten snel te bepalen. U kunt de volgende informatie 
weergeven voor twee gespecificeerde punten:

■ De afstand ertussen in tekeneenheden
■ De hoek tussen de punten in het XY-vlak
■ De hoek van de punten met het XY-vlak
■ De delta, of het verschil, tussen de coördinaatwaarden X, Y en Z van elk punt

Probeer het: De afstand en hoek tussen twee punten vinden

1 Klik op de menubrowser ➤ Tools ➤ Inquiry ➤ Distance.

2 Gebruik een objectmagneet om een punt op een object te vinden.

3 Gebruik een andere objectmagneet om een punt op een ander object te vinden.

4 Bekijk de gegevens die in het opdrachtvenster worden weergegeven.

5 Druk op F2 om de gegevens in een groter venster te bekijken, het tekstvenster.

Aan de slag

Handeling Menubrowser Pictogram

Objecten wissen Modify ➤ Erase

Objecten verlengen Modify ➤ Extend

Objecten bijsnijden Modify ➤ Trim

Objecten in een tekening kopiëren
Objecten tussen tekeningen kopiëren

Modify ➤ Copy
Edit ➤ Copy

Objecten verschuiven Modify ➤ Offset

Objecten spiegelen Modify ➤ Mirror

Objecten verplaatsen Modify ➤ Move

Objecten roteren Modify ➤ Rotate

Objecten afronden Modify ➤ Fillet

Eigenschappen bewerken Modify ➤ Properties
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Testvragen

1 Wat is het verschil tussen een overlappend selectievenster en een vensterselectie?

2 Wat is de snelste manier om verschillende parallelle lijnen te maken?

3 Wat is de gemakkelijkste manier om een boog te maken die twee andere objecten raakt?

4 Wanneer u een object maakt of wijzigt, wat doet u dan om het objectmagneetmenu weer te geven?

5 Wat is een gemakkelijke manier om de afstand tussen twee punten in een tekening te vinden?

Eigenschappen overeen laten komen Modify ➤ Match Properties

Revisiewolken maken Draw ➤ Revision Cloud

Informatie uit objecten extraheren Tools ➤ Inquiry ➤ Distance

Help-systeem

ERASE, EXTEND, TRIM, COPY, COPYCLIP, COPYMODE, PASTECLIP, OFFSET, MIRROR, MOVE, ROTATE, 
UNITS, FILLET, PROPERTIES, MATCHPROP, OPTIONS, REVCLOUD, DIST

Aan de slag

Handeling Menubrowser Pictogram
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Arceer om gebieden met patronen of effen kleu-
ren op te vullen, zodat u het onderwerp of mate-
riaal kunt identificeren

Maak blokken wanneer u tek-
eningen of delen van tekenin-
gen meermaals wilt gebruiken

Deze symbolen, blokken genoemd, 
representeren standaarditems zoals 
bomen of struiken
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Overzicht van blokken

In AutoCAD en AutoCAD LT worden symbolenblokken genoemd. Een blok is een verzameling 
objecten die tot één object zijn samengevoegd. Gebruik blokken om objecten zoals bomen, 
sluitingen of deuren voor te stellen.

Blokken worden meestal gedefinieerd en bewaard in tekeningen, de zogenoemde blokkenbibliotheken 
of symbolenbibliotheken, vanwaar ze in andere tekeningen kunnen worden ingevoegd. Een hele 
tekening kan ook als blok worden ingevoegd.

Blokken kunnen ook blokattributen bevatten, waarin gegevens zoals onderdeelnummers, datums en 
prestatieklassen worden bewaard.

Voordelen van blokken

Met blokken kunt u uw work gemakkelijker en sneller uitvoeren:

■ Teken op efficiënte wijze door blokken in plaats van afzonderlijke objecten in te voegen, te 
verplaatsen en te kopiëren.

■ Maak een standaardbibliotheek met vaak gebruikte symbolen, componenten of 
standaardonderdelen.

■ Bewaar gekoppelde gegevens met blokattributen die geëxtraheerd kunnen worden om rapporten 
te maken.

■ Beheer blokken met DesignCenter. DesignCenter biedt een handig organisatiepunt voor en 
toegang tot duizenden symbolen op uw computer, uw lokale netwerk en het World Wide Web.

blokverwijzingen 
van sluiting die in 
een tekening is 
ingevoegdblokdefinitie voor 

sluiting
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Bronnen van blokken

Er zijn verschillende bronnen van blokken die u in uw tekeningen kunt gebruiken.

■ Uw computer. In de map DesignCenter zijn meer dan 300 standaardblokken in 
15 symbolenbibliotheektekeningen beschikbaar.

■ Uw bedrijfsnetwerk. U kunt ook uw eigen blokken en blokkenbibliotheken maken, of misschien 
heeft uw bedrijf al zijn eigen standaardbibliotheken.

■ Het World Wide Web. Er zijn talrijke commerciële en Autodesk-symbolenbibliotheken met 
duizenden blokken beschikbaar. U kunt deze openen via het tabblad DC Online in DesignCenter.

N.B. Meer geavanceerde onderwerpen zoals het maken van blokken, blokattributen of 
blokkenbibliotheken worden niet in deze gids besproken.

Blokken invoegen

Blokken kunnen op de volgende drie manieren in tekeningen invoegd worden:

■ Het dialoogvenster Insert. Plaats een blok door zijn invoegpunt, schaal en rotatiehoek op te 
geven.

■ Het DesignCenter. Ga naar symbolenbibliotheken en zet een blok in een tekening of op een 
toolpalet, of sleep het ernaartoe. Via DesignCenter kunt u een groot aantal blokken en 
blokkenbibliotheken openen en beheren.

■ Het venster Tool Palettes. Zet een blok in een tekening of sleep het ernaartoe. Via toolpaletten 
kunt u uw meest gebruikte blokken organiseren en oproepen.

Studieles: Blokken toevoegen

1 Open MyDesign, de tekening die u in een vorige studieles hebt gemaakt en opgeslagen.
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2 Verschuif de lijnen om muren te maken (als het een beautycentrum of motorbehuizing betreft) 
of noklijnen (voor een onderdeel van een raamsluiting). Gebruik een waarde voor de 
verschuivingsafstand die geschikt is voor hetgeen u maakt. Rond de hoeken af met behulp van 
Fillet, met de afrondingsstraal ingesteld op 0.

Een blokkenbibliotheek openen

1 Klik op de menubrowser ➤ Tools ➤ DesignCenter.

Het venster DesignCenter is verdeeld in de structuurweergave aan de linkerzijde en het 
inhoudsgebied aan de rechterzijde. 

2 Klik in het venster DesignCenter indien nodig op de tab Folders. In de structuurweergave 
navigeert u naar de map Help\GettingStarted\Symbol Libraries.

3 Klik op het plusteken (+) van de toepasselijke blokkenbibliotheek voor uw tekening:

■ Fasteners - Metric.dwg
■ Fasteners - US.dwg
■ Office - Metric.dwg
■ Office - US.dwg

4 Klik op het item Blocks onder de tekening die u zojuist heeft uitgevouwen. De blokken zijn nu 
zichtbaar in het vak Content van DesignCenter.
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Blokken via DesignCenter plaatsen en verplaatsen

1 Sleep een van de blokken uit DesignCenter naar uw tekening. De precieze locatie is niet 
belangrijk.

2 Klik op het blok. Er verschijnt nu een gekleurde grip. Versleep de grip om het blok op zijn plaats 
te zetten.

3 Klik op de grip en klik met de rechtermuisknop. In het snelmenu klikt u op Rotate. Roteer het 
blok met de cursor of door een rotatiehoek in te voeren.

4 In DesignCenter dubbelklikt u op een ander blok.

5 In het dialoogvenster Insert klikt u op Specify On-Screen in het vak Rotation. Klik op OK.

6 Klik op een locatie in uw tekening. U wordt nu gevraagd om een rotatiehoek op te geven. Roteer 
het blok met de cursor of door een rotatiehoek in te voeren.

7 Sluit het venster DesignCenter.

Blokken via dialoogvenster Insert plaatsen

1 Klik op de menubrowser ➤ Insert ➤ Block.

2 In het dialoogvenster Insert klikt u op het pijltje naast het vak Name. Dit zijn de blokdefinities 
die in uw tekeningbestand worden bewaard. Klik op een definitie en klik dan op OK ter 
bevestiging. Specificeer de locatie voor het blok.

3 Voeg nog meer blokken aan uw tekening toe. Sla de tekening op.

Blokkenbibliotheken openen via het web

1 Open DesignCenter nogmaals.

2 Klik op de tab DC Online. Als u een internetverbinding hebt, kunt u de commerciële 
symbolenbibliotheken verkennen die beschikbaar zijn.
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Overzicht van arceringen

Een arceerpatroon is een standaardpatroon van lijnen of stippen dat gebruikt wordt om een deel van 
een tekening te benadrukken, of om materiaal zoals beton, staal of gras te identificeren. 
Een arceerpatroon kan ook een opvulling in effen kleur zijn.

Standaardarceerpatronen gebruiken

De map DesignCenter bevat meer dan 60 industriestandaard (ISO en Engels) arceerpatronen. U kunt 
ook arceerpatronen gebruiken uit arceerpatronenbibliotheken van andere bedrijven. Arceerpatronen 
worden in arceerpatronenbestanden met de extensie PAT bewaard.

Associatieve arceringen

Arceringen zijn standaard associatief. Associatieve arceringen zijn aan hun grenzen gekoppeld en 
worden bijgewerkt wanneer de grenzen worden gewijzigd. U kunt associativiteit op elk moment van 
een arcering verwijderen.

Industriestandaard 
arceerpatronen

ANSI31

INSUL

AR-CONC

Gearceerd object Resultaat van het bewerken van 
een grens met niet-associatieve 
arcering

Resultaat van het bewerken 
van een grens met 
associatieve arcering
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Arceringen of opvullingen in effen kleur invoegen

U kunt objecten in een tekening op een van de volgende manieren arceren of opvullen:

■ Kies Hatch uit het menu of de werkbalk Draw om arceringen en effen opvullingen te maken.
■ Via DesignCenter kunt u arceringen naar de tekening of een toolpalet slepen. 
■ Via een toolpalet kunt u veel gebruikte arceringen snel naar een tekening slepen.

Arceergrenzen definiëren

Arceergrenzen kunnen een willekeurige combinatie zijn van objecten zoals lijnen, bogen, cirkels, 
polylijnen, tekst en blokken. Arceergrenzen moeten een ingesloten gebied vormen, maar kunnen 
eilanden (ingesloten gebieden binnen het gearceerde gebied) bevatten die wel of niet gearceerd 
kunnen worden.

ResultaatGedetecteerde grenzenGeselecteerd intern punt

intern punt

eilanden
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Studieles: Arceringen aan een tekening toevoegen

In deze studieles arceert u een deel van uw tekening zodat het resultaat er ongeveer zo uitziet:

1 Open MyDesign, de tekening die u in de vorige studieles hebt gemaakt en opgeslagen.

2 Klik op de menubrowser ➤ Draw ➤ Hatch.

3 Op het tabblad Hatch controleert u de naam van het arceerpatroon en het staaltje in het vak Type 
and Pattern. Kies een ander arceerpatroon.

4 In het vak Boundaries klikt u op Add: Pick Points. Klik dan ergens tussen de parallelle lijnen voor 
de muren en druk op ENTER.

5 Klik op Preview onder in het dialoogvenster. 

Er zijn waarschijnlijk een aantal dingen die u wilt veranderen, zoals de cirkel die wordt gearceerd, 
de arceringshoek en de arceerafstand. 

6 Druk op ESC om naar het dialoogvenster terug te keren.

7 Klik op de knop > (meer opties) in de rechterbenedenhoek van het dialoogvenster.

8 In het vak Islands klikt u op Outer. Klik vervolgens op de knop < (minder opties).

9 In het vak Angle and Scale kunt u de waarden voor de hoek en de schaal wijzigen. Als de arcering 
te dicht is, verhoogt u de waarde voor de schaal met factor 10.

10 Klik op Preview. Bent u niet tevreden met het resultaat, dan gaat u terug naar stap 6. Klik anders 
met de rechtermuisknop of druk op ENTER ter bevestiging.

11 Sla uw tekeningbestand op.
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Testvragen

1 Wat is een blok?

2 Wat is een blokkenbibliotheek?

3 Hoe kunt u objectmagneten met blokken gebruiken?

4 Op welke drie manieren kunt u een gebied in een tekening arceren?

5 Hoe vult u een gebied met een effen kleur?

Aan de slag

Handeling Menubrowser Pictogrammen

Een blok invoegen Insert ➤ Block

DesignCenter openen Tools ➤ Palettes ➤ DesignCenter

Het venster Tool Palettes openen Tools ➤ Palettes ➤ Tool Palettes

Een gebied arceren Draw ➤ Hatch
Tools ➤ Palettes ➤ DesignCenter
Tools ➤ Palettes ➤ Tool Palettes

Help-systeem

ADCENTER, BLOCK, EXPLODE, INSERT, TOOLPALETTES, HATCH
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Tekst maken en wijzigen

AutoCAD en AutoCAD LT bieden een teksteditor waarmee tekst aan tekeningen kan worden 
toegevoegd. De teksteditor bestaat uit een tab op het lint met een set panelen en een 
tekstbegrenzingskader met een liniaal aan de bovenkant. Deze twee onderdelen worden automatisch 
weergegeven wanneer u de opdracht Multiline Text gebruikt.

Met de opdracht Multiline Text kunt u opmaak kiezen die op het gehele tekstobject of alleen 
geselecteerde tekst van toepassing is. U kunt ook inspringingen instellen en een of meer kolommen 
opgeven.

Voordat u de tekst maakt, geeft u de breedte ervan op door twee tegenovergestelde hoeken van een 
tekstkader op te geven. Alleen de breedte van het kader is van invloed. De tekst die u invoert, wordt 
in het dialoogvenster geplaatst binnen de opgegeven breedte, en woorden die niet passen, worden 
op de volgende regel gezet.

Wanneer u de teksteditor gebruikt, kunt u de breedte gemakkelijk wijzigen door de rechterkant van 
de liniaal te verslepen. 

weergaveopties

wijzigingen behouden en sluiten

breedte van 
alineatekst-object 
instellenalinea-inspringing

inspringing voor eerste regeltabstops
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N.B. De snelste manier om wijzigingen in een bestaand tekstobject aan te brengen, is door erop te 
dubbelklikken. Hierdoor wordt de teksteditor geopend en de tekst in het begrenzingskader 
weergegeven.

Aanvullende functies die voor tekst in tekeningen beschikbaar zijn:

■ Spellingcontrole met aanpasbare woordenboeken om spelling te controleren
■ Zoeken en corrigeren van tekst via het dialoogvenster Find and Replace.
■ Gemakkelijk meerdere tekstkolommen instellen en de kolombreedte aanpassen
■ Maken van gespiegelde tekst

Probeer het: Alineatekstobjecten maken

1 Begin een nieuwe tekening.

2 Klik op de menubrowser ➤ Draw ➤ Text ➤ Multiline Text.

3 Klik op twee punten om de breedte van het tekstobject te bepalen.

4 Typ uw tekst in het begrenzingskader.

5 Selecteer een woord en klik op enkele opmaakopties.

Deze opties lijken op die van de meeste tekstverwerkingstoepassingen.

6 Klik op Close Text Editor op het lint.

Probeer het: Een bestaand alineatekstobject wijzigen

1 Dubbelklik op het tekstobject.

2 Selecteer meerdere woorden of de hele alinea en klik op opmaakopties.

3 Klik op Close Text Editor op het lint.
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Werken met tekststijlen

Aan elk tekstobject in een tekening is een tekststijl gekoppeld. Wanneer u tekst invoert, wordt de 
actieve tekststijl toegepast, waarmee de volgende eigenschappen bepaald worden:

■ Font Hiermee wordt de vorm van de tekens ingesteld.
■ Font style Hiermee worden cursief en vet voor TrueType-lettertypen ingesteld.
■ Height Hiermee wordt de grootte van tekeneenheden in de tekst ingesteld.
■ Obliquing angle Hiermee wordt de voorwaartse of achterwaartse helling van de tekst ingesteld. 
■ Orientation Hiermee wordt de verticale of horizontale uitlijning van regeltekst ingesteld.
■ Other text characteristics Hiermee worden effecten zoals brede en achterwaartse tekst ingesteld.

Tekststijlen maken en wijzigen

Met uitzondering van de standaardtekststijl (STANDARD) moet u elke tekststijl opgeven die u wilt 
gebruiken. Nadat u een stijl hebt gemaakt, kunt u de instellingen aanpassen, de naam wijzigen of de 
stijl verwijderen wanneer u die niet langer nodig hebt. Gebruik het dialoogvenster Text Style om een 
tekststijl te maken of wijzigen. 

Als u het lettertype van een bestaande stijl verandert, wordt de tekst in de tekening met die stijl 
opnieuw gegenereerd met het nieuwe lettertype.

N.B. Als u notities en labels rechtstreeks op een lay-out in een papierkader maakt, is schalen niet nodig. 
Notities en labels die in een werkvlak gemaakt zijn, moeten aan de schaal van het lay-outvenster 
aangepast worden.

kies een 
andere 
tekststijl

een nieuwe tekststijl maken

bekijk de 
wijzigingen die 
u aanbrengt

geef een lettertype op
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Tekstgrootte voor vensterschaal instellen

U kunt tekst in een werkvlak of op de lay-out in een papierkader maken. De ruimte waarin u tekst 
maakt, is afhankelijk van de omstandigheden.

■ Als de tekst nauwer verbonden is met de lay-out, moet u de tekst in een papierkader maken. 
Bij deze optie hoeft u geen rekening te houden met schaal en kunt u de tekst op volledige grootte 
(1:1) maken.

■ Als de tekst nauwer verbonden is met het model, en u verwacht dat er vanuit andere tekeningen 
of weergaven naar het model en de tekst verwezen zal worden, moet u de tekst in een werkruimte 
maken. Bij deze optie moet de tekst meestal geschaald worden.

Wanneer u een of meer aanzichten op een tekeninglay-out maakt, moet u ze meestal met 
verschillende andere schalen dan 1:1 in lay-outvensters weergeven. Als u tekst in een werkvlak 
maakt, moet u de grootte ervan aanpassen zodat deze in een papierkader goed weergegeven en 
geplot kan worden.

Tekstgrootte in werkvlak instellen

Gebruik de volgende formule om de tekstgrootte in een werkvlak in te stellen:

Tekstgrootte in werkvlak = gewenste tekstgrootte/schaal van het lay-outvenster

■ Voorbeeld 1: Als de gewenste tekstgrootte 3 mm is en de schaal van het venster 1:4 (0.25), 
gebruikt u 3/0.25 = 12 mm voor de tekstgrootte in een werkvlak.

■ Voorbeeld 2: Als de gewenste grootte 1/8 inch is en de schaal van het venster is 1”=4’ (1:48), 
gebruikt u (1/8)/(1/48) = 48/8 = 6 inches voor de tekstgrootte in een werkvlak.

Het is veel gemakkelijker om tekst direct op de lay-out te maken, omdat schalen dan niet nodig is. 
Het is raadzaam aanzichtspecifieke tekst in een werkvlak te maken, en algemene notities, tabellen 
en labels in een papierkader.

Aan de slag

Handeling Menubrowser Pictogram

Alineatekst maken Draw ➤ Text ➤ Multiline Text 

Tekst wijzigen Modify ➤ Object ➤ Text

De spelling in een tekening controleren Tools ➤ Spelling

Tekst zoeken en vervangen Edit ➤ Find

Tekststijlen maken Format ➤ Text Style

Help-systeem

FIND, MTEXT, MIRRTEXT, MTEXTED, SPELL, STYLE, SCALETEXT, JUSTIFYTEXT, STYLE, SPACETRANS
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Testvragen

1 Wat is de snelste manier om de alineateksteditor te openen wanneer u bestaande tekst moet wijzigen?

2 Wat zijn enkele voordelen van het maken van aanvullende tekststijlen?

3 Hoe beslist u of u tekst in een papierkader of een werkvlak maakt?

4 Welke teksthoogte moet u in een werkvlak gebruiken, als de gewenste teksthoogte in een papierkader 
2.5 mm is en de weergaveschaal van het lay-outvenster 1/50 (0.02)?
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Vervolgbemating

Lineair 
(verticaal)

Lineair
(horizontaal)

Uitgelijnd

Basislijn

Hartpunt

Coördinaat

Diameter

HoekQuick Leader

Radius
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Overzicht van bematingen

Bematingen geven de geometrische afmetingen van objecten, de afstanden of hoeken tussen 
objecten, of de locatie van een element weer. Er zijn vier algemene bematingsstijlen: 

■ Linear. Hiermee worden afstanden gemeten met behulp van horizontale, verticale, uitgelijnde, 
geroteerde of basislijnbemating, en vervolg- of kettingbemating.

■ Ordinate. Hiermee wordt de afstand van een punt vanaf een opgegeven oorsprongspunt 
gemeten.

■ Radial. Hiermee worden de stralen en diameters van bogen en cirkels gemeten.
■ Angular. Hiermee wordt de hoek gemeten die door twee lijnen of drie punten gevormd wordt.

Onderdelen van een bemating

Bematingen bevatten een aantal afzonderlijke elementen: 

■ Dimension line. Geeft de richting en reikwijdte van een bemating aan. Bij hoeken is de maatlijn 
een boog. 

■ Extension line. Strekt zich uit van het element dat bemaat wordt, tot de maatlijn.
■ Dimension text. Drukt de bematingswaarde uit en kan voorvoegsels, achtervoegsels en 

toleranties bevatten. U kunt ook uw eigen tekst leveren of de tekst helemaal onderdrukken.
■ Arrowhead. Geeft het einde van de maatlijn aan. U hebt de keus uit verschillende pijlpunten, 

waaronder bouwkundige maatstreepjes en stippen.
■ Leader. Vormt een ononderbroken lijn van een annotatie naar het element waarnaar wordt 

verwezen. Wanneer bematingstekst niet tussen extensielijnen past, kunnen er, afhankelijk van de 
bematingsstijl, automatisch verwijslijnen gemaakt worden. U kunt ook verwijslijnen maken om 
tekst of een blok met een element te verbinden.

maatlijn

extensielijn

bematingstekst

pijlpunt

verwijs
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Associatieve bematingen en verwijslijnen

Bematingen zijn standaard associatief. De afmetingen die door associatieve bematingen worden 
weergegeven, worden automatisch bijgewerkt terwijl u de objecten wijzigt waaraan ze zijn 
gekoppeld.

Verwijslijnobjecten bestaan uit tekst, een verwijslijn en een pijlpunt. 

■ Als het tekstdeel van een verwijslijnobject wordt verplaatst, wordt de verwijslijn ook aangepast.
■ Als een verwijslijnobject aan een geometrisch object is gekoppeld, en het object wordt verplaatst, 

uitgerekt of geschaald, worden de pijlpunt en het verwijslijndeel van het verwijslijnobject ook 
bijgewerkt.
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Bematingen maken

U kunt lijnen, bogen, cirkels en verschillende andere objecttypen bematen. Er zijn twee 
hoofdmethoden om bematingen te maken:

■ Selecteer een object om te bematen (1) en specificeer de locatie van de bematingslijn (2) zoals in 
de volgende voorbeelden te zien is.

■ Gebruik objectmagneten om de oorsprong van extensielijnen te specificeren, en specificeer 
vervolgens de locatie van de maatlijn. De oorsprongspunten van de extensielijn kunnen zich op 
afzonderlijke objecten bevinden.

Studieles: Bematingen maken

In deze studieles stelt u de schaal voor uw tekening in en voegt u verschillende bematingen aan uw 
ontwerp toe.

1 Open MyDesign, de tekening die u in vorige studielessen hebt gemaakt en opgeslagen.

2 Klik op de lay-outtab.

Resultaat van lijnselectie 
voor een bemating

Resultaat van 
cirkelselectie voor een 

1

2

1

2
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Stel de weergaveschaal van het venster in.

1 Klik op de blauwe grens van het lay-outvenster om het te selecteren.

2 Klik op de menubrowser ➤ Modify ➤ Properties.

3 In het palet Properties klikt u eerst op Display Locked en vervolgens op No.

N.B. Wij raden u ten sterkste aan de weergave in lay-outvensters vergrendeld te houden, tenzij u 
de weergaveschaal van het venster instelt. Hiermee voorkomt u dat u of iemand anders per ongeluk 
in- of uitzoomt en de weergaveschaal wijzigt.

4 Dubbelklik in het lay-outvenster. Hiermee wordt een werkvlak via de lay-out geopend.

5 Klik op de menubrowser ➤ View ➤ Zoom ➤ Extents.

Met deze stap wordt uw weergave in het lay-outvenster gecentreerd.

6 Dubbelklik buiten het lay-outvenster om naar het papierkader terug te keren.

U kunt nu de precieze schaal voor de bouwtekening of het onderdeel opgeven.

7 Klik op de blauwe grens van het lay-outvenster om het te selecteren. Klik op Standard Scale in 
het vak Misc category van het palet Properties.

8 Klik op het pijltje om een lijst met schalen weer te geven. Klik op de schaal die het geschiktst lijkt 
voor het formaat van het tekenblad en de grootte van uw bouwtekening of onderdeel. U kunt 
desgewenst altijd nog andere schaal kiezen.

9 Vergrendel het lay-outvenster om te voorkomen dat u per ongeluk wijzigingen aanbrengt.

Bematingen toevoegen

1 Maak de laag Dimensions de actieve laag.

Het is raadzaam een aparte laag te gebruiken die voor bematingsobjecten is gereserveerd.

2 Dubbelklik in het lay-outvenster om het werkvlak te openen.

Er is een goede reden waarom u bematingen via het lay-outtablad in plaats van het tabblad 
Model maakt. Wanneer u via het lay-outtablad in een werkvlak bemaat, worden de bematingen 
automatisch ten opzichte van de vensterschaal geschaald.

3 Klik op de menubrowser ➤ Dimension ➤ Linear. Volg de aanwijzingen om verschillende lineaire 
bematingen te maken.
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4 Experimenteer met verschillende andere bematingstypen.

N.B. Automatische bematingsschaling wordt niet in alle tekeningen of tekeningsjabloonbestanden 
ingeschakeld. Dit werkt alleen wanneer de systeemvariabele DIMSCALE op 0 is ingesteld. U kunt 
DIMSCALE op de opdrachtregel invoeren. In het Help-systeem vindt u meer informatie over DIMSCALE.

Tekst toevoegen

1 Dubbelklik buiten het lay-outvenster om naar het papierkader terug te keren.

2 Maak de laag Text de actieve laag.

3 Maak verschillende notities met behulp van de opdracht Multiline Text.

4 Sla uw tekening op.
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Bematingsopties gebruiken

In het menu Dimension en op de gelijknamige werkbalk zijn naast de basisbematingen de volgende 
opties nog beschikbaar:

■ Center marks and centerlines om het precieze midden van cirkels of bogen te vinden.
■ Leader lines om de annotatie met elementen in de tekening te verbinden.
■ Geometric tolerances om afwijkingen van de vorm, het profiel, de richting, locatie en uitloop van 

elementen in de tekening weer te geven.

Hartpunten en hartlijnen maken

U kunt gemakkelijk eeen hartpunt of hartlijn op een cirkel of boog maken. De grootte en stijl van 
hartpunten en hartlijnen worden door de bematingsstijl bepaald.

Probeer het: Hartpunten en hartlijnen maken

1 Begin een nieuwe tekening en klik op de tab Model.

2 Teken een kleine cirkel.

3 Klik op de menubrowser ➤ Dimension ➤ Center mark.

4 Klik op de cirkel.

Twee lijnen in de vorm van een plusteken worden nu in het midden van de cirkel gemaakt.

U kunt hartpunten ook automatisch maken met radius- en diameterbematingen.

hartpunt

hartlijnen
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Verwijslijnen met annotatie maken

U kunt een verwijslijn vanaf een willekeurig punt of element in een tekening maken. Bij een multi-
verwijslijn kunnen rechte lijnsegmenten of afgewerkte spline-krommen worden gebruikt. 
Verwijslijnkleur, schaal en pijlpuntstijl worden door de actieve multi-verwijslijnstijl bepaald. 
Een korte lijn, de zogenoemde haaklijn, verbindt de annotatie meestal met de verwijslijn. Annotaties 
van multi-verwijslijnen kunnen uit alineatekst, een controlekader voor eigenschappen of een 
blokverwijzing bestaan.

Probeer het: Maak een multi-verwijslijn

1 Klik op de menubrowser ➤ Dimension ➤ Multileader.

2 Klik op een locatie voor de pijlpunt.

3 Klik op een locatie voor de haaklijn.

4 Voer tekst in het begrenzingskader in.

5 Klik op Close Text Editor op het lint.

verwijslijn

haaklijn
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Bematingsstijlen maken en wijzigen

Aan elke bemating is een bematingsstijl gekoppeld. Met behulp van bematingsstijlen kunt u 
tekenstandaarden instellen en opleggen, en bematingsopmaak en -gedrag gemakkelijker wijzigen. 
Een bematingsstijl bepaalt:

■ Opmaak en positie van maatlijnen, extensielijnen, pijlpunten en hartpunten.
■ Uiterlijk, positie en gedrag van bematingstekst
■ Regels die tekstplaatsing en maatlijnen bepalen
■ Algemene bematingsschaal
■ Opmaak en precisie van primaire, alternatieve en hoekbematingseenheden
■ Notatie en precisie van tolerantiewaarden

Voor nieuwe bematingen worden de huidige instellingen in het dialoogvenster Dimension Style 
Manager gebruikt. De stijl STANDARD wordt standaard aan bematingen toegewezen tot u een andere 
stijl selecteert.

Overrides: hiermee kunt u wijzigingen in de actieve bematingsstijl aanbrengen. Vervangende 
instellingen gelden voor alle volgende bematingen die met die stijl worden gemaakt tot u een 
nieuwe stijl actief maakt, maar wijzigen een bematingsstijl niet permanent. U kunt ook 
eigenschappen van bematingen via het palet Properties vervangen.
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Opties voor Dimension Style opgeven

Of u nu New, Modify of Override in de Dimension Style Manager selecteert, dezelfde optieset is 
beschikbaar. 

■ Lines: hiermee wordt het uiterlijk en gedrag van maatlijnen en extensielijnen ingesteld.
■ Symbols and Arrows: hiermee wordt het uiterlijk en gedrag van bematingspijlpunten, 

hartpunten en hartlijnen ingesteld.
■ Text: hiermee wordt het uiterlijk, de plaatsing en uitlijning van bematingstekst ingesteld.
■ Fit: hiermee worden opties voor de plaatsing van maatlijnen, extensielijnen en tekst ingesteld. 

Hierbij is ook de instelling voor automatische bematingsschaling inbegrepen.
■ Primary Units: hiermee worden de notatie (bijvoorbeeld wetenschappelijk, decimaal, 

bouwkundig) en precisie van lineaire en hoekbematingseenheden ingesteld.
■ Alternate Units: hiermee worden een alternatieve eenheidnotatie en precisiewaarde ingesteld. 

Deze functie ondersteunt de weergave van twee bematingen, zoals metrieke en Engelse eenheden. 
■ Tolerances: hiermee worden tolerantiewaarden en precisie ingesteld.

N.B. Wanneer u een bematingsstijl wilt maken die aan industrie- of bedrijfsstandaarden voldoet, moet 
over vele instellingen overeenstemming worden bereikt. Het is belangrijk dat uw organisatie een of meer 
officiële bematingsstijlen maakt of handhaaft.
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Bematingen wijzigen

U kunt bematingen wijzigen met grips of met bewerkingsopdrachten. U kunt bematingsstijlen ook 
wijzigen of vervangen, zoals in het vorige onderwerpen is besproken. Wilt u beduidende wijzigingen 
in een bemating aanbrengen, dan is het meestal gemakkelijker om de bemating te wissen en 
opnieuw te maken.

Voor kleine wijzigingen in een bemating kunt u het beste grips gebruiken. U kunt een maatlijn 
bijvoorbeeld gemakkelijk verslepen om deze met een andere maatlijn uit te lijnen.

U kunt bematingstekst ook naar een andere locatie verslepen.

1 Klik op bemating
2 Klik op grip aan 
het einde van de 
maatlijn

3 Verplaats grip 
naar nieuwe 
bematingslocatie

1 Klik op bemating
2 Klik op grip op 
bematingstekst

3 Verplaats grip om 
bematingstekst op een 
andere locatie te zetten
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Aan de slag

Handeling Menubrowser Pictogram

Lineaire bematingen maken Dimension ➤ Linear

Uitgelijnde bematingen maken Dimension ➤ Aligned

Bematingen met coördinaten maken Dimension ➤ Ordinate

Radiusbematingen maken Dimension ➤ Radius

Diameterbematingen maken Dimension ➤ Diameter

Hoekbematingen maken Dimension ➤ Angular

Basislijnbematingen maken Dimension ➤ Baseline

Vervolgbematingen maken Dimension ➤ Continue

Een bematingsstijl maken en wijzigen Dimension ➤ Dimension Style

Een bestaande bemating updaten om een 
stijlwijziging te implementeren

Dimension ➤ Update

Een hartpunt maken Dimension ➤ Center mark

Verwijslijnen met annotatie maken Dimension ➤ Multileader

Help-systeem

DIMALIGNED, DIMANGULAR, DIMBASELINE, DIMCONTINUE, DIMDIAMETER, DIMJOGGED, 
DIMLINEAR, DIMORDINATE, DIMRADIUS, DIMSCALE, DIMSTYLE, DIMEDIT, DIMTEDIT, DIMOVERRIDE, 
DIMCENTER, DIMSTYLE, DIMREGEN, MLEADER
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Testvragen

1 Wat is het gedrag van associatieve verwijslijnen en associatieve bematingen?

2 Waarom is het raadzaam lay-outvensters te vergrendelen?

3 Welke bematingsvariabele moet op 0 ingesteld worden om te verzekeren dat bematingen volgens de 
schaal van het lay-outvenster worden geschaald?

4 Wat is de gemakkelijkste manier om de locatie te wijzigen van een bematingselement, zoals de 
maatlijn of bematingstekst?
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Het model
Op volledige grootte gemaakt 
(1:1). Tekst en bematingen in 
het werkvlak worden 
geschaald ter compensatie 
van de schaalfactoren die in 
lay-outvensters worden 
gebruikt.

Lay-out
Stelt een teken-
blad voor dat een 
titelblok, een of 
meer lay-outven-
sters en tekstob-
jecten bevat

Lay-outvensters
Geef een of meer aanzichten van 
het model weer, die allemaal 
apart kunnen worden geschaald

Plotstijlen
Vervang eigenschappen zoals kleur en 
lijndikte tijdelijk tijdens het plotten

Pagina-instellingen
Sla plotinstellingen op met een 
naam en koppel ze aan een lay-out



Lay-outs en plots maken

Met lay-outs werken  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  148
Plotters kiezen en configureren . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  152
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Met lay-outs werken

U gebruikt een lay-out om de geplotte pagina samen te stellen. Een lay-out bestaat meestal uit de 
volgende objecten:

■ Algemene notities en tabellen
■ Aanzichtspecifieke labelblokken en bijschriftblokken (dit is een geavanceerd onderwerp dat niet 

in deze gids besproken wordt)
■ Lay-outvensters

Lay-outs geven de paginarand en het feitelijke afdrukgebied weer. Het paginaformaat en feitelijke 
afdrukgebied zijn afhankelijk van de printer of plotter die aan de lay-out is toegewezen.

paginarand

afdrukgebied lay-out lay-outvenster, geeft een aanzicht 
van een werkvlak weer
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Een nieuwe lay-out maken

Wanneer u een nieuwe lay-out maakt, zal dat meestal om een van deze twee redenen zijn. U wilt

■ een nieuw tekensjabloonbestand maken met een ander papierformaat en andere afdrukstand.
■ een lay-out met een ander papierformaat, andere afdrukstand en ander titelblok aan een 

bestaande tekening toevoegen.

De gemakkelijkste manier om een nieuwe lay-out te maken is met behulp van de wizard Create 
Layout. Nadat u een lay-out hebt gemaakt, kunt u het titelblok vervangen en lay-outvensters maken 
of verwijderen.

Probeer het: Een lay-out maken

1 Begin een nieuwe tekening.

2 Klik op de menubrowser ➤ Tools ➤ Wizards ➤ Create Layout.

3 Volg de stappen in de wizard om een lay-out met een ander papierformaat en overeenkomstig 
titelblok te maken.

4 Klik met de rechtermuisknop op het lay-outtabblad. Kies Rename in het snelmenu. 
Voer een nieuwe naam in voor de lay-out.

Klik op de menubrowser ➤ menu File ➤ Save As om deze tekening als een nieuw 
tekeningsjabloonbestand op te slaan. Geef een DWT-extensie op onder Files of Type in het 
dialoogvenster Save Drawing As.

Lay-outvensters gebruiken

In layout-vensters op een lay-outtabblad worden aanzichten van een werkvlak weergegeven. 
In de volgende punten wordt de relatie tussen lay-outvensters en werkvlakken samengevat:

■ De meeste objecten in uw tekeningen worden gemaakt in het werkvlak op het tabblad Model.
■ U maakt lay-outvensters om een of meer aanzichten van een werkvlak in een lay-out weer te 

geven en te schalen.
■ Ga via een lay-outvenster naar het werkvlak om het aanzicht te pannen en de zichtbaarheid van 

lagen in te stellen. U kunt de zichtbaarheid van lagen in elk lay-outvenster apart bepalen.
■ Gebruik het tabblad Model als u belangrijke wijzigingen in uw model wilt aanbrengen.
■ Als u goed geschaalde bematingen wilt maken, gaat u naar een werkvlak via het lay-outtabblad 

en bepaalt u vervolgens de bematingen van het model.

Wanneer u een nieuwe lay-out maakt, wordt standaard één layout-venster toegevoegd. U kunt 
meerdere lay-outvensters toevoegen voor onafhankelijke aanzichten zoals details en 3D-aanzichten. 
De instellingen voor schaal, ploteigenschappen en zichtbaarheid van lagen kunnen voor elk venster 
afzonderlijk worden ingesteld.
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Studieles: Werken met lay-outvensters

In deze studieles oefent u de meest gebruikte bewerkingen voor lay-outvensters.

De weergaveschaal van een aanzicht in een lay-outvenster wijzigen

1 Klik op de menubrowser ➤ File ➤ Open.

2 In het dialoogvenster Select File zoekt u naar de map \Help\GettingStarted in de productmap van 
AutoCAD of AutoCAD LT. Hierin opent u het bestand arbor.dwg.

3 Klik op de menubrowser ➤ Format ➤ Layer. Klik in Layer Properties Manager op het gloeilampje 
op de laag Viewport om de objecten op die laag weer te geven.

De blauwe randen van de lay-outvensters zijn nu zichtbaar.

4 Klik op de menubrowser ➤ Modify ➤ Properties. Klik op de blauwe rand van het lay-outvenster 
in de rechterbovenhoek.

5 In het palet Properties onder Misc klikt u op Display Locked. Klik op het pijltje en dan op No.

De weergave-eigenschappen voor het lay-outvenster zijn nu ontgrendeld. U gaat nu de exacte 
schaal van het aanzicht in dit lay-outvenster veranderen.

6 Klik op Standard Scale in het palet Properties.

7 Klik op het pijltje om een lijst met schalen weer te geven, en klik op 1:40.

Het aanzicht wordt onmiddellijk met de nieuwe weergaveschaal aangepast.

8 Dubbelklik in het lay-outvenster om naar het werkvlak te gaan. Pan het aanzicht wanneer nodig, 
maar wijzig de schaal van het aanzicht niet met Zoom. Dubbelklik vervolgens buiten de lay-
outvensters om naar het papierkader terug te keren.

9 Gebruik het palet Properties om het lay-outvenster te vergrendelen.

U vergrendelt het lay-outvenster om te voorkomen dat u hierin per ongeluk pant en zoomt. 
Zo worden de positie en schaal van het aanzicht in het venster beschermd.

Een lay-outvenster wissen

1 Klik op de menubrowser ➤ Modify ➤ Erase.

2 Klik op de rand van het lay-outvenster in de rechterbovenhoek en druk op ENTER.

Een lay-outvenster is een object. Net als andere objecten kan het verplaatst, gekopieerd en gewist 
worden.
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Een nieuw lay-outvenster maken

1 Maak de laag Viewport de actieve laag.

2 Klik op de menubrowser ➤ View ➤ Viewports ➤ 1 Viewport.

3 Klik op twee punten in een leeg gebied op de lay-out. De twee punten zijn de diagonale hoeken 
van het nieuwe lay-outvenster.

Het nieuwe lay-outvenster kan een bestaand venster overlappen.

4 Klik op de rand van het lay-outvenster om de grips te selecteren.

5 Pas de grootte van het lay-outvenster aan door op een grip te klikken, de cursor te verplaatsen en 
op een nieuwe locatie te klikken. Verplaats het lay-outvenster met de opdracht Move.

6 Gebruik het palet Properties om de weergaveschaal van het aanzicht in het lay-outvenster in te 
stellen.

7 Dubbelklik in het lay-outvenster en pan het aanzicht. Dubbelklik buiten het alle vensters om 
naar het papierkader terug te keren.

8 Gebruik het palet Properties om het lay-outvenster te vergrendelen.

9 Schakel de laag Viewport uit.

10 Sluit de tekening zonder opslaan.

N.B. Maak lay-outvensters altijd op een aparte laag die aan vensterobjecten is toegewezen. Wanneer u 
klaar bent om te plotten, schakelt u de laag uit om te voorkomen dat de vensterranden geplot worden.
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Plotters kiezen en configureren

AutoCAD en AutoCAD LT ondersteunen een groot aantal printers en plotters. Apparaten waarop een 
Windows-printerstuurprogramma geïnstalleerd is, zijn automatisch beschikbaar wanneer u plot, 
tenzij de plotoptie om systeemprinters te verbergen is geselecteerd. Vele plotters die geen Windows-
stuurprogramma's (niet-systeemplotters) hebben, kunnen geconfigureerd worden met 
stuurprogramma'svan Autodesk of de plotterfabrikant.

U kunt ook stuurprogramma's configureren om tekeningen in verschillende bestandsindelingen op 
te slaan, zoals DWF™ -bestanden (Design Web Format) om tekeningen in een webbrowser of externe 
viewer weer te geven, PostScript-bestanden voor gebruik met programma's voor paginalay-out en 
rasterbestanden.

Als een uitvoerapparaat niet in het dialoogvenster Plot of Page Setup weergegeven wordt, of als de 
instellingen onjuist zijn, kunt u gemakkelijk printer- en plotterconfiguraties toevoegen of wijzigen.

Een plotterconfiguratie toevoegen

De Plotter Manager is een map die een methode biedt voor het toevoegen, verwijderen en wijzigen 
van plotterconfiguraties. Plotterconfiguratiebestanden hebben de extensie .pc3 en worden in de map 
Plotters opgeslagen. Als u de map Plotters wilt weergeven, klikt u op de menubrowser ➤ menu File ➤ 
Plotter Manager.

De Plotter Manager biedt plotterconfiguratiebestanden (PC3) voor alle niet-systeemprinters die u 
installeert. Plotterconfiguratiebestanden kunnen ook voor Windows®-systeemprinters gemaakt 
worden, als u andere standaardeigenschappen dan die van Windows wilt gebruiken.

De Plotter Manager
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Dubbelklik op de wizard Add-A-Plotter in de Plotter Manager om een plotterconfiguratie toe te 
voegen. De wizard Add-A-Plotter vraagt u om informatie over uw plotter, netwerkinstellingen, 
aangepaste plottereigenschappen, instellingen voor uitvoerkwaliteit enzovoort.

Nadat er een nieuw PC3-bestand is gemaakt, is de plotterconfiguratie beschikbaar voor lay-outs en 
plotten.

Een plotterconfiguratie wijzigen

De Plotter Configuration Editor wordt gebruikt om

■ de gegevens voor poort- of bestandsuitvoer te bewerken
■ papierformaten en papierlay-outs te wijzigen of toe te voegen
■ uitvoer van vector- en rasterafbeeldingen te regelen
■ uw plotter te kalibreren
■ de aangepaste eigenschappen van uw plotter in te stellen

Als u de Plotter Configuration Editor wilt starten, kunt u op het bestand PC3 dubbelklikken of 
Properties selecteren in het dialoogvenster Plot.

Plotstijlen gebruiken om eigenschappen te vervangen (optioneel)

Een plotstijl is een optionele methode om te bepalen hoe elk object of elke laag geplot moet worden. 
Wanneer u een plotstijl aan een object of laag toewijst, worden eigenschappen zoals kleur en 
lijndikte voor het plotten vervangen. Dit is alleen van invloed op de weergave van geplotte objecten.

Plotstijltabellen: hierin kunt u groepen plotstijlen verzamelen en in een bestand opslaan dat u later 
tijdens het plotten kunt specificeren. De Plot Style Manager is een map die alle beschikbare 
plotstijlentabellen en de wizard Add-A-Plot Style bevat.

Er zijn twee typen plotstijltabellen:

■ Kleurafhankelijke plotstijltabellen. De kleur van een object bepaalt hoe het wordt geplot. 
De bestanden hebben de extensie .ctb. Kleurafhankelijke plotstijlen kunt u niet direct aan 
objecten toewijzen. U moet de kleur van een object wijzigen om te kunnen bepalen hoe het wordt 
geplot. Zo kunt u instellen dat alle rode objecten in een tekening met een lijndikte van 0.50 mm 
geplot moeten worden.

■ Benoemde plotstijltabellen. Plotstijlen worden direct aan objecten en lagen toegewezen. 
De bestanden hebben de extensie .stb. Als u deze gebruikt, kunt u elk object in een tekening op 
een andere manier plotten, ongeacht de kleur van het object.

Met de Plot Style Manager kunt u plotstijltabellen toevoegen, verwijderen, van naam veranderen, 
kopiëren en bewerken. U kunt de Plot Style Manager via het menu Files oproepen.
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Vanaf een lay-out plotten

Is uw tekening klaar, dan kunt u gaan plotten. In het dialoogvenster Plot kunt u de printer of plotter 
en vele andere instellingen selecteren, waarmee u de complete controle krijgt over uw uitvoer.

Voordat u uw tekening plot, is het raadzaam een volledig plotvoorbeeld te genereren. Als de 
afbeelding niet juist is, kunt u wijzigingen aanbrengen in de plotinstellingen, pagina-instellingen en 
de plotstijltabel die aan de lay-out gekoppeld zijn.

Pagina-instellingen

Aangezien er zo veel plotinstellingen zijn, kunt u ze benoemen en als een pagina-instelling opslaan 
via de Page Setup Manager. Wanneer u klaar bent om te plotten, kunt u de naam van de pagina-
instelling in het dialoogvenster Plot opgeven.

Stel dat u naar een andere plotter voor kleuruitvoer overschakelt. U kunt dan snel alle instellingen 
voor die plotter herstellen door de naam van een eerder opgeslagen pagina-instelling op te geven. 
Als u terug wilt schakelen, geeft u de naam van de oorspronkelijke pagina-instelling op.

Aan elk lay-outtabblad kan een benoemde pagina-instelling gekoppeld zijn. Pagina-instellingen 
worden in de tekening opgeslagen.

het gebied 
van de te plot-
ten tekening 
selecteren

een 
afdrukstand
standeen voorbeeld 

genereren

een plotschaal 
opgeven

de lay-out op de pagina 
plaatsen

een pagina-
formaat 
selecteren

een printer 
of plotter 
selecteren

opties weergeven of 
verbergen

een plotstijl 
opgeven
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Probeer het: Een pagina-instelling maken

1 Begin een nieuwe tekening. Klik indien nodig op een lay-outtabblad.

2 Klik op de menubrowser ➤ File ➤ Page Setup Manager.

3 Klik op New. 

4 Voer My_New_Plotter in het dialoogvenster New Page Setup in. Klik op OK.

5 Wijzig enkele instellingen in het dialoogvenster Page Setup. Klik op OK.

De nieuwe pagina-instellingsnaam wordt in de Page Setup Manager weergegeven.

6 Klik op My_New_Plotter en klik op Set Current.

De pagina-instelling My_New_Plotter wordt nu aan het actieve lay-outtabblad gekoppeld.

7 Klik op Close.

Als u niet alle instellingen in het dialoogvenster Page Setup opgeeft wanneer u een lay-out maakt, 
kunt u de pagina instellen net voordat u gaat plotten.

Studieles: Een tekening plotten

In deze oefening bewerkt u de pagina-instelling voor een bestaande lay-out, maakt u een nieuwe 
lay-out, voegt u een titelblok in de nieuwe lay-out in en plot u de tekening.

Een bestaande lay-out bewerken

U bereidt het plotten vanaf een lay-outtabblad voor door een lay-out en een venster in te stellen, en 
bematingen te maken. 

1 Klik op de menubrowser ➤ File ➤ Open.

2 Ga naar de map \Help\GettingStarted in het dialoogvenster Select File, selecteer plan.dwg en klik 
op Open.

Dit is een tekening van een grondplan en hoogte.

3 Klik op het lay-outtabblad Elevation.

Op de lay-out Elevation wordt een pagina-instelling gebruikt waarmee het plotgebied en 
paginaformaat worden bepaald. Er is ook een specifieke plotterconfiguratie aan de lay-out 
Elevation gekoppeld.

4 Klik op de menubrowser ➤ File ➤ Page Setup Manager.

5 Klik op Modify in de Page Setup Manager.

6 Onder Plot Style Table (Pen Assignments) opent u de vervolgkeuzelijst en klikt u op het bestand 
monochrome.ctb. Als u wordt gevraagd een plotstijltabel toe te passen, moet u deze niet op alle 
andere lay-outs toepassen.

7 Selecteer Display Plot Styles. Klik op OK.

8 Klik op Close om de Page Setup Manager te sluiten.

De tekening is nu zwart-wit omdat de lay-out een voorbeeld van de tekening toont zoals deze 
met de monochrome plotstijltabel zal worden geplot.

9 Klik op de knop Model. Het model wordt nog steeds in kleur weergegeven.
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Een nieuwe lay-out maken

1 Maak de laag Viewport de actieve laag.

2 Klik op de menubrowser ➤ Tools ➤ Wizards ➤ Create Layout. 

De wizard Create Layout begeleidt u bij het maken van een lay-out.

3 Voer een naam voor de nieuwe lay-out op de pagina Begin van de wizard Create Layout in. 
Typ Elevation and Floor Plan. Klik op Next.

4 Selecteer op de pagina Printer de printer die u wilt gebruiken om deze lay-out te plotten. Selecteer 
DWF6 ePlot.pc3. Klik op Next.

In deze studieles plot u de tekening naar een DWF-bestand in plaats van een plotter. DWF-
bestanden (Design Web Format) zijn handig voor het distribueren van tekeningen via e-mail, 
FTP-sites, projectwebsites of cd's. DWF-bestanden zijn kleiner, sneller en bieden een hogere 
resolutie dan andere populaire opties. DWF-bestanden kunnen bekeken worden met Autodesk® 
Design Review, een viewer die u gratis van de Autodesk-website kunt downloaden.

5 De beschikbare papierformaten in de vervolgkeuzelijst op de pagina Paper Size zijn gebaseerd op 
de geselecteerde printer. Selecteer Letter of ANSI A (8.5 x 11.0 inches) als papierformaat. 
Zorg ervoor dat de breedte en hoogte bij Paper Size in Units respectievelijk 11.0 inches en 8.5 
inches is. Klik op Next.

6 Klik op de pagina Orientation op Portrait voor die afdrukstand. Klik op Next.

7 Klik op de pagina Title Block op None in de lijst met beschikbare titelblokken. Klik op Next. 
(Nadat de lay-out is gemaakt, voegt u een titelblok in.)

8 Klik op Array onder Viewport Setup op de pagina Define Viewports. Laat Scaled to Fit als de 
instelling voor Viewport Scale staan. (U kunt de schaal later wijzigen.) Typ 2 in het vak Rows. 
Typ 1 in het vak Columns. Typ 0.25 in het vak Spacing Between Rows. Typ 0.1 in het vak Spacing 
Between Columns. Hiermee worden twee verticaal uitgelijnde vensters gemaakt met een ruimte 
ertussen. Klik op Next.

selecteer de optie 
Array

geef 2 rijen 
met 1 kolom op
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9 Selecteer Select Location op de pagina Pick Location. Klik en sleep in het tekengebied om een 
rechthoekig lay-outvenster te maken dat net binnen het afdrukbare gebied (de streepjeslijnen) 
valt.

10 Klik op Finish op de gelijknamige pagina om het aanmaken van de nieuwe lay-out en vensters 
te voltooien.

Er zijn nu twee vensters gemaakt.

Een titelblok in een lay-out invoegen

1 Zorg ervoor dat u op het lay-outtabblad Elevation and Floor Plan staat.

2 Maak de laag Title Block de actieve laag.

3 Klik op de menubrowser ➤ Insert ➤ Block.

4 Klik op Letter (Portrait) in de lijst Name van het dialoogvenster Insert.

5 Zorg ervoor dat het selectievakje Specify On-screen onder Insertion Point is ingeschakeld.

6 Zorg ervoor dat het selectievakje Specify On-screen onder Scale is uitgeschakeld. Indien nodig 
kunt u 1 in de vakjes X, Y en Z typen om in te stellen dat de lay-out op volledige schaal geplot 
moet worden.

7 Zorg ervoor dat het selectievakje Specify On-screen onder Rotation is uitgeschakeld. Typ indien 
nodig 0 in het vakje Angle om het titelblok horizontaal te houden. Klik op OK.

8 Verplaats de cursor om het titelblok te centreren en klik dan om het op de lay-out te plaatsen.

De te plotten vensters instellen

Nu de lay-outvensters gemaakt zijn, kunt u de schaal opgeven van het werkvlakaanzicht dat in elk 
venster wordt weergegeven.

1 Selecteer beide vensters door op hun randen te klikken.

2 Klik op Properties in het menu Modify. 

3 Klik op Layer in het palet Properties en selecteer de laag Viewports in de vervolgkeuzelijst.
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4 Klik op Standard Scale in het palet Properties en selecteer 3/32"=1' in de vervolgkeuzelijst met 
schalen.

5 De werkvlakobjecten worden correct geschaald voor plotten bij 3/32"=1' (1:128).

6 Dubbelklik in het bovenste venster om naar het werkvlak te gaan. Pan de afbeelding in het 
venster tot alleen het hoogteaanzicht wordt weergegeven.

7 Klik in het onderste venster om het actief te maken. Pan de afbeelding in het venster tot alleen 
het grondplan wordt weergegeven.

8 Klik op de menubrowser ➤ Format ➤ Layer.

9 Selecteer de laag Viewports in de kolom Name in de Layer Properties Manager. Klik op het 
pictogram Plot/No Plot in de kolom Plot om het plotten van de laag Viewport uit te schakelen.

10 Dubbelklik buiten de vensters om naar het papierkader terug te keren. Vergrendel vervolgens 
beide vensters.

Het plotten wordt uitgeschakeld voor de vensterranden, maar de weergegeven objecten in het 
venster worden nog steeds geplot. U kunt ook de laag Viewport uitschakelen.

De lay-out plotten

Nu dat u een lay-out hebt gemaakt en de lay-outvensters voor plotten hebt voorbereid, kunt u de 
tekening plotten.

1 Klik op de menubrowser ➤ File ➤ Plot.

De plotter die u in de wizard gekozen hebt, is nog steeds geselecteerd.
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2 Klik indien nodig op de knop > in de rechterbenedenhoek van het dialoogvenster Plot om meer 
plotopties weer te geven.

3 Selecteer het bestand monochrome.ctb in de lijst Name onder Plot Style Table (Pen Assignments).

4 Klik op Extents onder Plot Area.

5 Klik op Portrait onder Drawing Orientation.

6 Stel de schaal van de plot op 1:1 in onder Plot Scale.

7 Klik op Center the Plot onder Plot Offset.

8 Klik op Preview onder aan het dialoogvenster. Nadat u de plot bekeken hebt, drukt u op ESC. 
Klik op OK om het dialoogevenster Plot te sluiten en de tekening naar het DWF-bestand te 
plotten.

U kunt het DWF-bestand nu desgewenst ter controle naar de klant sturen.

9 Klik op de menubrowser ➤ menu File ➤ Save As. Typ Plan Complete in het vak File Name van 
het dialoogvenster Save Drawing As en klik op Save.

Aan de slag

Handeling Menubrowser Lint

Een nieuwe lay-out maken Insert ➤ Layout Viewports

Een lay-outvenster maken View ➤ Viewports ➤ 1 Viewport Viewports

Een aanzicht in een lay-outvenster schalen Tools ➤ Properties Viewports

Een plotter toevoegen of een 
plotterconfiguratie wijzigen

File ➤ Plotter Manager Plotten

Eigenschappen tijdens plotten vervangen File ➤ Plot Style Manager Plotten

Opgeslagen instellingen voor plotten 
herstellen

File ➤ Page Setup Manager Plotten

Een lay-out plotten File ➤ Plot Plotten

Help-systeem

LAYOUT, LAYOUTWIZARD, MVIEW, PLOTTERMANAGER, OPTIONS, PAGESETUP, PLOTSTAMP, PLOT, 
STYLESMANAGER, PLOTSTYLE, CONVERTPSTYLES, CONVERTCTB
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Testvragen

1 Welke typen objecten zijn vaak op een lay-outtabblad te vinden?

2 Hoe geeft u de schaal van een lay-outvenster op?

3 Hoe schakelt u de weergave van lay-outvensterranden uit?

4 Hoe kunt u een plotstijltabel gebruiken?

5 Wat is de snelste manier om plotinstellingen op naam op te slaan?
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Verklarende woordenlijst

Opdrachten en systeemvariabelen die aan definities zijn gekoppeld, worden tussen haakjes 
weergegeven aan het eind van de definitie.

Term Definitie

aanwijsapparaat Een apparaat, zoals een muis of een digitaliseerpuck, waarmee u 
door de interface kunt navigeren, en objecten in het tekengebied 
kunt maken en bewerken. Een aanwijsapparaat heeft meestal 
verschillende knoppen, die u soms kunt aanpassen om bepaalde 
taken uit te voeren. 

aanzicht Een grafische weergave van een model vanaf een bepaalde 
ruimtelijke locatie (standpunt). Zie ook venster. (VPOINT, DVIEW, 
VIEW)

absolute coördinaten Coördinaatwaarden die vanaf de oorsprong van een 
coördinatenstelsel worden gemeten. Zie ook oorsprong, relatieve 
coördinaten, gebruikerscoördinatenstelsel (UCS), 
wereldcoördinaten, en wereldcoördinatenstelsel (WCS).

actieve objectmagneten Een Object Snap-modus instellen zodat deze voor alle volgende 
selecties wordt gebruikt. Zie ook Object Snap-modus en 
objectmagneten opheffen. (OSNAP)

annotatie Tekst, bematingen, toleranties, symbolen of notities.

associatieve arcering Arcering die zich aan de omlijningsobjecten aanpast, zodat de 
arcering bij wijziging van de omlijningsobjecten automatisch wordt 
aangepast. (BHATCH)

associatieve bemating Een bemating die automatisch wordt aangepast wanneer de 
bijbehorende geometrie wordt gewijzigd. Deze waarde wordt door 
de systeemvariabele DIMASSOC bepaald. Zie ook opgesplitste 
bemating.

attribuutdefinitie Een object dat deel uitmaakt van een blokdefinitie en waarin 
alfanumerieke gegevens over het blok kunnen worden opgeslagen. 
Attribuutwaarden kunnen vooraf worden gedefinieerd of worden 
opgegeven wanneer het blok wordt ingevoegd. Attribuutgegevens 
kunnen uit een tekening worden geëxtraheerd en in externe 
bestanden worden ingevoegd. (ATTDEF)



Auto-hide Een paletinstelling waarmee paletten automatisch worden 
verborgen wanneer de cursor buiten het palet wordt geplaatst, en 
automatisch worden geopend wanneer de cursor op de titelbalk 
wordt gezet.

basislijnbematingen Meerdere bematingen die vanaf dezelfde basislijn worden gemeten. 
Ook wel parallelbematingen genoemd. 

basispunt 1. In de context van bewerkingsgrips is dit de grip die na selectie 
een effen kleur krijgt om de focus van de volgende bewerking aan te 
geven. 2. Een punt voor relatieve afstand en hoek bij het kopiëren, 
verplaatsen en roteren van objecten. 3. De invoegbasispositie in de 
huidige tekening. (BASE) 4. De invoegbasispositie voor een 
blokdefinitie. (BLOCK)

begrenzingen Zie tekeningbegrenzingen.

bematingsstijl Een benoemde groep bematingsinstellingen die de opmaak van de 
bemating bepaalt en de instelling van bematingssysteemvariabelen 
vereenvoudigt. (DIMSTYLE)

bematingstekst De afmetingswaarde van bemate objecten.

bematingsvariabelen Een reeks numerieke waarden, tekenreeksen en instellingen 
waarmee bematingseigenschappen worden bepaald. (DIMSTYLE)

benoemd object Beschrijft de diverse soorten niet-grafische gegevens, zoals stijlen en 
definities, die bij een tekening worden opgeslagen. Benoemde 
objecten zijn onder meer lijntypen, lagen, bematingsstijlen, 
tekststijlen, blokdefinities, lay-outs, aanzichten en 
vensterconfiguraties. Benoemde objecten worden in 
definitietabellen (symbooltabellen) opgeslagen.

bevriezen Een instelling waarmee de weergave van objecten op geselecteerde 
lagen wordt onderdrukt. Objecten op bevroren lagen worden niet 
weergegeven, geregenereerd of geplot. Het bevriezen van lagen 
verkort regeneratietijd. Zie ook ontdooien. (LAYER)

blok Een algemene term voor een of meer objecten die worden 
samengevoegd om één object te vormen. Wordt vaak gebruikt voor 
een blokdefinitie of blokreferentie. Zie ook blokdefinitie en 
blokreferentie. (BLOCK)

blokdefinitie De naam, het basispunt en de set met objecten die in de 
symbolentabel van een tekening worden samengevoegd en 
opgeslagen. Zie ook blok en blokreferentie.

blokdefinitietabel Het niet-grafische gegevensgebied van een tekeningbestand waarin 
blokdefinities worden opgeslagen.

blokreferentie Een samengesteld object dat wordt ingevoegd in een tekening, en 
dat de gegevens weergeeft die in een blokdefinitie zijn opgeslagen. 
Ook wel verwijzing genoemd. Zie ook blok en blokdefinitie. 
(INSERT)

Term Definitie
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blokverwijzing Zie blokreferentie.

bovenaanzicht Een aanzichtrichting vanaf een punt op de positieve Z-as naar de 
oorsprong (0,0,0) toe. (PLAN)

B-spline-kromme Een gelijkmatige, uit delen opgebouwde polynome kromme die 
langs een opgegeven set stuurpunten loopt. (SPLINE)

BYBLOCK Een speciale objecteigenschap waarmee kan worden opgegeven dat 
het object de kleur of het lijntype moet overnemen van het blok 
waarin het zich bevindt. Zie ook BYLAYER.

BYLAYER Een speciale objecteigenschap waarmee kan worden opgegeven dat 
het object de kleur of het lijntype moet overnemen van zijn laag. Zie 
ook BYBLOCK.

CTB-bestand Een kleurafhankelijke plotstijltabel.

cursor Zie kruiscursor.

cursormenu Zie snelmenu.

definitietabel Het niet-grafische gegevensgebied van een tekeningbestand waarin 
blokdefinities worden opgeslagen.

DesignCenter Hiermee kunt u inhoud - waaronder blokken, arceringen en 
referentietekeningen (xref's) - doornemen, opzoeken, vooraf 
bekijken en invoegen. (ADCENTER)

digitale handtekening Hiermee wordt een individuele gebruiker of een organisatie met 
behulp van een digitale ID (een certificaat) geïdentificeerd, en kunt 
u een bestand valideren (zijn authenticiteit controleren). 
(SIGVALIDATE)

directe invoer van afstand Een methode voor het opgeven van een tweede punt waarbij eerst 
de cursor wordt verplaatst om de richting aan te geven en 
vervolgens een afstand wordt ingevoerd.

DWF Voor Design Web Format. Een sterk gecomprimeerde 
bestandsindeling die op basis van een DWG-bestand wordt 
gemaakt. DWF-bestanden kunnen gemakkelijk op het web worden 
gepubliceerd en bekeken. Zie ook DWG, DWT, en DXF.

DWT Voor tekeningsjabloon. Een tekeningbestand dat 
standaardinstellingen bevat die bij het maken van nieuwe 
tekeningen gebruikt moeten worden. Zie ook DWG.

DXF Voor Drawing Interchange Format. Een binaire of ASCII-
bestandsindeling van een AutoCAD-tekeningbestand om 
tekeningen naar andere toepassingen te exporteren of uit andere 
toepassingen te importeren. Zie ook DWF, DWG, en DWT.

eigenschappen Zie objecteigenschappen.

eiland Een ingesloten gebied binnen een gearceerd gebied.
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gebruikerscoördinaten-
stelsel (UCS)

Een door de gebruiker gedefinieerd coördinatenstelsel dat de 
richting aangeeft van de X-, Y- en Z-as in 3D-ruimte. Het UCS 
bepaalt de standaardpositie van geometrische modellen in een 
tekening. Zie ook wereldcoördinatenstelsel (WCS).

geometrie Alle grafische objecten zoals lijnen, cirkels, bogen, polylijnen en 
bematingen. Niet-grafische objecten zoals lijntypen, lijndikten, 
tekststijlen en lagen worden niet als geometrie beschouwd. Zie ook 
benoemd object.

grafisch gebied Zie tekengebied.

grafisch scherm Zie tekengebied.

grenzen Zie rastergrenzen.

Gripmodi De bewerkingsmogelijkheden wanneer grips op een object worden 
weergegeven: uitrekken, verplaatsen, roteren schalen en spiegelen.

grips Vierkantjes die op geselecteerde objecten verschijnen. Nadat u een 
grip hebt geselecteerd, kunt u het object via slepen bewerken in 
plaats van opdrachten in te voeren.

hoekbemating Een bemating die hoeken of boogsegmenten meet, en uit tekst, 
extensielijnen en verwijslijnen bestaat. (DIMANGULAR)

hoekeenheid De maateenheid voor een hoek. Hoekeenheden worden gemeten in 
decimale graden, graden/minuten/seconden, gradiënten of 
radialen.

hoekpunt Een locatie waarop randen of polylijnsegmenten elkaar raken.

i-drop Een methode waarmee u een tekeningbestand uit een webpagina 
kunt slepen en in een andere tekening kunt invoegen.

InfoCenter Een tool in de rechterbovenhoek van het toepassingsvenster waarin 
trefwoorden ingevoerd kunnen worden om meerdere bronnen en 
locaties tegelijk op informatie te doorzoeken (bijvoorbeeld de Help, 
New Features Workshop, weblocaties en opgegeven bestanden).

knooppunt Een specificatie van objectmagneten om punten, definitiepunten 
voor bematingen, en oorsprongen van bematingsteksten te vinden.

kruiscursor Een soort cursor die uit twee snijdende lijnen bestaat.

laag Een logische groepering van gegevens, vergelijkbaar met een 
transparante overlay op een tekening. U kunt lagen afzonderlijk of in 
combinatie weergeven. (LAYER)

lay-out De omgeving met tabbladen, waarin u te plotten lay-outvensters in 
het papierkader maakt en ontwerpt. Voor elke tekening kunnen 
meerdere lay-outs worden gemaakt.

lay-outvensters Objecten die in het papierkader worden gemaakt om verschillende 
aanzichten weer te geven. Zie ook papierkader. (VPORTS)
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lettertype Een tekenset, die letters, cijfers, leestekens en symbolen van een 
bepaalde grootte en met een bepaalde opmaak bevat.

lijnbreedte Zie lijndikte.

lijndikte Een breedtewaarde die aan alle grafische objecten kan worden 
toegewezen, behalve TrueType®-lettertypen en rasterbeelden.

lijnlettertype Zie lijntype.

lijntype Bepaalt de manier waarop een lijn of kromme wordt weergegeven. 
Een ononderbroken lijn heeft bijvoorbeeld een ander lijntype dan 
een streepjeslijn. Wordt ook lijnlettertype genoemd. (LINETYPE)

magneet Zie magneethoek, magnetisch raster, resolutie van magnetisch 
raster en PolarSnap.

magneethoek Het onzichtbare raster waarop de cursor automatisch wordt 
uitgelijnd met de rasterpunten op basis van de afstand die is 
ingesteld met de opdracht Snap. Het magnetische raster hoeft niet 
per se overeen te komen met het zichtbare raster, dat u afzonderlijk 
kunt instellen met de opdracht GRID. (SNAP)

magnetisch raster Het onzichtbare raster waarop de cursor automatisch wordt 
uitgelijnd met de rasterpunten op basis van de afstand die is 
ingesteld met de opdracht Snap. Het magnetische raster hoeft niet 
per se overeen te komen met het zichtbare raster, dat u afzonderlijk 
kunt instellen met de opdracht GRID. (SNAP)

matrix 1. Meerdere exemplaren van geselecteerde objecten in een 
rechthoekig of polair (radiaal) patroon. (ARRAY) 2. Een verzameling 
gegevensitems die elk worden aangegeven met een subscript of 
sleutel, en die zo zijn geordend dat een computer de verzameling 
kan analyseren en aan de hand van de sleutel gegevens kan 
ophalen. 

model Een twee- of driedimensionale weergave van een object. 

modelvensters Een weergave waarin het tekengebied in een of meer rechthoekige 
weergavegebieden wordt opgedeeld. Zie ook lay-outvensters en 
venster. (VPORTS)

modus Een software-instelling of bewerkingsstatus. 

naast elkaar gerangschikte 
vensters

Zie modelvensters.

NURBS Acroniem voor Nonuniform Rational B-Spline-kromme. Een B-spline-
kromme of -oppervlak dat door een reeks gewogen stuurpunten en 
een of meer knoopvectoren wordt gedefinieerd. Zie ook B-spline-
kromme.
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object Een of meer grafische elementen, zoals tekst, bematingen, lijnen, 
cirkels of polylijnen, die als één element kunnen worden gemaakt, 
gemanipuleerd en gewijzigd. Vroeger entiteit genoemd.

Object Snap-menu Het menu dat in het tekengebied bij de cursorlocatie verschijnt 
wanneer u de SHIFT-toets ingedrukt houdt terwijl u rechtsklikt met 
het aanwijsapparaat. Zie ook snelmenu.

objecteigenschappen Instellingen die de weergave en geometrische kenmerken van 
objecten bepalen. Eigenschappen die alle objecten met elkaar 
gemeen hebben, zijn o.a. kleur, laag, lijntype, lijntypeschaal en 
3D-dikte. (PROPERTIES)

objectmagneetmarkeringen Een geometrisch symbool dat verschijnt wanneer de cursor boven 
een object staat. Zie ook Object Snap-modus.

objectmagneetmodus Methoden voor het selecteren van veel gebruikte punten op een 
object terwijl u een tekening maakt of bewerkt. Zie ook actieve 
objectmagneten en objectmagneten opheffen.

objectmagneten opheffen Een actieve objectmagneet uitschakelen of wijzigen om één punt in 
te voeren. Zie ook Object Snap-modus en actieve 
objectmagneten.

ontdooien Een instelling waarmee eerder bevroren lagen worden weergeven. 
Zie ook bevriezen. (LAYER)

oorsprong Het punt waarop de assen van een coördinatenstelsel elkaar snijden. 
De oorsprong van een Cartesisch coördinatenstelsel is bijvoorbeeld 
het punt waar de X-, Y- en Z-as elkaar snijden (0,0,0). 

opdrachtalias Een snelkoppeling voor een opdracht. CP is bijvoorbeeld een alias 
voor COPY, en Z een alias voor ZOOM. U definieert aliassen in het 
PGP-bestand.

opdrachtregel Een tekstgebied dat is gereserveerd voor toetsenbordinvoer, 
prompts en berichten.

opdrachtvenster Een tekstgebied waarin de opdrachtregel en een geschiedenis van 
prompts en berichten wordt weergegeven.

opschonen Een functie waarmee ongebruikte definities zoals blokdefinities, 
lagen en tekststijlen uit een tekening kunnen worden verwijderd. 
(PURGE)

opsplitsen Een bewerking waarbij een samengesteld object, zoals een blok, 
bemating of polylijn, in enkelvoudige objecten wordt opgedeeld. 
In het geval van een blok blijft de blokdefinitie ongewijzigd. 
De blokverwijzing wordt vervangen door de inhoud van het blok. 
Zie ook blok, blokdefinitie en blokreferentie. (EXPLODE)

opvulling Een effen kleur die een door lijnen of krommen begrensd gebied 
bedekt. (FILL)
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Ortho-modus Beperkt de invoer van een aanwijsapparaat tot horizontaal of 
verticaal (ten opzichte van de huidige magneethoek en het 
gebruikerscoördinatenstelsel). Zie ook magneethoek en 
gebruikerscoördinatenstelsel (UCS). (ORTHO)

overlappend selectiekader Een rechthoekig gebied waarmee u objecten kunt selecteren die 
geheel of gedeeltelijk binnen zijn grenzen vallen. Zie ook 
vensterselectie.

pagina-instelling Een methode waarmee plotinstellingen benoemd en opgeslagen 
kunnen worden. Zie ook zoomen. (PAGESETUP)

pannen Het aanzicht van een tekening verschuiven zonder de vergroting te 
wijzigen. Zie ook zoomen. (PAN)

papierkader Een van de twee primaire ruimten waarin objecten zich bevinden. In 
het papierkader kunt u een definitieve lay-out maken voordat u gaat 
afdrukken of plotten, maar het wordt niet gebruikt voor teken- of 
ontwerpwerk. U kunt papierkadervensters ontwerpen met behulp 
van een lay-outtabblad. Het werkvlak wordt gebruikt om de 
tekening te maken. U ontwerpt uw model via het tabblad Model. 
Zie ook werkvlak. (PSPACE)

pijlpunt Een afsluitteken, zoals een pijlpunt, een schuine streep of stip, aan 
het eind van een bematingslijn dat aangeeft waar een bemating 
begint en eindigt. 

pline Zie polylijn.

plotstijl Een objecteigenschap die een set vervangingswaarden specificeert 
voor kleur, rastering, grijstinten, pentoewijzingen, 
schermvoorbeelden, lijntypen, lijndikten, eindstijlen, 
samenvoegingsstijlen en opvulstijlen. Plotstijlen worden tijdens het 
plotten toegepast.

plotstijltabel Een set plotstijlen. Plotstijlen worden in plotstijltabellen 
gedefinieerd, en zijn alleen op objecten van toepassing wanneer de 
plotstijltabel aan een lay-out of venster is gekoppeld.

polaire tracking Een nauwkeurige tekentool waarmee tijdelijke uitlijningspaden 
worden weergegeven die door gebruikergedefinieerd polaire 
hoeken worden bepaald. Zie ook PolarSnap.

PolarSnap Een nauwkeurige tekentool waarmee u naar incrementele afstanden 
langs het uitlijningspad voor polaire tracking springt. Zie ook polaire 
tracking.

polylijn Een object dat is samengesteld uit een of meer met elkaar 
verbonden lijnsegmenten of cirkelvormige bogen die als één object 
worden behandeld. Ook wel pline genoemd. (PLINE, PEDIT)

poolmatrix Objecten die een opgegeven aantal keren rond een opgegeven 
hartpunt zijn gekopieerd. (ARRAY)
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prompt Een bericht op de opdrachtregel waarin gevraagd wordt gegevens 
in te voeren of een bepaalde bewerking uit te voeren, zoals het 
opgeven van een punt.

Properties-palet Hierop worden eigenschappen van het geselecteerde object of een 
set objecten weergegeven of gewijzigd. Als er geen objecten zijn 
geselecteerd, worden de waarden van standaardeigenschappen 
voor alle objecten weergegeven of gewijzigd. (PROPERTIES)

punt 1. Een locatie in driedimensionale ruimte, gespecificeerd door X-, 
Y- en Z-coördinaatwaarden. 2. Een object dat uit één 
coördinaatlocatie bestaat. (POINT)

raster Een regelmatig patroon van punten dat als hulpmiddel bij het 
tekenen dient. De afstand tussen de rasterpunten is aanpasbaar. 
Rasterpunten worden niet geplot. Zie ook rastergrenzen. (GRID)

rastergrenzen De door de gebruiker gedefinieerde rechthoekige omtrek van het 
tekengebied dat door rasterpunten wordt bedekt wanneer het raster 
is ingeschakeld. Ook wel tekeninggrenzen genoemd. (LIMITS)

referentietekening (xref) Een tekeningbestand waarnaar een andere tekening verwijst. (XREF)

relatieve coördinaten Coördinaten die worden opgegeven ten opzichte van eerder 
opgegeven coördinaten.

schaal 1. De grootte van een object in vergelijking met andere objecten. 
2. De weergavegrootte van de componenten van onderbroken 
lijntypen en arceringen. 3. De schijnbare grootte van objecten in 
een aanzicht ten opzichte van een tekenblad. (SCALE, HPSCALE, 
LTSCALE, CELTSCALE, ZOOM) 

selectiegroep Een of meer geselecteerde objecten waarop een opdracht tegelijk 
mag worden uitgevoerd. 

selectieknop De knop op een aanwijsapparaat waarmee u objecten selecteert of 
punten opgeeft op het scherm. De selectieknop op een 
tweeknopsmuis is bijvoorbeeld de linkerknop.

selectievak De vierkante cursor waarmee een object in het tekengebied wordt 
geselecteerd.

sjabloonbestand voor 
tekeningen

Een tekeningbestand met vooraf bepaalde instellingen voor nieuwe 
tekeningen. Sjabloonbestanden voor tekeningen hebben de 
extensie .dwt.

sjabloontekening Een tekeningbestand met vooraf bepaalde instellingen voor nieuwe 
tekeningen zoals aclt.dwt en acltiso.dwt, maar elke tekening kan als 
sjabloon worden gebruikt. 
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Snap-modus Een modus waarin een aanwijsapparaat automatisch wordt 
uitgelijnd op een onzichtbaar rechthoekig raster. Wanneer de Snap-
modus actief is, worden de kruiscursor en alle ingevoerde 
coördinaten op het dichtstbijzijnde punt op het raster uitgelijnd. 
De resolutie van het magnetische raster bepaalt de afstand tussen 
de rasterpunten. Zie ook Object Snap-modus. (SNAP)

snelmenu Het menu dat op de cursorlocatie wordt weergegeven wanneer u 
met de rechterknop van uw aanwijsapparaat klikt. Het snelmenu en 
de opties die daarin worden geboden, hangen af van de locatie van 
de cursor en andere omstandigheden, bijvoorbeeld of een object is 
geselecteerd of dat er een opdracht wordt verwerkt.

sneltoetsen Toetsen en toetsencombinaties waarmee u opdrachten start. 
Met CTRL + S slaat u bijvoorbeeld een bestand op. De functietoetsen 
(F1, F2, enzovoort) zijn ook sneltoetsen. Ook accelerators genoemd.

spiegelen Een nieuwe versie van een bestaand object maken door het 
symmetrisch ten opzichte van een bepaalde lijn of bepaald vlak te 
reflecteren. (MIRROR)

spline Zie B-spline-kromme en NURBS.

standaardwaarde Een vooraf gedefinieerde waarde voor programma-invoer of een 
parameter. Standaardwaarden en -opties worden tussen punthaken 
aangegeven (<>).

statusbalk Het gebied onder in het toepassingsvenster dat knoppen bevat 
waarmee de werking van het programma wordt geregeld, en waar 
de coördinaten van de cursorlocatie in het tekengebied worden 
weergegeven.

STB-bestand Voor bestand met plotstijltabellen. Bevat plotstijlen en de 
bijbehorende kenmerken.

structuurweergave Een hiërarchische lijst die uit- of samengevouwen kan worden om 
de gewenste hoeveelheid gegevens weer te geven. 
Structuurweergaven zijn beschikbaar in DesignCenter, het 
dialoogvenster Purge en het Help-systeem.

symbolenbibliotheek Een verzameling blokdefinities die in één tekeningbestand zijn 
opgeslagen. Zie ook blokkenbibliotheek.

symbolentabel Zie definitietabel en blokdefinitietabel.

symbool Een voorstelling van een item dat vaak wordt gebruikt in 
tekeningen. Zie blok.

systeemvariabele Een naam die vergelijkbaar is met een opdracht die als modus, 
grootte of limiet wordt gebruikt. Systeemvariabelen met het 
kenmerk Alleen-lezen, zoals DWGNAME, kunnen niet rechtstreeks 
door de gebruiker worden gewijzigd.
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tekeneenheden De maateenheid die in een tekening wordt gebruikt. 
Eén tekeneenheid kan gelijk zijn aan een inch, millimeter, kilometer, 
mijl of andere afstand, afhankelijk van de tekening.

tekengebied Het gebied waarin uw tekeningen worden weergegeven en 
gewijzigd.

tekeningbegrenzingen De kleinste rechthoek die alle objecten in een tekening omvat, en 
die zodanig op het scherm wordt geplaatst dat de grootst mogelijke 
weergave van alle objecten wordt verkregen. (ZOOM)

tekeninggrenzen Zie rastergrenzen. 

tekststijl Een verzameling instellingen die onder een bepaalde naam wordt 
opgeslagen en die de opmaak van tekst bepaalt. Met tekststijlen 
kunt u tekens bijvoorbeeld uitrekken, comprimeren, cursiveren, 
spiegelen of in een verticale kolom zetten.

toolpalet Gebieden met tabbladen in het venster Tool Palettes, waarmee u 
efficiënt blokken en arceringen kunt ordenen, delen en plaatsen.

UCS Zie gebruikerscoördinatenstelsel (UCS).

UCS-pictogram Een pictogram dat de richting aangeeft van de UCS-assen. 
(UCSICON)

uitgelijnde bemating Een bemating die onder een willekeurige hoek de afstand aangeeft 
tussen twee punten. De bematingslijn loopt parallel aan de lijn 
tussen de definitiepunten van de bemating. (DIMALIGNED)

venster Zie modelvensters en lay-outvensters Zie ook aanzicht. (VPORTS)

vensterselectie Een rechthoekig gebied dat in het tekengebied wordt opgegeven 
om verschillende objecten tegelijk te selecteren. Zie ook 
overlappend selectiekader en selectie met polygoonkaders.

vervangende hoeken Vergrendelt de cursor voor het volgende punt dat wordt ingevoerd. 
Als u een vervangende hoek wilt opgeven, voert u een kleiner-dan-
teken (<) in gevolgd door een hoek, wanneer u achter de 
opdrachtprompt een punt moet opgeven.

vervolgbemating Een soort lineaire bemating waarbij de oorsprong van de tweede 
extensielijn van een geselecteerde bemating als de oorsprong van 
de eerste extensielijn wordt gebruikt, waardoor één lange bemating 
in kortere segmenten wordt opgedeeld die samen de totale 
afmeting vormen. Deze bemating wordt ook kettingbemating 
genoemd. (DIMCONTINUE)

verwijzing Zie blokreferentie.
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werkvlak Een van de twee primaire ruimten waarin objecten zich bevinden. 
Een geometrisch model wordt meestal in een driedimensionale 
coördinatenruimte geplaatst die het werkvlak wordt genoemd. De 
definitieve lay-out van specifieke aanzichten en annotaties van dit 
model wordt in het papierkader weergegeven. Zie ook papierkader. 
(MSPACE)

xref Zie referentietekening (xref).

zoomen Het verkleinen of uitbreiden van de schijnbare vergroting van het 
tekengebied. (ZOOM)

zwevende vensters Zie lay-outvensters.
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Index

A
aanwijsapparaten, 30, 38, 40, 161
aanzichten, 38, 161

hele tekening weergeven, 38
pannen, 15, 39
verplaatsen, 39
Zie ook vensters

absolute coördinaten, 74, 161
accelerators (sneltoetsen), 169
achterwaarts lezen van tekst, 128
actieve laag, 50, 59
actieve objecten (schaalinstellingen), 62
actieve objectmagneet, 77, 161
Add-a-Plotter (wizard), 153
afdrukstand, 154
afronden van objecten, 68, 83, 94
afstand

arceerpatronen, 122
raster- en magneetinstellingen, 72

afstanden
berekenen, 111
directe invoer van afstand, 79, 163
meten, 83
polaire tracking, 79
poolcoördinaten, 74

afwerken van weergave, 40
algemene schaalfactor voor lijntypen, 62
aliassen, opdracht, 31, 166
annotaties, 134, 140, 161
arceringen en arceerpatronen, 113, 120

associatieve arceringen, 120
bronnen van, 120
eilanden binnen grenzen, 121
interne punten, 122

invoegen, 121
assen voor coördinaten, 74
associatieve arceringen, 120, 161
associatieve bematingen, 17, 135, 161
attribuutdefinities, 161
Autodesk Design Review (DWF-viewer), 156
Auto-hide (functie), 162
automatisch verbergen en paletten, 57
AutoSnap-markeringen, 76, 81

B
basislijnbematingen, 131, 144
basispunten, 90, 93, 162
beëindigen van opdrachten, 34
beginpunten, 65, 67
begrenzingen, tekening, 162
bematingen en bematen

associatieve bematingen, 17, 135
bematingen bewerken, 143
bematingen verplaatsen, 143
bematingsstijlen, 141, 162
bematingsvariabelen, 162
eigenschappen bewerken, 58
elementen of bematingen, 134
grips, 143
hartpunten en hartlijnen, 139, 142
lagen voor, 136, 137
maateenheden, 142
maken, 136, 144
nauwkeurigheid, 13
overzicht, 134
schaal wijzigen, 149
standaarden voor, 142



stijlen in sjablonen opslaan, 9
tekst, 142, 162
typen, 17, 134, 144

bematingen met coördinaten, 131, 134, 144
bematingen van Quick Leader, 131
bematingsstijlen, 141, 162

extensielijnen, 142
vervangen, 141

bematingstekst, 134, 162
bematingsvariabelen, 162
benoemde lagen, 7
benoemde objecten, 162
benoemde plotstijltabellen, 153
berekenen van afstanden, hoeken of coördinaten,

111
bevriezen van lagen, 51, 162
bewerken van objecten

afronden, 94
associatieve arceringen en, 120
bematingen, 143
eigenschappen, 57, 107
eigenschappen kopiëren, 108
gripbewerkingsmodus, 109
kopieën verschuiven, 92
nauwkeurig bewerken, 95
objecten bijsnijden, 88
objecten dupliceren, 90
objecten selecteren voor bewerking, 86
objecten wissen, 87
objectgrenzen, 96
overzicht, 19
revisiewolken, 19, 110
spiegelen, 92
tekeningen wijzigen, 19
tekst, 126
tekststijlen, 128
verlengen van objecten, 88

bewerken van plotterconfiguraties, 153
bewerken van tekst, 126, 128
bibliotheken

blokkenbibliotheken, 116
DesignCenter, 118
DesignCenter Online, 119

bijschriften (verwijslijnen), 17, 134, 140
bijsnijdgrenzen, 106
blokattributen, 116
blokdefinities, 162
blokdefinitietabellen, 162
blokken, 113, 116, 162

blokattributen, 116
blokdefinities, 162
blokdefinitietabellen, 162
blokreferenties, 162
bronnen van, 117
invoegen, 117
titelblokken, 157

vaak gebruikt voor, 116
verplaatsen, 119
Zie ook blokkenbibliotheken

blokkenbibliotheken, 116, 118, 119
blokreferenties, 162
blokverwijzingen (blokreferenties), 163
bogen

afronden, 68, 94
polylijnen maken met, 65
tekenen, 67
weergave opnieuw genereren van, 40

bouwkundige sjabloonbestanden, 45
bouwkundige tekening (notatie van 

tekeneenheden), 46
bovenaanzichten, 163
breedte

polylijnen, 66
tekstobjecten, 126
teksttekens, 128

breuken, 46, 47
B-spline-krommen, 163
BYBLOCK (eigenschap), 163
BYLAYER (eigenschap), 59, 61, 63, 163

C
Cancel (opdracht), 34
Cartesische coördinaten, 74, 75
Center (objectmagneet), 78
centreren van weergaven in lay-outvensters, 137
cirkels, 33, 67, 94, 103

weergave opnieuw genereren van, 40
coördinaten en coördinatenstelsels

absolute en relatieve coördinaten, 74, 75, 161, 
168

Cartesische coördinaten, 74
delta berekenen, 111
dynamische invoer en, 75
oorsprongspunt, 74, 102
opgeven, 13
overzicht, 74
poolcoördinaten, 74

COPY (opdracht), 83
correcties (revisiewolken), 110
CTB-bestanden (kleurafhankelijke plotstijltabellen),

153, 163
cursieve lettertypen, 128
cursormenu's. Zie snelmenu's
cursors

dynamische prompts weergegeven door, 32
in- of uitzoomen met, 38
pannen met, 39
selectiekader, 81
uitlijnen aan raster, 72
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D
DC Online (tabblad in DesignCenter), 119
decimalen

afronding op het scherm, 47
notatie van tekeneenheden, 46

definitietabellen, 163
delta berekenen, 111
deselecteren van objecten, 86
Design Web Format-bestanden (DWF), 152, 156
DesignCenter, 163

arceerpatronen in, 121
bronnen van blokkenbibliotheken, 117
tabblad DC Online, 119

diameterbematingen, 131, 144
diameters, 67
digitale handtekeningen, 163
Dimension Style Manager (dialoogvenster), 141
DIMSCALE (systeemvariabele), 138
directe invoer van afstand, 79, 91, 163
DIST (opdracht), 83, 111
Drafting Settings (dialoogvenster), 73, 77
Drawing Interchange Format-bestanden (DXF), 163
DWF-bestanden (Design Web Format), 152, 156, 

163
DWT-bestanden. Zie sjabloonbestanden
DXF-bestanden, 163
Dynamic Input (knop), 75
dynamische invoer, 75

E
eigenschappen, 56

bewerken, 58, 107
laagtoewijzingen, 56
naar andere objecten kopiëren, 108
overeen laten komen, 108
Paneel Properties, 107
paneel Properties, 57
Properties (palet), 57, 107, 168
toewijzen, 56
weergeven, 58

eilanden, 121, 163
eindpunten, 65, 67
ellipsen, 94
Endpoint (objectmagneet), 78, 104
Engelse eenheden (tekeningsjabloonbestanden in),

45
entiteiten. Zie objecten
ERASE (opdracht), 87
ESC-toets, 30
EXPLODE (opdracht), 66
EXTEND (opdracht), 88
extensielijnen, 134, 142

F
FILLET (opdracht), 68, 83
formaat wijzigen

lijntypen, 62
tekstobjecten, 126
vensters, 151

G
gebruikerscoördinatenstelsel (UCS), 164
geometrie, 164
gesloten polylijnen, 65
grafisch gebied van het scherm (tekengebied), 170
grenzen

bewerken, 96
bijsnijdgrenzen, 106
gearceerde gebieden, 121
polylijnen, 101
tekstobjecten, 126
verlengen van objecten, 88

grenzen, raster, 72, 168
gripmodi, 164
grips, 164

bematingen bewerken, 143
bewerken van objecten, 109
blokken, 119
gripmodi, 164
venstergrips, 151
weergeven, 86

H
haaklijnen, 140
handelingen ongedaan maken, 34
hartlijnen, 139, 142
hartpunten, 131, 139, 142
helling van teksttekens, 128
Help

Help-opdracht, 25
Help-systeem, 23
inhoudsopgave (tabblad Contents), 25
procedureel, 25
studieles, 24

herhalen van opdrachten, 34, 91
hoekbematingen, 131, 134, 144, 164
hoekeenheden, 164
hoeken

arceerpatronen, 122
berekenen, 111
hoekeenheden, 164
opgeven voor bogen, 67
polaire tracking, 79
poolcoördinaten, 74
rotatiehoeken, 93
teksttekens, 128
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vervangende hoeken, 80, 170
hoeken afronden, 94
hoekpunten, 164
hoogte van teksttekens, 128
horizontale bematingen, 131
horizontale uitlijning van tekst, 128

I
i-drop, 164
in- of uitzoomen, 171

aanzichten schalen in vensters, 5, 157
overzicht, 15, 38

Infopalet, 164
ingeschreven veelhoeken, 66
inhoudsopgave in Help-systeem, 25
Insert (dialoogvenster), 119
Intersection (objectmagneet), 78, 97
invoegen van blokken, 117, 119, 157
ISO-standaarden, 44, 120

J
JIS-standaarden, 44
JOIN (opdracht), 66

K
kettingbematingen (vervolgbematingen), 131, 144, 

166, 170
kleurafhankelijke plotstijltabellen (CTB), 153, 163
kleuren

aan lagen toewijzen, 7, 50, 59
kleurafhankelijke plotstijltabellen, 153, 163
op objecten toepassen, 59

knooppunten, 164
knopinfo, 76
koordelengte, opgeven voor bogen, 67
kopiëren

eigenschappen naar andere objecten, 108
meerdere kopieën van objecten, 91
objecten, 83, 90

kruiscursor, 164
Zie ook cursors

L
labels in werkvlak en papierkader, 128
lagen, 164

actieve laag, 50, 59
bematingen op, 136, 137
benoemen, 7
bevriezen, 51
eigenschappen bewerken, 58

eigenschappen en, 56, 58
kleurtoewijzingen, 7, 50, 59
laag Viewports, 157
Layer Properties Manager, 50, 51, 59, 150
lijntypetoewijzingen, 7, 61
overzicht, 7, 50
paneel Layers, 57
plotstijlen, 7
tekeningen ordenen met, 42, 50
verbergen of weergeven, 51, 60, 150
vergrendelen, 51
volgorde wijzigen, 50

Layer Properties Manager, 50, 51, 60, 150
Layers (paneel), 57
lay-outs, 146, 164

lijntypen in, 62
naar werkvlak schakelen, 49
overzicht, 5, 48
pagina-instellingen en, 154
plotten vanaf, 154
schaal en tekeneenheden, 3, 46
tekstgrootte en, 129
vensters, 146, 164
vergeleken met modellen, 48
weergaveschaal, 137

lay-outtabblad, 48
lay-outvensters, 146, 164
lege gebieden binnen arceringen (eilanden), 121, 

163
lettertypen, 128, 165
lijnbreedten (lijndikten), 7, 42, 63, 165
lijndikten, 7, 42, 63, 165
lijnen

afronden, 94
bematingsstijlen, 142
exacte lengte, 79
extensielijnen op bematingen, 134
haaklijnen, 140
hartlijnen, 139, 142
hoeken, 80
lijndikten, 7, 42, 63, 165
lijntypen. Zie lijntypen
loodrecht, 79
parallel, 64
polylijnen, 64
taps toelopen, 66
tekenen, 32, 64
verschuiven, 11
verwijslijnen, 134, 140

lijnlettertypen. Zie lijntypen
lijntypen, 165

algemene schaalfactor, 62
eigenschappen bewerken, 107
laagtoewijzingen, 7, 61
Linetype Manager, 61
objecten identificeren met, 42
overzicht, 60
schaal wijzigen, 61, 62
stijlen in sjablonen opslaan, 9
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lineaire bematingen, 131, 134, 144
lineaire maateenheden, 47
Linetype Manager, 61
Lineweight Settings (dialoogvenster), 63
linkermuisknop, 30
loodlijnen, 79

M
maateenheden, 3, 45, 46, 142

in bematingen, 142
sjabloonbestanden, 45
tekeneenheden, 3, 46

maatlijnen, 134
magneethoeken, 165
magneten

tekeningen maken met, 81
magnetische rasters, 165
matrices, 156, 165
mechanisch tekenen (sjabloonbestanden), 45
mechanische tekening (notatie van tekeneenheid),

102
meerdere kopieën van objecten, 91
menu's, 30, 31, 169
metrische eenheden (sjabloonbestanden in), 45
Midpoint (objectmagneet), 78
modellen en werkvlak, 5, 146, 165

bematen en, 137
formules voor tekstgrootte, 129
in- of uitzoomen, 157
informatie extraheren uit, 111
lijntypen in, 62
naar lay-outs schakelen, 49
naar papierkader schakelen, 150
notities en labels in, 128
schaal en tekeneenheden, 3, 46
tekening in werkvlak, 48
tekstgrootte in, 129
vensters, 165
vergeleken met lay-outs, 48

modelvensters, 165
modi, bepaald, 165
muizen, 30, 161
Multiline Text (paneel), 126

N
naast elkaar gerangschikte vensters (modelvensters),

165
navigatie

Help-systeem, weergave, 24
New Features Workshop, 23
New Page Setup (dialoogvenster), 155
Nonuniform Rational B-Spline-krommen 

(NURBS), 165
notities, in werkvlak en papierkader, 128

NURBS (Nonuniform Rational 
B-Spline-krommen), 165

O
Object Snap (menu), 31, 76, 166
Object Snap-modus, 166
objecteigenschappen, 166
objecten, 166

afronden, 94
arceerpatronen, 120
associatieve bematingen, 135
bijsnijdranden, 88
dupliceren, 90
eigenschappen, 56, 107, 166
eigenschappen bewerken, 57, 58
eigenschappen kopiëren, 108
grips, 109
kleuren, 59
kopieën verschuiven, 92
lijndikten, 63
lijntypen, 60
op lagen weergeven, 150
roteren, 93
selecteren, 86
spiegelen, 92
tekenen, 11
verplaatsen, 93
wissen, 87

objecten roteren, 93, 119
objectmagneetmarkeringen, 166
objectmagneten

actieve objectmagneten, 77
afstand, 72
AutoSnap-markeringen, 81
bematingen en, 136
magneethoeken, 165
magneetpunten doorlopen, 76
magnetisch raster, 165
markeringen, 166
nauwkeurigheid en, 13
overzicht, 72
Snap-modus, 166, 169
typen, 78
vervangen, 166

objectmagneten opheffen, 166
OFFSET (opdracht), 64, 83
omgekeerde tekst, 128
omkeren van objecten (objecten spiegelen), 83, 92, 

103
omschreven veelhoeken, 66
onderwerpen in Help-systeem, weergave, 24
ongedaan maken van bewerkingen, 34
ontdooien, 51, 166
oorsprongspunt, 102
oorsprongspunten, 74, 166
opdrachtaliassen, 31, 166
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opdrachten
aliassen, 31, 166
annuleren of ongedaan maken, 34
beëindigen, 34
beginnen op opdrachtregel, 31
bewerkingsopdrachten, 86
dynamische prompts, 32
herhalen, 34
hulp en informatie, 25
kiezen, 31
opties, 31

opdrachtregel, 31, 166
opdrachtvenster, 31, 166
openen

blokkenbibliotheken, 118
sjabloonbestanden, 45

opmaak
bematingen, 141
tekeneenheden, 46
Text Formatting, 126

oppervlakten
selectiegebieden, 86
vinden voor objecten, 100

opschonen, 166
opslaan

bestanden als DWF-bestanden, 156
bestanden in andere indelingen, 152

opsplitsen van objecten, 66, 166
opvraagopdrachten, 111
opvullingen, 120, 121, 166
opvullingen in effen kleur, 121, 166
Ortho-modus, 167
overeen laten komen van eigenschappen tussen 

objecten, 108
overlappende selectiegebieden, 86, 167
overlays, 7

P
Page Setup Manager, 154, 155
pagina-instellingen, 146, 154, 167
PAN (opdracht), 39
panelen

paneel Layers, 57
paneel Properties, 57

pannen, 15, 39, 167
papierformaat, 153, 156
papierkader, 5, 167

naar werkvlak schakelen, 49, 150
notities en labels in, 128
schaal wijzigen van lijntypen in, 62
tekstgrootte en, 129
vergeleken met werkvlak, 48

papinaformaat, 154
parallelle bematingen (basislijnbematingen), 131, 

144
parallelle lijnen, 64

passend maken van bematingen (opties), 142
PAT-bestanden, 120
PC3-bestanden, 152
Perpendicular (objectmagneet), 78
pijlpunten, 134, 142, 167
plines. Zie polylijnen
Plot (dialoogvenster), 154
Plot Style Manager, 153
plotschalen, 154
plotstijlen, 7, 146, 153, 167
plotstijltabellen (STB-bestanden), 153, 167, 169
Plotter Configuration Editor, 153
Plotter Manager, 152
plotterconfiguratiebestanden (PC3), 152
Plotters (map), 152
plotters en plotten

instellen, 154
pagina-instellingen, 154
plotstijlen, 146, 153
plotten vanaf lay-outs, 154
Plotter Configuration Editor, 153
plotters configureren, 152
schalen in werkvlak, 158
stuurprogramma-ondersteuning voor, 152
vensterranden afdrukken, 151
vooraf bekijken, 154

polaire tracking, 13, 79, 167
PolarSnap, 102, 167
polylijnen, 64, 167

afronden, 94
breedten, 66
grenzen markeren, 101
sluiten, 65
verdelen of verbinden, 66

poolcoördinaten, 74
poolmatrices, 167
poorten, 153
PostScript-bestanden, 152
printers

ondersteuning voor, 152
plotstijlen en plotstijltabellen, 153
Plotter Configuration Editor, 153
plotters selecteren, 154

procedurele Help, 25
prompts, 31, 32, 168
Properties (palet), 57, 107, 168
Properties (paneel), 57
punten, 168

absolute coördinaten, 74, 161
afstand of coördinaten berekenen, 111
AutoSnap-markeringen, 76, 81
coördinatenstelsels. Zie coördinaten en 

coördinatenstelsels
oorsprongspunt, 102
oorsprongspunten, 74, 166
opgeven voor bogen, 67
opgeven voor cirkels, 67
poolcoördinaten, 74
relatieve coördinaten, 75, 168
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Q
Quadrant (objectmagneet), 78, 104

R
raaklijnmethode om cirkels te tekenen, 67, 103
radiusbematingen, 131, 134, 144
rafelige weergave, 40
rafelige weergave opnieuw genereren, 40
rasterbestanden, 152
rastergrenzen, 72, 168
rasters, 168

afstand, 72
overzicht, 72
rastergrenzen, 72, 168
uit- en inschakelen, 72
weergeven of verbergen, 72

rechtermuisknop, 30
rechtermuisknop (acties), 30
rechthoeken, 65
referentietekeningen (xref's), 168
relatieve coördinaten, 75, 168
relatieve waarden, 74
revisiewolken, 19, 110
rode correcties in tekeningen, 110
rotatie tegen de klok in, 93

S
schaal van de tekening. Zie schalen en schaal wijzigen
schakelen

tussen modellen en lay-outs, 49
tussen pagina-instellingen, 154
tussen werkvlak en papierkader, 150

schalen en schaal wijzigen, 168
aanzichten in vensters, 5
arceerpatronen, 122
bematingen, 138
lijndikten en, 63
lijntypen, 61, 62
overzicht, 3
plotschalen, 154
tekeneenheden vergeleken met schaal, 3, 46
tekst, 129
weergaveschaal instellen, 137

scherpe hoeken op objecten, 94
schuin geplaatste tekst, 128
secundaire bematingsstijlen, 141
Select Template (dialoogvenster), 45
selecteren

deselecteren van objecten, 86
objecten, 86

selectiegebieden, 86
selectiegroepen, 86, 168
selectiekader, 81, 168

selectieknop, 30, 168
sjablonen, 168

DWT-bestanden, 163
ontwerpnormblad en, 9

sjabloonbestanden, 44
openen, 45
voorbeeldbestanden, 45

sjabloonbestanden voor tekeningen. Zie 
sjabloonbestanden

Snap en springen. Zie objectmagneten
Snap-modus, 169
snelkoppelingen

bewerken van tekst, 127
magneetpunten doorlopen, 76
toetsen (sneltoetsen), 169

snelmenu’s, 30, 31, 169
snijranden, 88
spiegelen van objecten, 83, 92, 103, 169
splines, 94, 163, 165
stand

pagina's, 154
tekst, 128

standaardwaarden
definitie, 169
eigenschapsinstellingen, 57

STANDARD (stijl), 128, 141
statusbalk, 169
STB-bestanden (benoemde plotstijltabellen), 153, 

169
stijlen

bematingsstijlen, 141, 162
ontwerpnormblad, 9
plotstijlen, 153
tekststijlen, 128

straal
afronden van objecten, 94
opgeven voor bogen, 67
opgeven voor cirkels, 67
opgeven voor veelhoeken, 66

structuurweergaven, 169
studieles (tekeningsjabloonbestanden), 45
stuurprogramma's, printer, 152
symbolen

definitie, 169
in bematingen, 142
Zie ook blokken

symbolenbibliotheken, 116, 169
DesignCenter Online, 119
openen, 118

systeemvariabelen, 169

T
tabblad Model, 48
Tangent (objectmagneet), 78
taps toelopende lijnen, 66
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technische tekening (notatie van tekeneenheden),
46

tekeneenheden, 3, 45, 46, 170
tekenen van objecten

afronden, 94
bogen, 67
cirkels, 33, 67
lijnen, 32, 64
overzicht, 11
polylijnen, 64
rechthoeken, 65
veelhoeken, 64

tekengebied, 170
tekeningbegrenzingen, 170
tekeningen analyseren, 111
tekeningen beginnen, 44
tekeningen en tekeningbestanden

coördinatenstelsels, 74
hele tekening weergeven, 38
in- of uitzoomen, 15
invoegen van blokken, 117
nieuwe tekeningen beginnen, 44
oefenen, 52
plotten, 154
rasters, 72
revisiewolken, 110
sjabloonbestanden, 44
Snap-modus, 72
weergave pannen, 39
wijzigen, 19

tekeningen wijzigen, 19, 110
tekeninggrenzen (rastergrenzen), 72, 168
tekst

annotaties, 134, 140
bematingstekst, 134, 142, 162
breedte van, 126
stijlen, 128, 170
stijlen in sjablonen opslaan, 9
teksteditor, 126
Text Formatting, 126
vensters en, 129
werkvlak en papierkader, 128

teksteditor, 126
tekststijlen, 9, 128, 170
Text Style (dialoogvenster), 128
titelblokken, 157
toetsen (sneltoetsen), 169
toetsenbord (sneltoetsen), 169
tolerantieopties voor bematingen, 142
toolpaletten, 170
trefwoorden in Help-systeem, 23
TRIM (opdracht), 83, 88
TrueType-lettertypen, 128

U
UCS (gebruikerscoördinatenstelsel), 170
UCS-pictogram, 170
uitgelijnde bematingen, 131, 144, 170
uitlijnen van tekst, 128
updaten van bematingen en verwijslijnen, 135

V
variabelen

bematingsvariabelen, 162
systeemvariabelen, 169

veelhoeken, 64
vensters, 146

aanzichten schalen, 5, 38
eigenschappen, 150
grips, 151
in- of uitzoomen, 157
instellingen wijzigen, 156
lagen weergeven in, 150
maken, 149
meerdere vensters, 156
overlappen, 151
overzicht, 5
overzicht van werkvlak en papierkader, 48
pannen, 39
plotranden, 151
schaal van lijntype in, 62
verkleinen/vergroten, 151
weergaveschaal, 137
wijzigen, 149
wissen, 150

vensterselectiegebieden, 86, 170
verbergen

lagen, 51, 60
Properties (palet), 57

verbinden van polylijnen, 66
verdelen van polylijnen, 66
vergrendelen

lagen, 51
vergroten van aanzicht in vensters. Zie in- of 

uitzoomen
verkleinen/vergroten

lijntypen, 62
tekstobjecten, 126
vensters, 151

verlengen van objecten, 88, 98
verplaatsen

bematingen, 143
blokken, 119
objecten, 93
objecten roteren, 93
tekst in bematingen, 135
weergave pannen, 39

verschuiven van objecten, 11, 64, 83, 92, 102
verticale bematingen, 131
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verticale uitlijning van tekst, 128
vervangende bematingsstijlen, 141
vervolgbematingen, 131, 144, 170
vervolgkeuzelijsten, 31
verwijderen van objecten, 87
verwijslijnen (bijschriften), 17, 134, 140
verwijslijnobjecten, 135
verwijzingen (blokreferenties), 170
vooraf bekijken van plotgebieden en -instellingen,

154

W
weergeven

eigenschappen, 57
lagen, 51
opdrachtopties, 32
Properties (palet), 57
rafelige weergave opnieuw genereren, 40
raster, 72
venstereigenschappen, 150
weergaveschaal, 137

wetenschappelijke tekening (notatie van 
tekeneenheden), 46

wielmuis, 30, 38, 40
wijzigen van tekeningen

Zie ook bewerken van objecten
Windows-printerstuurprogramma's, 152
wissen van lay-outvensters, 150

X
X- en Y-waarden, 74
xref's (referentietekeningen), 163, 171

Z
zichtbaarheid van lagen, 51
ZOOM (opdracht), 38
zwart-wit plotten, 155
zwevende vensters (lay-outvensters), 146, 164
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